Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN backup for ADSL , can work ?????

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname omisd01

!

logging queue-limit 100

enable password xxxxx

!

username all

ip subnet-zero

!

!

no ip domain lookup

!

!

isdn switch-type basic-net3

!

!

!

!

interface ATM0

no ip address

backup delay 10 120

backup interface BRI0

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5snap

protocol ppp dialer

dialer pool-member 1

!

bundle-enable

dsl operating-mode auto

!

interface BRI0

ip address negotiated

encapsulation ppp

no ip split-horizon

dialer string 1525

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-net3

isdn spid1 0

isdn spid2 0

ppp authentication pap callin

ppp pap sent-username isids01 password 7xxxxxx

ppp multilink

multilink load-threshold 1 either

!

interface FastEthernet0

ip address xxx.xxx.xxx.26 255.255.255.248

speed auto

!

interface Dialer0

ip address xxx.xxx.xxx.97 255.255.255.252

encapsulation ppp

dialer pool 1

ppp pap sent-username omisd01@tmnet password xxxxxx!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 BRI0 10

no ip http server

!

!

dialer-list 1 protocol ip permit

!

!

line con 0

password xxxx

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

!

end

Attache pls find the real configuration. Both ADSL and ISDN is tested working. My problems is when i use ISDN to backup ADSL i faced some issues, it can't work !!!!

Observation.

when the inter ATM 0 is down, the int dia 0 is always remain up and sproofing, that caused the floating stating route can not kickin and the isdn can not dial. any idea how to configure ISDN backup in this kind of situation.

3 REPLIES
New Member

Re: ISDN backup for ADSL , can work ?????

Looking at the config, you have IP negotiated for the links. Won't you need static addresses so that routing tables know when something has failed to bring up sec link?

Just a thought

Steve

New Member

Re: ISDN backup for ADSL , can work ?????

Hi,

Thanks for your reply, what am i observed the problem is that the ADSL interfaces i'm trying to back up don't typically go down when L3 connectiviity is lost, and the backup strategies Cisco have typically rely on that happening.

Conslusion

When configured PPPoA using PaP and CHAP for ADSL, the dial-bakup will not work.

Bronze

Re: ISDN backup for ADSL , can work ?????

I've seen many people come across this problem. Depending on your ISP's PPP implementation the router may install a host route to your ISP upon initial connection of your adsl circuit. If it does install a host route than you can use dialer watch for your back up. Don't use the backup commands in this scenario they won't work. If you do install a host route to your ISP set up dialer watch to watch that specific host route and add an additional static host route for that host and point it out your BRI 0 interface to trick the router into thinkin it will get to that host via the BRI 0 which will bring up the backup.

Heres a link on dialer watch.

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a008009455e.shtml

Feel free to e mail me directly if you have any questions.

Daniel

dbellazetin@hotmail.com

98
Views
0
Helpful
3
Replies