Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

isdn backup problem

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Dear friends,

The network is like this,the customer is connected through 256k serial lease line from our network and he is taken the isdn connection from different network.now the customer wants when our link (i.e serial ) goes down then it is autometically fallback to isdn.and that time our network is not come in the picture.that network has given him the pool of IP i.e 10.202.224.160/28 ,username is xxxxx and password is xxxx and the dialer string is xxxx.and that network end RAS IP is 10.202.221.13.here is my bri interface configuratio done in customer end router

interface bri0/0

ip address 10.202.224.161 255.255.255.240

dialer-group 1

encapsulation ppp

no keepalive

ppp multilink

ppp authentication pap

no ip route-cache

dialer string xxxx

no ndsp enable

isdn switch-type basic-net3

no mpls route-cache

exit

ip route 0.0.0.0 0.0.0.0 10.202.221.13 100

this is the only configuration i did in the router for isdn and im not able to dial i have confusion in routing.Pls help me regarding configuration as early as possible.

thanks with regards

santosh

6 REPLIES
VIP Purple

Re: isdn backup problem

Hello,

your default route has an administrative distance of 100, possibly there is another route with a lower value that takes precedence ? Can you post the output of the commands:

show ip route

debug dialer events

And also, if possible, the full config of both client side and central side router ?

Regards,

Georg

New Member

Re: isdn backup problem

I agree with Georg it is always best to see the entire configurations since so many parts of configurations interrelate.

Two comments:

1. Confirm that your configuration includes a global command "dialer-list 1 protocol ip permit" or something similar to define "interesting traffic" for DDR (dial on demand routing). Without that command, "dialer-group 1" points to a non-existent dialer-list, nothing is interesting, and a dialout will never occur.

2. When using the "dialer string xxxx" command instead of the "dialer map ..." command you should make your related static routes not show the next hop address, but instead simply reference the dialing interface name, as follows:

ip route 0.0.0.0 0.0.0.0 bri0/0 100 (see Georg's point about the 100 value in the command)

We assume 10.202.221.13 is found at the phone number xxxx in the dialer string. Using "dialer string" instead of "dialer map" is easier to configure, but remember that the router then has no clues about where to find the next hop address if it is in a different network than the dialing interface. For that reason we simply make our route statement refer to the dialing interface and not to the next hop.

I hope this is helpful information and is to the point,

Scott

New Member

Re: isdn backup problem

hi scallawa,

I am sending u the following configuration.The network is like this,the customer is connected through 256k lease line from our network and he is taken the isdn connection from different service provider.now the customer wants when our link (i.e serial ) goes down then it is autometically fallback to isdn.and that time our network is not come in the picture.that service provider has given him the pool of IP i.e 202.56.224.160/28 ,username is light and password is light and the dialer string is 1501.and that service provider end RAS IP is 202.56.221.13.

Pls help me in this as early as possible

xxxxx# sh run

Building Configuration...done

Current configuration: 1285 bytes

hostname GlobalBHP

user light password 0 light

enable password PUQURUSUTUUU encrypt

service password-encrypt

no service enhanced-secure

dialer-list 1 protocol ip permit

isdn switch-type basic-net3

interface loopback0

exit

interface fastethernet0

ip address 61.17.81.2 255.255.255.192

no ip redirects

no ip proxy-arp

exit

interface serial1/0

physical-layer sync

encapsulation hdlc

ip address 202.9.146.210 255.255.255.252

bandwidth 256

backup interface bri0/0

backup delay 10 30

exit

interface bri0/0

ip address 202.56.224.161 255.255.255.240

dialer pool-member 1

encapsulation ppp

no keepalive

ppp authentication pap

ppp pap sent-username light password light

bandwidth 56

no ip route-cache

dialer string 1503

no ndsp enable

isdn switch-type basic-net3

no mpls route-cache

exit

ip route 0.0.0.0 0.0.0.0 202.9.146.209

ip route 0.0.0.0 0.0.0.0 202.56.221.13 100

line vty 0 4

exec-timeout 0 0

password 7 TYQY\YZYUYUYTZ

login

exit

thanks with regards

santosh

New Member

Re: isdn backup problem

Santos,

Save your current configuration and then try this:

conf t

int bri0/0

no dialer pool-member 1

dialer-group 1

dialer string 1503

ppp authentication pap callin

exit

no ip route 0.0.0.0 0.0.0.0 202.56.221.13 100

ip route 0.0.0.0 0.0.0.0 bri0/0 100

end

I believe that will get things going again. Keep in mind you have configured a ten second delay ("backup delay 10 30") before the BRI is to come out of standby mode and begin looking for interesting traffic.

New Member

Re: isdn backup problem

Hi scallawa,

your configuration make it working.now everything is working normal.thanks for it.now you tell me one thing now only one channel is working means i am only getting 64kb speed i want my both channel to work.what i have to add in my configuration.

thanks

santosh

New Member

Re: isdn backup problem

Hi Santosh, glad to hear it is working.

To have the second channel come up add the command "dialer load-threshold 25 either" to the BRI interface. You can change the 25 to a number between 3 and 254 to adjust when the second channel comes up. A lower number will bring it up sooner. The number you use is divided by 255 to determine what fraction of the channels that are up should be exceeded before the next channel is brought up. Using 25 as the value makes the threshold about 10% (25/255). When the first channel traffic exceeds 10% the second channel will dial, come up, and begin to share the traffic load thereby providing a total bandwidth of 128kb.

You can also add "ppp multilink" to the BRI configuration. This works alongside "diale rload-threshold ". If the other end of the connection agrees to do multilink then the B channels (whether one or both are up) will be put into a multilink bundle which may or may not provide some benefit depending on your traffic. You can test both ways and decide whether to use multilink or not.

scallawa

92
Views
0
Helpful
6
Replies