Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Backup With Dialer Interface, and ip unnumbered

I am having some trouble connecting the two with isdn you will find floating interface routes for the isdn. when running debug I get on the WHSE-TO-MAIN Router "cause I =no route to network", and on MAIN-TO-WHSE i get "cause i = host rejected"

any thoughts here are the configs

----------------------------------------------------------------------------

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname MAIN-TO-WHSE

!

boot system flash 1:aaa1308.bin

enable password 7 091C175A4E0914071F

!

username WHSE-TO-MAIN password 7 055B5F5C76404D1C0D

!

!

!

!

memory-size iomem 15

ip subnet-zero

ip name-server 208.229.42.8

!

isdn switch-type basic-5ess

isdn voice-call-failure 0

!

!

!

interface FastEthernet0/0

ip address 172.19.0.1 255.255.0.0

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

description connected to WHSE-TO-MAIN

ip unnumbered FastEthernet0/1

no ip directed-broadcast

service-module t1 remote-alarm-enable

!

interface BRI0/0

description connected to WHSE-TO-MAIN

no ip address

no ip directed-broadcast

encapsulation ppp

shutdown

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-5ess

no cdp enable

ppp authentication pap

ppp multilink

!

interface FastEthernet0/1

description connected to Westbury

ip address 208.229.42.251 255.255.255.0

no ip directed-broadcast

no keepalive

duplex auto

speed auto

!

interface FastEthernet0/1.1

no ip directed-broadcast

!

interface Dialer1

description connected to WHSE-TO-MAIN

ip unnumbered FastEthernet0/1

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map ip 172.16.0.1 name WHSE-TO-MAIN broadcast 16092081481

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication pap

ppp multilink

!

router rip

version 2

network 208.229.42.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 208.229.42.11

ip route 146.132.226.206 255.255.255.255 208.229.42.52

ip route 161.173.192.0 255.255.240.0 208.229.42.52

ip route 165.247.40.0 255.255.255.0 208.229.42.11

ip route 172.16.0.0 255.255.0.0 BRI0/0 220

ip route 172.17.0.0 255.255.0.0 208.229.42.2

ip route 172.19.0.0 255.255.0.0 FastEthernet0/0

ip route 199.88.143.0 255.255.255.0 208.229.42.11

ip http server

!

dialer-list 1 protocol ip permit

-----------------------------------------------------------------------------------

version 12.0

service timestamps debug uptime

service timestamps log datetime

service password-encryption

!

hostname WHSE-TO-MAIN

!

boot system flash:c2600-i-mz.120-7.T

enable secret 5 $1$q2LT$ajPf9bLmDVmMNXAvX385G0

!

username MAIN-TO-WHSE password 7 055B5F5C76404D1C0D

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-5ess

isdn voice-call-failure 0

!

!

!

interface FastEthernet0/0

description connected to Robbinsville

ip address 172.16.0.1 255.255.0.0

no ip directed-broadcast

no keepalive

duplex auto

speed auto

!

interface Serial0/0

description connected to MAIN-TO-WHSE

ip unnumbered FastEthernet0/0

no ip directed-broadcast

no ip mroute-cache

service-module t1 remote-alarm-enable

!

interface BRI0/0

description connected to MAIN-TO-WHSE

no ip address

no ip directed-broadcast

encapsulation ppp

shutdown

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-5ess

no cdp enable

ppp authentication pap

ppp multilink

!

interface Dialer1

description connected to MAIN-TO-WHSE

ip unnumbered FastEthernet0/0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map ip 208.229.42.251 name MAIN-TO-WHSE broadcast 15167941521

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication pap

ppp multilink

!

router rip

version 2

network 172.16.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 208.229.42.251 permanent

ip route 63.77.35.0 255.255.255.0 208.229.42.11

ip route 172.17.0.0 255.255.0.0 208.229.42.2 permanent

ip route 198.80.14.0 255.255.255.0 208.229.42.11

ip route 199.88.143.0 255.255.255.0 208.229.42.11 permanent

ip route 208.229.42.0 255.255.255.0 BRI0/0 220

ip http server

!

logging 172.16.1.17

dialer-list 1 protocol ip permit

any help would be greatly appreciated

thanks in advance

3 REPLIES
Silver

Re: ISDN Backup With Dialer Interface, and ip unnumbered

Please change the routing command to point to the dialer 1 interface on both end.

For eg: ip route 172.16.0.0 255.255.0.0 BRI0/0 220

change to : ip route 172.16.0.0 255.255.0.0 dialer1 220

Thanks, Mak

Cisco Employee

Re: ISDN Backup With Dialer Interface, and ip unnumbered

Just to add, the other way to achive the same is to point the floating static route to the next hop with higher matric. So in your case the config will be

ip route 172.16.0.0 255.255.0.0 172.16.0.1 220

That will work because you have a dialer map (ina away is a static route) configured.

Pl. visit following url for more

http://www.cisco.com/warp/public/793/access_dial/hdlc_12497.html

New Member

Re: ISDN Backup With Dialer Interface, and ip unnumbered

Let me ask you a question im using both ip unnumbed on the S0 interface, and the Dialer1 interface. Is this going to cause any problems, as you can see in the diagram im not done configuring it for backup, right now im just trying to get it to work. I have some debug's to paste in im not sure if it means anything but take a look at these two lines i think i have a problem with the isdn lines. one being data only, and the other being voice and data.

--------------------------------------------------------------------------------------------------

MAIN-TO-WHSE -----------------208.229.24.0

0x08017D05040288901801832C0B3136303932303831343831

4d03h: SETUP pd = 8 callref = 0x7D

4d03h: Bearer Capability i = 0x8890

4d03h: Channel ID i = 0x83

4d03h: Keypad Facility i = '16092081481'

4d03h: ISDN BR0/0: RX <- RRr sapi = 0 tei = 72 nr = 27

4d03h: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 72 ns = 39 nr = 27 i = 0x0801FD02180189

4d03h: CALL_PROC pd = 8 callref = 0xFD

4d03h: Channel ID i = 0x89

4d03h: ISDN BR0/0: TX -> RRr sapi = 0 tei = 72 nr = 40

4d03h: ISDN BR0/0: received HOST_PROCEEDING call_id 0x842C

4d03h: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 72 ns = 40 nr = 27 i = 0x0801FD45080282A2340103

4d03h: DISCONNECT pd = 8 callref = 0xFD

4d03h: Cause i = 0x82A2 - No channel available

4d03h: Signal i = 0x03 - Network congestion tone on

4d03h: ISDN BR0/0: TX -> RRr sapi = 0 tei = 72 nr = 41

4d03h: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x842C

4d03h: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

----------------------------------------------------------------------------------------------------------

WHSE-TO-MAIN ----------------------172.16.0.0

0x08017105040288901801832C0B3135313637393431353231

45w3d: SETUP pd = 8 callref = 0x71

45w3d: Bearer Capability i = 0x8890

45w3d: Channel ID i = 0x83

45w3d: Keypad Facility i = '15167941521'

45w3d: ISDN BR0/0: RX <- RRr sapi = 0 tei = 69 nr = 3

45w3d: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 69 ns = 6 nr = 3 i = 0x08007B3201C3

45w3d: INFORMATION pd = 8 callref = (null)

Info Request i = 0xC3

45w3d: ISDN BR0/0: TX -> RRr sapi = 0 tei = 69 nr = 7

45w3d: ISDN BR0/0: Incoming call id = 0x7D5, dsl 0

45w3d: ISDN BR0/0: received HOST_INFORMATION call_id 0x0

45w3d: ISDN BR0/0: RX <- INFOc sapi = 0 tei = 69 ns = 7 nr = 3 i = 0x0801F15A08028283952A2D809E143531362D3739342D3135323120202020202020209E14436865636B206E756D6265722C2072656469616C

45w3d: RELEASE_COMP pd = 8 callref = 0xF1

45w3d: Cause i = 0x8283 - No route to destination

45w3d: Locking Shift to Codeset 5

45w3d: Codeset 5 IE 0x2A i = 0x809E14, '516-794-1521', 0x20202020202020209E14, 'Check', 0x20, 'number,', 0x20, 'redial'

45w3d: ISDN BR0/0: TX -> RRr sapi = 0 tei = 69 nr = 8

45w3d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x94C5

45w3d: ISDN BR0/0: Error: Unfound B-channel on Disconnect_Ack - callid 0x94C5

45w3d: ISDN BR0/0: HOST_DISC_ACK Voice cid 0x9

I do not have all of the details, nor am i an expert on isdn line types but from the bottom two erros it appears that the both of the routers are talking but the isdn line type's are diffrent.

161
Views
0
Helpful
3
Replies