Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN BRI 2nd B channel won't stay up

I have a 3620 router with an 8 port isdn BRI module in it. The purpose of this router is to have ISDN modem users dial-in so it isn't a Cisco to Cisco connection (3com, U.S. Robotics, etc.). The U.S. Robotics isdn modem doesn't work at all but thats another problem that I'll have to look into. The 3com and EICON Diva ISDN modem both connect with one channel.

Right now, I'm more concerned with getting the 2nd B channel to stay connected. I dial the first number in the list and it connects no problem. When I pass the threshold (which is now set to 1) the 2nd B channel tries to connect but gets rejected (call rejected). I believe that I have the correct commands in the config but it never stays up. After running debug, it shows a rejected call to the B channel when the load goes above the threshold. The call was initiated on an NT 4.0 workstation with a 3com isdn modem. As you can see in the debug, BRI1/6:2 is trying to be brought up and this was due to a traffic increase (dialer load-threshold 1 either). The call is rejected and BRI1/6:2 goes back to a down state. The SPID1 in BRI1/6 (BRI1/6:1) is the number that is initially dialed.

All I want is for a second B channel to come up when it reaches the dialer threshold.

Any ideas? Do I have this setup incorrectly? I have the same thing working on a Cisco 804 router but it is a router to router connection.

Config and debug are below.

RUNNING-CONFIG

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ISDNROUTER

!

logging rate-limit console 10 except errors

aaa new-model

aaa authentication login default group radius

aaa authentication ppp default group radius

aaa accounting network default start-stop group radius

!

ip subnet-zero

!

!

no ip finger

ip name-server xxx.xxx.xxx.xxx

!

isdn switch-type basic-ni

!

!

!

interface Ethernet0/0

description connected to EthernetLAN

ip address xxx.xxx.xxx.xxx 255.255.255.0

ip helper-address xxx.xxx.xxx.xxx

no keepalive

full-duplex

!

interface BRI1/0

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############1

isdn spid2 #############2

no cdp enable

!

interface BRI1/1

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############3

isdn spid2 #############4

no cdp enable

!

interface BRI1/2

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############5

isdn spid2 #############6

no cdp enable

!

interface BRI1/3

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############7

isdn spid2 #############8

no cdp enable

!

interface BRI1/4

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############9

isdn spid2 ############10

no cdp enable

!

interface BRI1/5

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 #############11

isdn spid2 #############12

no cdp enable

!

interface BRI1/6

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 ############13

isdn spid2 ############14

no cdp enable

!

interface BRI1/7

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 ############15

isdn spid2 ############16

no cdp enable

!

interface Dialer1

description connected to Dial-inPCs(ISDN)

ip unnumbered Ethernet0/0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 3600 either

dialer load-threshold 1 either

dialer-group 1

peer default ip address pool DPOOL

no cdp enable

ppp authentication pap chap

ppp multilink

!

ip local pool DPOOL xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

ip default-gateway xxx.xxx.xxx.xxx

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

radius-server retransmit 3

radius-server key 7 1234567890

!

end

!

DEBUG

1w2d: ISDN BR1/6: Event: Accepting the call id 0x109

1w2d: %LINK-3-UPDOWN: Interface BRI1/6:2, changed state to up

FRSISDN02#

1w2d: ISDN BR1/6: TX -> INFOc sapi = 0 tei = 80 ns = 65 nr = 9 i = 0x080199

0218018A

1w2d: CALL_PROC pd = 8 callref = 0x99

1w2d: Channel ID i = 0x8A

1w2d: ISDN BR1/6: RX <- RRr sapi = 0 tei = 80 nr = 66

1w2d: ISDN BR1/6: RX <- INFOc sapi = 0 tei = 80 ns = 9 nr = 66 i = 0x080119

5A08028295

1w2d: RELEASE_COMP pd = 8 callref = 0x19

1w2d: Cause i = 0x8295 - Call rejected

1w2d: ISDN BR1/6: TX -> RRr sapi = 0 tei = 80 nr = 10

FRSISDN02#

1w2d: %LINK-3-UPDOWN: Interface BRI1/6:2, changed state to down

FRSISDN02#

1w2d: ISDN BR1/6: TX -> RRp sapi = 0 tei = 89 nr = 72

1w2d: ISDN BR1/6: RX <- RRf sapi = 0 tei = 89 nr = 1

FRSISDN02#

1w2d: ISDN BR1/6: RX <- UI sapi = 0 tei = 127 i = 0x08011A050402889018018A3401

407008C136373230353934952A1A808001038C0E466F727761726465642D6275737980010380013C

1 REPLY
Bronze

Re: ISDN BRI 2nd B channel won't stay up

The call is being cleared by the caller, not the cisco:

1w2d: ISDN BR1/6: Event: Accepting the call id 0x109

1w2d: ISDN BR1/6: TX -> INFOc sapi = 0 tei = 80 ns = 65 nr = 9 i = 0x0801990218018A

1w2d: CALL_PROC pd = 8 callref = 0x99

1w2d: ISDN BR1/6: RX <- INFOc sapi = 0 tei = 80 ns = 9 nr = 66 i = 0x0801195A08028295

1w2d: RELEASE_COMP pd = 8 callref = 0x19

1w2d: Cause i = 0x8295 - Call rejected

Not sure why the carrier or remote is rejecting the call.

I would suggest you increase the load-threshold to 3 (not related to your current problem, but it may prevent future toggling) and that you enable MSEC timestamps for debugging purposes:

serv time log da ms

serv time deb da ms

I would stick with "debug isdn q931" when troubleshooting this, too. In general, to troubleshoot problems with the second channel connecting I would pay attention to:

show ppp mult ! confirm existing bundles

debug isdn q931 ! have a look at what ISDN is doing

debug ppp neg ! If the ISDN call is being accepted, see what PPP is doing

214
Views
0
Helpful
1
Replies