Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

isdn bri doesn't call

Hello, I am a beginner in the networking and have to configure a router 2503 to do a call to a windows 2000 RRAS. The windows calls but does not authenticates chap, but now isn't a problem. On the other hand the router does not even begin the call. Below I attach you the configuration. Can someone help me?

Thank you.

Current configuration:

!

version 11.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname Barcelona

!

boot system flash

enable secret XXXXX

!

username xxxxx password xxxxx

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

!

interface Ethernet0

shutdown

!

interface Serial0

shutdown

!

interface BRI0

description Connect to Windows 2000

ip address 10.0.2.1 255.255.255.0

encapsulation ppp

dialer idle-timeout 7200

dialer map ip 10.0.2.2 name cisco 999000999

dialer load-threshold 1 either

dialer-group 1

ppp authentication chap

!

ip route 10.0.2.2 255.255.255.255 BRI0

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

line vty 0 4

login

!

end

3 REPLIES
Silver

Re: isdn bri doesn't call

How are you trying to initiate a call? What does "sh isdn status" indicate?

The following debugs will be useful when trying to ping 10.0.2.2. (If you are tying to initiate a call to any other ip address across, need to add appropriate routing command. "ip route x.x.x.x z.z.z.z 10.0.2.2)

deb dialer / deb isdn q931/ deb ppp nego.

http://www.cisco.com/warp/public/701/23.html

Thanks, Mak.

New Member

Re: isdn bri doesn't call

Hello, thank you very much, now already calls but does not establishes the authentication chap. The communication establishes between a router 2503 and windows 2000 RRAS. The W2K pc is called rrasw2k and rras has name cisco and password cisco. The router is called bcn. Down below there is the configuration. The debug show this:

BR0:1 PPP: Phase is AUTHENTICATING, by both

BR0:1 CHAP: O CHALLENGE id 9 len 24 from "bcn"

BR0:1 CHAP: I CHALLENGE id 0 len 34 from "rrasw2k"

BR0:1 CHAP: Username rrasw2k not found

BR0:1 CHAP: Unable to authenticate for peer

BR0:1 PPP: Phase is TERMINATING

BR0:1 LCP: O TERMREQ [Open] id 21 len 4

BR0:1 LCP: I TERMACK [TERMsent] id 21 len 4

BR0:1 LCP: State is Closed

BR0:1 PPP: Phase is DOWN

BR0:1 PPP: Phase is ESTABLISHING, Passive Open

BR0:1 LCP: State is Listen

BR0:1 LCP: State is Closed

BR0:1 PPP: Phase is DOWN

---------------------------------

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname bcn

!

enable secret 5 XXXXXXXX

!

username xxxxx password xxxxx

isdn switch-type basic-net3

!

interface Ethernet0

no ip address

shutdown

!

interface BRI0

ip address 10.0.2.2 255.255.255.0

encapsulation ppp

dialer idle-timeout 7200

dialer map ip 10.0.2.2 939999999

dialer load-threshold 1 either

dialer-group 1

ppp authentication chap

!

no ip classless

ip route 10.0.2.2 255.255.255.255 BRI0

dialer-list 1 protocol ip permit

!

end

Can anyone help me?

Thank you.

Marti.

Bronze

Re: isdn bri doesn't call

Marti,

You need to add the remote host rrasw2k in your router's configuration, along with the proper password. This host does not have the name "cisco" because the CHAP challenge in your debugging comes from the device named rrasw2k. Your config needs to have this username/password.

Good Luck!

Mark

85
Views
0
Helpful
3
Replies
CreatePlease login to create content