Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ISDN BRI Error: Cause i=0x82EF - Protocol error; unspecified

I'm receiving the following error message on two Cisco 1760 routers that are attempting to communicate with each other over an ISDN BRI link: "Cause i = 0x82EF - Protocol error; unspecified."

I have appended configuration files and a debug session using pings below w/ more information.

I have talked with the phone company:

* all circuit tests pass.

* the technician could establish sessions w/ each of my routers over their ISDN BRI channels.

The "sh isdn status" command gives the following:

Global ISDN Switchtype = basic-ni

ISDN BRI0/0 interface

dsl 0, interface ISDN Switchtype = basic-ni

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 97, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI = 98, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI 97, ces = 1, state = 8(established)

spid1 configured, spid1 sent, spid1 valid

Endpoint ID Info: epsf = 0, usid = 70, tid = 0

TEI 98, ces = 2, state = 8(established)

spid2 configured, spid2 sent, spid2 valid

Endpoint ID Info: epsf = 0, usid = 71, tid = 0

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Number of L2 Discards = 6, L2 Session ID = 41

Any ideas?

*** BEGIN CONFIG AND DEBUG INFORMATION ***

Side 1:

Cisco 1760 router

ISDN BRI U interface

IOS 12.2(11)T8

SPID1: 101123000000

SPID2: 101123111100

Side 2:

Cisco 1760 router

ISDN BRI U interface

IOS 12.2(11)T8

SPID1: 10112322220101

SPID2: 10112333330101

*****************************************************

Side 1 router startup-config:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ...

!

ip subnet-zero

ip name-server ...

!

!

isdn switch-type basic-ni

!

!

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

ip address 10.0.0.8 255.255.255.0

speed 100

full-duplex

fair-queue

!

interface BRI0/0

description ISDN Circuit

ip address 10.68.0.1 255.255.0.0

encapsulation ppp

dialer string 1232222 ; Note: I've also used a dialer map command w/ the same result.

dialer load-threshold 127 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 101123000000 1230000

isdn spid2 101123111100 1231111

compress predictor

ppp multilink

!

router rip

version 2

redistribute static

passive-interface BRI0/0

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.254

ip route 10.69.0.0 255.255.0.0 10.68.0.2

ip http server

!

!

access-list 121 permit ip any any

access-list 121 permit icmp any any

access-list 121 permit tcp any any

access-list 121 permit udp any any

dialer-list 1 protocol ip list 121

!

*****************************************************

Side 2 router startup-config:

!

version 12.2

service password-encryption

!

ip subnet-zero

!

isdn switch-type basic-ni

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

description Uplink to ...

ip address 10.69.0.1 255.255.0.0

speed 10

full-duplex

fair-queue

!

interface BRI0/0

description ISDN Circuit

ip address 10.68.0.2 255.255.0.0

encapsulation ppp

dialer string 1230000

dialer load-threshold 127 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 10112322220101 1232222

isdn spid2 10112333330101 1233333

compress predictor

ppp multilink

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.68.0.1

ip http server

!

!

access-list 121 permit ip any any

access-list 121 permit icmp any any

access-list 121 permit tcp any any

access-list 121 permit udp any any

dialer-list 1 protocol ip list 121

!

*****************************************************

Debug session: Side 1 router calling Side 2 router:

clear dialer

...#sh dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

1232222 0 0 never - Default

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

BRI0/0:2 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

...#sh debug

Dial on demand:

Dial on demand events debugging is on

The following ISDN debugs are enabled on all DSLs:

debug isdn error is ON.

debug isdn q931 is ON.

...#

Oct 7 16:09:16.874: BR0/0 DDR: place call

Oct 7 16:09:16.874: BR0/0 DDR: Dialing cause ip (s=10.0.0.1, d=10.69.88.77)

Oct 7 16:09:16.874: BR0/0 DDR: Attempting to dial 1232222

Oct 7 16:09:16.878: ISDN BR0/0 Q931: TX -> SETUP pd = 8 callref = 0x29

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '1232222'

Oct 7 16:09:17.086: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xA9

Channel ID i = 0x89

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808807, '1232222', 0x80010D800114800114800114

...#

Oct 7 16:09:17.118: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xA9

Cause i = 0x82EF - Protocol error; unspecified

Oct 7 16:09:17.122: BRI0/0: wait for isdn carrier timeout, call id=0x8029

Oct 7 16:09:17.126: ISDN BR0/0 Q931: TX -> RELEASE pd = 8 callref = 0x29

Oct 7 16:09:17.218: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xA9

Oct 7 16:09:18.204: BR0/0 DDR: place call

Oct 7 16:09:18.204: BR0/0 DDR: Dialing cause ip (s=10.0.0.1, d=10.69.88.77)

Oct 7 16:09:18.204: BR0/0 DDR: Attempting to dial 1232222

Oct 7 16:09:18.208: ISDN BR0/0 Q931: TX -> SETUP pd = 8 callref = 0x2A

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '1232222'

Oct 7 16:09:18.388: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xAA

Channel ID i = 0x89

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808807, '1232222', 0x80010D800114800114800114

Oct 7 16:09:18.420: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xAA

Cause i = 0x82EF - Protocol error; unspecified

Oct 7 16:09:18.424: BRI0/0: wait for isdn carrier timeout, call id=0x802A

Oct 7 16:09:18.424: ISDN BR0/0 Q931: TX -> RELEASE pd = 8 callref = 0x2A

Oct 7 16:09:18.516: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xAA

Oct 7 16:09:19.454: BR0/0 DDR: place call

Oct 7 16:09:19.454: BR0/0 DDR: Dialing cause ip (s=10.0.0.1, d=10.69.88.77)

Oct 7 16:09:19.454: BR0/0 DDR: Attempting to dial 1232222

Oct 7 16:09:19.458: ISDN BR0/0 Q931: TX -> SETUP pd = 8 callref = 0x2B

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '1232222'

Oct 7 16:09:19.634: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xAB

Channel ID i = 0x89

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808807, '1232222', 0x80010D800114800114800114

Oct 7 16:09:19.670: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xAB

Cause i = 0x82EF - Protocol error; unspecified

Oct 7 16:09:19.674: BRI0/0: wait for isdn carrier timeout, call id=0x802B

Oct 7 16:09:19.678: ISDN BR0/0 Q931: TX -> RELEASE pd = 8 callref = 0x2B

Oct 7 16:09:19.770: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xAB

Oct 7 16:09:20.560: BR0/0 DDR: place call

Oct 7 16:09:20.560: BR0/0 DDR: Dialing cause ip (s=10.0.0.1, d=10.69.88.77)

Oct 7 16:09:20.560: BR0/0 DDR: Attempting to dial 1232222

Oct 7 16:09:20.564: ISDN BR0/0 Q931: TX -> SETUP pd = 8 callref = 0x2C

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '1232222'

Oct 7 16:09:20.736: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xAC

Channel ID i = 0x89

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808807, '1232222', 0x80010D800114800114800114

Oct 7 16:09:20.772: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xAC

Cause i = 0x82EF - Protocol error; unspecified

Oct 7 16:09:20.776: BRI0/0: wait for isdn carrier timeout, call id=0x802C

Oct 7 16:09:20.780: ISDN BR0/0 Q931: TX -> RELEASE pd = 8 callref = 0x2C

Oct 7 16:09:20.872: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xAC

Oct 7 16:09:21.617: BR0/0 DDR: place call

Oct 7 16:09:21.617: BR0/0 DDR: Dialing cause ip (s=10.0.0.1, d=10.69.88.77)

Oct 7 16:09:21.617: BR0/0 DDR: Attempting to dial 1232222

Oct 7 16:09:21.621: ISDN BR0/0 Q931: TX -> SETUP pd = 8 callref = 0x2D

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '1232222'

Oct 7 16:09:21.786: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xAD

Channel ID i = 0x89

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808807, '1232222', 0x80010D800114800114800114

Oct 7 16:09:21.818: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xAD

Cause i = 0x82EF - Protocol error; unspecified

Oct 7 16:09:21.822: BRI0/0: wait for isdn carrier timeout, call id=0x802D

Oct 7 16:09:21.826: ISDN BR0/0 Q931: TX -> RELEASE pd = 8 callref = 0x2D

Oct 7 16:09:21.922: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xAD

3 REPLIES
Bronze

Re: ISDN BRI Error: Cause i=0x82EF - Protocol error; unspecified

Hi Larry,

don't know if it is of much help, but this url has an explanation of disconnect cause codes:

http://www.cisco.com/en/US/customer/tech/tk801/tk379/technologies_tech_note09186a008012e95f.shtml

The 82 in 0x82EF seems to indicate that the local telco is sending the disconnect because of an "unspecified" protocol error.

Do you have debug info for the sessions that the telco was able to establish? You could then compare your setup parameters with theirs. E.g. do they support 64k or should you set your speed to 56k etc.

hth

Herbert

New Member

Re: ISDN BRI Error: Cause i=0x82EF - Protocol error; unspecified

Hello:

Yes, everytime you receive a 82 in the cause ID that means a Telco isuue, talk to them & explain them that something is wrong in their side.

New Member

Re: ISDN BRI Error: Cause i=0x82EF - Protocol error; unspecified

Gentlemen: Thank you for your responses. I did have many telephone chats with various SBC technicians; but to no avail. I was told that if I use an 11-digit dialer number a la 12121230000 I would get a 64K connection instead of a 56K connection, which eventually proved to be correct. However, instead of a proper connection, the error message changed: "Cause i = 0x82C1 - Bearer capability not implemented." This caused more frustration for me and head scratching from SBC; even to the point of them trying to trace the call and see where the problem started. As you both mentioned, the 82 in the cause code indicated the local ISDN router.

To make a long story short, after going through my routers' settings with a fine tooth comb and finding nothing apparently wrong, I decided to prepend the dialer string with a "9" to see what would happen. It worked! Apparently my ISDN lines do not connect directly to an ISDN switch but through a PBX and then to an ISDN switch. The SBC technicians apparently did not know or realize this fundamental fact.

1228
Views
0
Helpful
3
Replies
CreatePlease to create content