Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN BRI Layer 2 shut down after 20 days exactly, T203?

I've got a C3640 off site providing remote dialin access for users over a BRI interface.

It appears that if users do not access this service for 20 days the interface falls into a 'Layer 2 : TEI Assigned' state, thus requiring a site visit and a physical reset of the interface before normal access can be restored.

I thought it may have been something to do with ISDN Timer T203 as this seemed to be set to exactly 20 days, halving the value caused it to shut down in ten days. I've tried setting the value to 0 but it seems to revert back to 20 days. The highest value possible also has the same effect.

I'm a bit stumped as to which way to proceed from here, any suggestions would be greatly welcomed.

2 REPLIES
Bronze

Re: ISDN BRI Layer 2 shut down after 20 days exactly, T203?

I am not sure what command are you using it to change this value. I see that this timer is being talked about more with respect to frame-relay lapf. You could probably check if this is a problem with the hardware or software that you are using. If there is no other way to fix this or access the router, how about getting console or AUX access to the router by dialing up via a modem and then resetting the interface on the router through the CLI.

New Member

Re: ISDN BRI Layer 2 shut down after 20 days exactly, T203?

Thanks for your reply, I've posted the current config to see if this will shed anymore light on the problem. The command I suspect is causing the problem appears under the serial interface.

version 12.2

service timestamps debug uptime

service timestamps log datetime msec localtime

service password-encryption

!

hostname *

!

boot system flash c3640-jk9o3s-mz.122-7c.bin

logging buffered 4096 debugging

enable secret *

!

username * password *

!

memory-size iomem 40

ip subnet-zero

no ip source-route

!

!

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

ip address-pool local

!

isdn switch-type primary-net5

call rsvp-sync

!

!

!

!

!

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-16

!

!

!

interface FastEthernet0/0

ip address *

no ip route-cache

no ip mroute-cache

speed 100

half-duplex

!

interface Serial1/0:15

ip unnumbered FastEthernet0/0

ip nat inside

encapsulation ppp

ip mroute-cache

dialer rotary-group 1

isdn switch-type primary-net5

isdn overlap-receiving

isdn T203 30000

no cdp enable

!

interface Group-Async1

physical-layer async

ip unnumbered FastEthernet0/0

encapsulation ppp

timeout absolute 60 0

dialer in-band

dialer idle-timeout 900

async mode dedicated

peer default ip address pool Dialup

no fair-queue

ppp callback accept

ppp authentication chap pap

ppp multilink

!

interface Dialer1

ip unnumbered FastEthernet0/0

ip nat inside

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer load-threshold 100 outbound

dialer-group 1

autodetect encapsulation ppp

peer default ip address pool Dialup

ppp callback accept

ppp authentication chap pap

ppp multilink

!

ip local pool Dialup *

ip default-gateway *

ip nat inside source list 1 interface FastEthernet0/0 overload

no ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route * 255.255.255.0 Dialer1

ip route * 255.255.255.0 Dialer1

no ip http server

ip pim bidir-enable

!

access-list 1 permit *

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

password *

logging synchronous

login

line aux 0

line vty 0 4

password *

login

!

end

To re-itterate, this router shuts down ISDN layer 2 if it not used for a period greater than 20 days.

Any advice would be greatly appreciated, I'm pulling my hair out over this fault.

264
Views
0
Helpful
2
Replies