Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN Callback with Cisco 2611

I must configure our Cisco 2611 Router for Remote Access.

One configuration is for travelling user , they must only dial-in access.

For this i have a solution and this works.

This is the current configuration:

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname styx

!

enable secret 5 $1$/PMt$6T5NUOm3ID05qKK3FrXiU/

!

username jehe password 0 ??

username schorge password 0 ??

username wanieck password 0 ??

ip subnet-zero

isdn switch-type primary-net5

!

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

!

!

interface Ethernet0/0

ip address 172.22.44.91 255.255.0.0

no ip directed-broadcast

!

interface Ethernet0/1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial1/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

shutdown

dialer pool-member 1

isdn switch-type primary-net5

no fair-queue

ppp authentication pap

!

interface Dialer1

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

dialer remote-name jehe

dialer pool 1

dialer-group 1

peer default ip address pool dialin_pool

no cdp enable

!

ip local pool dialin_pool 172.22.44.100 172.22.44.110

ip classless

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

line vty 0 4

password ??

login

!

end

How i configure a ISDN Callback for our home user?

Please help me.

Thank you and best regards

Claus-Dieter Schorge

1 REPLY
Cisco Employee

Re: ISDN Callback with Cisco 2611

Instead of using dialer profile, you can use "dialer rotary-group" config with "ppp callback accept" command..So if user dialsin and negotiate callback duing LCP, he will be called back..Those who dosen't negotiate callback, will be given ip address from pool and logged in.

So the config will look like this

interface Serial1/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

shutdown

dialer rotary-group 1

isdn switch-type primary-net5

no fair-queue

ppp authentication pap

!

interface Dialer1

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

dialer remote-name jehe

dialer-group 1

ppp callback accept

peer default ip address pool dialin_pool

no cdp enable

Thanks...Tejal

168
Views
0
Helpful
1
Replies
CreatePlease to create content