Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN Callback with PPP multilink

Using an 800 router dialing into a 3640, I need to implement callback and PPP multilink. Each part works fine on its own. When implemented together, the first channel is raised, then dropped and a callback is succesful. The next channel is then brought up, but doesnt get called back. The result is one call out and one call in. Routing all works fine, however billing is being done centrally, so both calls need to be from the 3640 out. This is the relevant config from both routers. Any help would be greatfully appreciated.

hostname remote

!

enable password (removed)

!

username sara-ldn password 0 password

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

!

interface Ethernet0

ip address 10.6.72.1 255.255.255.252

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp callback request

ppp multilink

multilink load-threshold 1 either

!

interface Dialer0

ip address 10.6.64.2 255.255.248.0

encapsulation ppp

dialer pool 1

dialer remote-name sara-ldn

dialer string (removed)

dialer-group 1

ppp callback request

ppp authentication chap

multilink load-threshold 1 either

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.6.40.0 255.255.248.0 Dialer0

ip http server

!

!

dialer-list 1 protocol ip permit

!

!

line con 0

stopbits 1

line vty 0 4

password cisco

login

!

no rcapi server

!

!

end

hostname "sara-ldn"

!

username remote password 0 password

ip subnet-zero

!

!

ip domain-name sarasin

!

!

isdn switch-type primary-net5

call rsvp-sync

!

!

!

!

!

!

controller E1 1/0

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 10.6.47.1 255.255.248.0

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

ppp callback accept

ppp authentication chap

!

interface Dialer0

ip address 10.6.64.1 255.255.248.0

encapsulation ppp

dialer in-band

dialer enable-timeout 2

dialer map ip 10.6.64.2 name remote class dial1 removed

dialer-group 1

ppp callback accept

ppp authentication chap

!

ip classless

ip route 10.6.48.0 255.255.248.0 10.6.2.2

ip route 10.6.72.0 255.255.255.252 10.6.64.2

no ip http server

!

!

map-class dialer dial1

dialer callback-server username

dialer-list 1 protocol ip permit

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

Kind regards

Will

1 REPLY
Bronze

Re: ISDN Callback with PPP multilink

There are a couple bugs out there that deal with ppp callback not working with multilink. Take a look through these two bugs:

CSCdm29261 - PPP Callback doesnt work with Multilink

CSCdk62941 - PPP callback does not callback

Be sure that you are running an IOS that is after the first fixed-in version.

109
Views
0
Helpful
1
Replies
CreatePlease to create content