Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

isdn come up too soon (dialer watch)

Hi all,

two router (hsrp ) with two line connect to center (different metric,through different router),one of them have a isdn bri use dialer watch as backup .

the problem is when one of the primary link down

,even anther line is up, the isdn come up quickly.

we use the ios version is 12.0 . who can give me

some advices.

BRs

biao shen

3 REPLIES
Bronze

Re: isdn come up too soon (dialer watch)

Hi biao shen,

can you please post the config of the 2 routers, so we can see how ecatly you've implemented this and what could be wrong.

regards

Herbert

New Member

Re: isdn come up too soon (dialer watch)

Hello Herbert,

ethernet WAN ethernet

172.16.1.0/24| branch1

| center |172.16.16.0/24 172.16.1.0/24| branch2

configuration:

hostname branch1

username center password cisco

interface f0/0

ip address 172.16.1.2 255.255.255.0

standby ip 172.16.1.1

standby preempt

interface s0/0

ip address 172.16.2.1 255.255.255.0

interface bri0/0

ip address 192.168.1.2 255.255.255.252

encap ppp

ppp authentication chap

dialer-group 1

dialer watch-group 1

dialer watch-disable 30

dialer map ip 192.168.1.1 name center broadcast xxxxx

dialer map ip 172.16.16.0 name center broadcast xxxxx

isdn switch-type basic-net3

dialer-list 1 protocol ip list 100

dialer watch-list 1 ip 172.16.16.0 255.255.255.0

access-list 100 remark for dialer

access-list 100 deny eigrp any any

access-list 100 permit ip any any

hostname branch2

interface f0/0

ip address 172.16.1.3 255.255.255.0

standby ip 172.16.1.1

standby priority 95

interface s0/0

ip address 172.16.3.1 255.255.255.0

hostname center

username branch1 password cisco

interface f0/0

ip address 172.16.16.1 255.255.255.0

interface bri0/0

ip address 192.168.1.1 255.255.255.0

isdn switch-type basic-net3

encap ppp

ppp authentication chap

dialer-group 1

dialer-list 1 protocol ip permit

BRs

Biao

Bronze

Re: isdn come up too soon (dialer watch)

Biao,

first of all I would ebable HSRP tracking on branch1, like this:

int f0/0

standby track ser0/0 10

This will lower the hsrp priority to 90 when s0/0 is down, so branch2 will become the active hsrp router.

However this will not prevent your dialer-watch to activate the BRI. Since the dialer-watch will only do this when the router has no route to 172.16.16.0/24, you need to check why the router does not have this route when the primary link fails.

From the partial config you posted, it is not clear how you do the routing; is it static, or do you run a routing protocol?

I don't think there is a solution using static routing, since a (floating) static route via branch2 will cause the dialer-watch to never become active.

So you'll need to run a routing protocol between the 3 routers. When the primary link then fails, branch1 will still receive its routing info via branch2. Only when branch2 (or its serial) goes down as well, branch1 will have no route and the dialer-watch will activate the isdn.

hth

Herbert

99
Views
0
Helpful
3
Replies
CreatePlease to create content