Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ISDN Configuration

I'm newby with cisco ISDN. I'm trying to configure a cisco 800 for ISDN, with a static public IP. Does anyone have an example config?

3 REPLIES
New Member

Re: ISDN Configuration

Greetings:

This should get you started. Has NAT, DHCP and setting up to your POTS ports.

Steve

===============

!

hostname bruce

!

logging console debug

ip routing

enable secret 5 $1$pt2x$iFvzJn4RzMNYYW1/BJAoH/

!

*** Usernames ***

!

dial-peer voice 1 pots

call-waiting

ring 0

port 1

destination-pattern 4560054

!

dial-peer voice 2 pots

call-waiting

ring 0

port 2

destination-pattern 4560055

!

pots country US

ip subnet-zero

!

ip dhcp pool DHCPPoolLAN_0

network 10.10.10.0 255.255.255.0

dns-server 206.10.30.100 206.10.30.101

netbios-name-server 192.61.35.10 192.61.146.110

default-router 10.10.10.10

!

ip name-server 206.10.30.100

ip name-server 206.10.30.101

isdn switch-type basic-ni

!

!

interface Ethernet0

ip address 10.10.10.10 255.255.255.0

no ip directed-broadcast

no ip proxy-arp

ip nat inside

no ip route-cache

no shutdown

!

interface BRI0

no ip address

no ip directed-broadcast

no ip route-cache

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 21845600541111 4560054

isdn spid2 21845600551111 4560055

isdn incoming-voice modem

ppp authentication chap pap callin

no shutdown

!

interface Dialer1

encapsulation ppp

ip nat outside

ip address negotiated

no ip directed-broadcast

no ip proxy-arp

no ip route-cache

no ip split-horizon

dialer idle-timeout 2147483

dialer string 4560072 class DialClass

dialer string 4560073 class DialClass

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

pulse-time 0

ppp authentication chap pap callin

ppp chap hostname *****

ppp chap password 7 1212040502595A567F

ppp pap sent-username ***** password 7 15190A1E14787D767D

ppp multilink

!

ip nat inside source list 18 interface Dialer1 overload

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

map-class dialer DialClass

dialer isdn speed 56

!

access-list 18 deny 171.68.203.215

access-list 18 permit 10.0.0.0 0.255.255.255

!

dialer-list 1 protocol ip permit

!

line con 0

line vty 0 4

login

password cisco

!

end

Cisco Employee

Re: ISDN Configuration

Here is the place for a sample config, including troubleshooting

http://www.cisco.com/warp/public/793/access_dial/isdn800_14562.html

Also this one is good too.

http://www.cisco.com/warp/public/471/ddreasyip.html

New Member

Re: ISDN Configuration

If you need a quick start and a guide to help you try downloading the Cisco Config Maker from:

http://www.cisco.com/warp/public/cc/pd/nemnsw/cm/index.shtml

218
Views
0
Helpful
3
Replies
CreatePlease to create content