Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Connection issue between 2 801 routers

Hi all

I am having problems with 2 801 routers that I have configured for ddr from router1 to router2.

Router1 will dial to Router2 but no traffic will flow.

I have included configs for both, please help if you can!!

Thanx

Ade

**Router1**

Current configuration :

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Oli**

!

enable secret 5 $1$G9ei$n3U**

!

username well** password 7 030754180**

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Ethernet0

description connected to EthernetLAN

ip address 192.168.2.2 255.255.255.0

ip access-group 121 in

!

interface BRI0

description connected to Well**

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Dialer1

description connected to Well**

ip address 192.168.3.1 255.255.255.0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name Well** broadcast

dialer map ip 192.168.3.7 name Well** broadcast 0151**

dialer hold-queue 10

dialer-group 1

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

ppp authentication chap

!

ip classless

ip route 0.0.0.0 0.0.0.0 dialer1 permanent

ip http server

!

!

access-list 121 deny udp any any eq netbios-dgm

access-list 121 deny udp any any eq netbios-ns

access-list 121 deny udp any any eq netbios-ss

access-list 121 deny tcp any any eq 137

access-list 121 deny tcp any any eq 138

access-list 121 deny tcp any any eq 139

access-list 121 permit ip any any

dialer-list 1 protocol ip permit

banner motd ^C **** Welcome to Oli** 801 Router ****^C

!

line con 0

exec-timeout 0 0

password 7 0454070F19244**

login

stopbits 1

line vty 0 4

exec-timeout 0 0

password 7 0454070F19244**

login

!

no rcapi server

!

!

end

**Router2**

Current configuration:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Well**

!

enable password 7 14001707000**

!

username well** password 7 14141D180**

username oliv** password 7 104D060A0**

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Ethernet0

description connected to EthernetLAN_1

ip address 192.168.0.23 255.255.255.0

!

interface BRI0

description connected to Oliv**

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Dialer1

description connected to Oliv**

ip address 192.168.3.7 255.255.255.0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name Oliv** broadcast

dialer map ip 192.168.3.1 name Oliv** broadcast **81535

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 dialer1

!

dialer-list 1 protocol ip permit

!

snmp-server engineID local 00000009020000B0C28BDCB7

snmp-server community public RO

snmp-server location Central Office

snmp-server chassis-id JAD045256GL

banner motd ^C**** Welcome to Well** 801 Router ****^C

!

line con 0

exec-timeout 0 0

password 7 083649420**

login

transport input none

stopbits 1

line vty 0 4

password 7 083649420**

login

!

no rcapi server

!

!

end

3 REPLIES
Cisco Employee

Re: ISDN Connection issue between 2 801 routers

Just make sure that the dialer map statement o router R2 have exact hostname of the router R1. As per the config you have Oli** as the host name of R1 but in the dialer map on R2, you have name as Oliv** . So be sure on that.

If that is fine then you might need to remove the "snampshot" config just for testing. If still no routing after connection, need to see what "debug ip icmp" reports when you issue ping from R1 to R2. Lets see if anything may have went wrong during PPP. So pl. enable debug for following

debug isdn q931

debug ppp nego

debug dialer

Collect that debug on R2 (receiving router) Also include sh ip route as well.

New Member

Re: ISDN Connection issue between 2 801 routers

Router1:-

**** Welcome to Oli*801 Router ****

User Access Verification

Password:

23:45:73014444032: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 01512

551581 Welli*, call lasted 119 seconds

23:45:73014444032: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

23:45:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to down

Password:

Oli*>ping 192.168.3.

23:45:146028888064: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up7

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.3.7, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/63/140 ms

Oli*>

23:45:35: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to up

23:45:40: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01512551581 Well

ington

Oli*>ping 192.168.3.7

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.3.7, timeout is 2 seconds:

!!!!!

Oli*>ping 192.168.0.23

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.23, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Oli*>ping 192.168.0.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.5, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Oli*>ping 192.168.0.23

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.23, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

Oli*>ping 192.168.0.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.5, timeout is 2 seconds:

!!!!!

Success rate is 0 percent (0/5)

Oli*>ping 192.168.0.20

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.20, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Olivemount>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S 192.168.0.0/24 [1/0] via 192.168.3.7

C 192.168.2.0/24 is directly connected, Ethernet0

192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.3.0/24 is directly connected, Dialer1

C 192.168.3.7/32 is directly connected, Dialer1

S* 0.0.0.0/0 is directly connected, Dialer1

New Member

Re: ISDN Connection issue between 2 801 routers

Welli*#debug isdn q931

ISDN Q931 packets debugging is on

Welli*#debug ppp nego

PPP protocol negotiation debugging is on

Welli*#debug dialer

Dial on demand events debugging is on

Welli*#

2w0d: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 68 changed to down

2w0d: ISDN BR0: RX <- SETUP pd = 8 callref = 0x27

2w0d: Sending Complete

2w0d: Bearer Capability i = 0x8890

2w0d: Channel ID i = 0x89

2w0d: ISDN BR0: Event: Received a DATA call from on B1 at 64 Kb/s

2w0d: ISDN BR0: Event: Accepting the call id 0x3F

2w0d: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

2w0d: BR0:1 PPP: Treating connection as a callin

2w0d: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

2w0d: BR0:1 LCP: State is Listen

2w0d: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 68 changed to up

2w0d: ISDN BR0: TX -> CALL_PROC pd = 8 callref = 0xA7

2w0d: Channel ID i = 0x89

2w0d: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xA7

2w0d: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x27

2w0d: BR0:1 LCP: I CONFREQ [Listen] id 7 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0x10F1B27A (0x050610F1B27A)

2w0d: BR0:1 LCP: O CONFREQ [Listen] id 88 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0xFCCBB596 (0x0506FCCBB596)

2w0d: BR0:1 LCP: O CONFACK [Listen] id 7 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0x10F1B27A (0x050610F1B27A)

2w0d: BR0:1 LCP: I CONFACK [ACKsent] id 88 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0xFCCBB596 (0x0506FCCBB596)

2w0d: BR0:1 LCP: State is Open

2w0d: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

2w0d: BR0:1 CHAP: O CHALLENGE id 60 len 31 from "Welli*"

2w0d: BR0:1 CHAP: I CHALLENGE id 7 len 31 from "Oli*"

2w0d: BR0:1 CHAP: Waiting for peer to authenticate first

2w0d: BR0:1 CHAP: I RESPONSE id 60 len 31 from "Oli*"

2w0d: BR0:1 CHAP: O SUCCESS id 60 len 4

2w0d: BR0:1 CHAP: Processing saved Challenge, id 7

2w0d: BR0:1 CHAP: O RESPONSE id 7 len 31 from "Welli*"

2w0d: BR0:1 CHAP: I SUCCESS id 7 len 4

2w0d: BR0:1 PPP: Phase is UP [0 sess, 0 load]

2w0d: BR0:1 IPCP: O CONFREQ [Closed] id 32 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.7 (0x0306C0A80307)

2w0d: BR0:1 IPCP: I CONFREQ [REQsent] id 7 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.1 (0x0306C0A80301)

2w0d: BR0:1 IPCP: O CONFACK [REQsent] id 7 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.1 (0x0306C0A80301)

2w0d: BR0:1 IPCP: I CONFACK [ACKsent] id 32 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.7 (0x0306C0A80307)

2w0d: BR0:1 IPCP: State is Open

2w0d: BR0:1 DDR: dialer protocol up

2w0d: Di1 IPCP: Install route to 192.168.3.1

2w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to u

p

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 1 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: O ECHOREP [Open] id 1 len 12 magic 0xFCCBB596

2w0d: BR0:1 LCP: I ECHOREP [Open] id 1 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: Received id 1, sent id 1, line up

2w0d: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01517381535 Oli*

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: O ECHOREP [Open] id 2 len 12 magic 0xFCCBB596

2w0d: BR0:1 LCP: I ECHOREP [Open] id 2 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: Received id 2, sent id 2, line up

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 3 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: O ECHOREP [Open] id 3 len 12 magic 0xFCCBB596

2w0d: BR0:1 LCP: I ECHOREP [Open] id 3 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: Received id 3, sent id 3, line up

{output cut here, It is exactly the same through to id12}

2w0d: BR0:1 LCP: I ECHOREP [Open] id 12 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: Received id 12, sent id 12, line up

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 12 len 12 magic 0x10F1B27A

2w0d: BR0:1 LCP: O ECHOREP [Open] id 12 len 12 magic 0xFCCBB596

2w0d: BR0:1 DDR: idle timeout

2w0d: BR0:1 DDR: disconnecting call

2w0d: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 01517381535 Oli*, call lasted 120 seconds

2w0d: ISDN BR0: TX -> DISCONNECT pd = 8 callref = 0xA7

2w0d: Cause i = 0x8090 - Normal call clearing

2w0d: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x27

2w0d: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

2w0d: BR0:1 IPCP: State is Closed

2w0d: BR0:1 PPP: Phase is TERMINATING [0 sess, 0 load]

2w0d: BR0:1 LCP: State is Closed

2w0d: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]

2w0d: BR0:1 DDR: disconnecting call

2w0d: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0xA7

2w0d: Di1 IPCP: Remove route to 192.168.3.1

2w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to d

own

2w0d: ISDN BR0: RX <- SETUP pd = 8 callref = 0x26

2w0d: Sending Complete

2w0d: Bearer Capability i = 0x8890

2w0d: Channel ID i = 0x89

2w0d: ISDN BR0: Event: Received a DATA call from on B1 at 64 Kb/s

2w0d: ISDN BR0: Event: Accepting the call id 0x40

2w0d: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

2w0d: BR0:1 PPP: Treating connection as a callin

2w0d: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

2w0d: BR0:1 LCP: State is Listen

2w0d: ISDN BR0: TX -> CALL_PROC pd = 8 callref = 0xA6

2w0d: Channel ID i = 0x89

2w0d: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xA6

2w0d: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x26

2w0d: BR0:1 LCP: I CONFREQ [Listen] id 8 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0x10F3C2F0 (0x050610F3C2F0)

2w0d: BR0:1 LCP: O CONFREQ [Listen] id 89 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0xFCCDC5E8 (0x0506FCCDC5E8)

2w0d: BR0:1 LCP: O CONFACK [Listen] id 8 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0x10F3C2F0 (0x050610F3C2F0)

2w0d: BR0:1 LCP: I CONFACK [ACKsent] id 89 len 15

2w0d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

2w0d: BR0:1 LCP: MagicNumber 0xFCCDC5E8 (0x0506FCCDC5E8)

2w0d: BR0:1 LCP: State is Open

2w0d: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

2w0d: BR0:1 CHAP: O CHALLENGE id 61 len 31 from "Wellington"

2w0d: BR0:1 CHAP: I CHALLENGE id 8 len 31 from "Olivemount"

2w0d: BR0:1 CHAP: Waiting for peer to authenticate first

2w0d: BR0:1 CHAP: I RESPONSE id 61 len 31 from "Olivemount"

2w0d: BR0:1 CHAP: O SUCCESS id 61 len 4

2w0d: BR0:1 CHAP: Processing saved Challenge, id 8

2w0d: BR0:1 CHAP: O RESPONSE id 8 len 31 from "Wellington"

2w0d: BR0:1 CHAP: I SUCCESS id 8 len 4

2w0d: BR0:1 PPP: Phase is UP [0 sess, 0 load]

2w0d: BR0:1 IPCP: O CONFREQ [Closed] id 33 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.7 (0x0306C0A80307)

2w0d: BR0:1 IPCP: I CONFREQ [REQsent] id 8 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.1 (0x0306C0A80301)

2w0d: BR0:1 IPCP: O CONFACK [REQsent] id 8 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.1 (0x0306C0A80301)

2w0d: BR0:1 IPCP: I CONFACK [ACKsent] id 33 len 10

2w0d: BR0:1 IPCP: Address 192.168.3.7 (0x0306C0A80307)

2w0d: BR0:1 IPCP: State is Open

2w0d: BR0:1 DDR: dialer protocol up

2w0d: Di1 IPCP: Install route to 192.168.3.1

2w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to u

p

2w0d: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01517381535 Oli*

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 1 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: O ECHOREP [Open] id 1 len 12 magic 0xFCCDC5E8

2w0d: BR0:1 LCP: I ECHOREP [Open] id 1 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: Received id 1, sent id 1, line up

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: O ECHOREP [Open] id 2 len 12 magic 0xFCCDC5E8

2w0d: BR0:1 LCP: I ECHOREP [Open] id 2 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: Received id 2, sent id 2, line up

{output cut here, It is exactly the same through to id12}

2w0d: BR0:1 LCP: I ECHOREQ [Open] id 6 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: O ECHOREP [Open] id 6 len 12 magic 0xFCCDC5E8

2w0d: BR0:1 LCP: I ECHOREP [Open] id 6 len 12 magic 0x10F3C2F0

2w0d: BR0:1 LCP: Received id 6, sent id 6, line up2w0d: BR0:1 LCP: I Welli*>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.0.0/24 is directly connected, Ethernet0

C 192.168.3.0/24 is directly connected, Dialer1

S* 0.0.0.0/0 is directly connected, Ethernet0

is directly connected, Dialer1

I have a feeling that the final lines on router2 hold the key, but with limited experience I think I will await your answers!!

(I have removed the

I can ping the welli* router and the dialer using the router interface, I can also ping the Welli* interface (192.168.3.7 & 192.168.0.23), but can't get any further.

Trying to ping a server fails.

Also using a command prompt with a default gateway of 192.168.2.2, traffic goes out but the pings fail.

Thanks for all of your help.

103
Views
4
Helpful
3
Replies