Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Connectivity problem - addendum.

Sorry I posted the incorrect config previously. Here is the proper post.

I have a 2611 in a hub site, and another at a spoke site. The hub site router is acting as a simple access router with an E1 card transferring requests to a Radius server. This part works fine locally however when dialling up remotely, the hub router hangs the line up after a few seconds without even attempting to authenticate. Hub config is below, the spoke sited were dialling successfully to a Tigris router. Any help appreciated.

Thanks

Dean

sh run

Building configuration...

Current configuration : 2183 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname mel04

!

logging rate-limit console 10 except errors

aaa new-model

aaa authentication login default group radius

aaa authentication login NO_RADIUS local

aaa authentication ppp default group radius

aaa authorization exec default group radius

aaa authorization exec NO_RADIUS local

aaa authorization network default local group radius

aaa accounting send stop-record authentication failure

aaa accounting exec default start-stop group radius

aaa accounting network default start-stop group radius

enable password 7 045E1B570C345E4B

--More-- !

username root password 7 151C0E07102B39

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

ip name-server 202.81.96.82

!

isdn switch-type primary-ts014

!

!

controller E1 1/0

pri-group timeslots 1-31

!

!

interface Ethernet0/0

description Connected to HP Switch on mel04 VLAN

ip address 202.81.105.66 255.255.255.252

full-duplex

!

interface Ethernet0/1

no ip address

--More-- shutdown

half-duplex

!

interface Serial1/0:15

no ip address

isdn switch-type primary-ts014

no cdp enable

!

interface Dialer0

no ip address

no cdp enable

!

interface Dialer1

description connected to dial in PCs(ISDN)

no ip address

encapsulation ppp

no ip split-horizon

dialer in-band

dialer-group 1

peer default ip address pool mel04-Group-1

ppp authentication chap pap callin

ppp multilink

!

--More-- ip local pool me104-Group-1 203.81.106.1 203.81.106.30

ip classless

ip default-network 202.81.105.0

ip route 0.0.0.0 0.0.0.0 202.81.105.65

ip http server

!

snmp-server community public RO

snmp-server location Richmond

radius-server host 202.81.96.93 auth-port 1645 acct-port 1646 key 7 050C051B285F5E

radius-server host 202.81.96.94 auth-port 1645 acct-port 1646 key 7 10490A0D0C0402

radius-server host 202.81.96.99 auth-port 1645 acct-port 1646 key 7 07082258471A09

radius-server retransmit 3

!

line con 0

exec-timeout 0 0

password 7 11071C0E031319

transport input none

line aux 0

line vty 0 4

password 7 06080A2A584F1B

--More-- authorization exec NO_RADIUS

login authentication NO_RADIUS

!

no scheduler allocate

end

mel04#

  • Other Network Infrastructure Subjects
3 REPLIES
Cisco Employee

Re: ISDN Connectivity problem - addendum.

The D channel of the E1/PRI line "interface Serial1/0:15" is not likned with the interface dialer 1. So i can expect the PPP call not to work. So to fix that you need to have the config like following. "dialer rotary-group 1" will link that interface with "interface dialer 1"

interface Serial1/0:15

no ip address

dialer rotary-group 1

dialer-group 1

ppp authentication chap pap callin

ppp multilink

isdn switch-type primary-ts014

!

Also not sure why the dialer interface is not configured with the ip address. You need to add the command "ip unnumbered ethernet 0/0" under "interface dialer 1". with that calls should work fine(asumming the radius is configured fine). If not, we need to see the debug for following

debug isdn q931

debug ppp nego

debug ppp auth

debug aaa authentication

debug aaa authorization

New Member

Re: ISDN Connectivity problem - addendum.

Dean

Just a quick comment...I noticed that in the statement

"ip local pool me104-Group-1 203.81.106.1 203.81.106.30"

you refer to ME104-Group-1 rather than MEL04-Group-1

would stop an IP address being allocated.

Regards

Peter

New Member

Re: ISDN Connectivity problem - addendum.

Peter, thanks very much for that, what a trap for young players! I'm not sure if this is the existing config as I have posted an old capture but I'll certainly be checking that.

Dean

84
Views
0
Helpful
3
Replies