Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN D-channel Layer 2 Problem !!

hi ,

I have a router with E1 module (see sh version below) , I'm trying to connect this router to a PBX .

the problem is , ISDN serial 0:15 interface is giving TEI_ASSIGNMENT in the layer 2 (this is from sh isdn status), and it shows Serial1/0:15 is up, line protocol is up (spoofing) (in show interface s1/0:15)

I know that the problem is in the D-channel ,

I'm trying to set the encapsulation to PPP on the interface s1/0:15 but it gives me this error :

"%Hardware does not support ISDN data calls; encapsulation not set."

anyone can tell me what is that , I'm sure that the problem is from the encaspulation !!!

please help.

this is what I got when trying to set the encapsulation to PPP

MICDGWV(config-if)#int s1/0:15

MICDGWV(config-if)#encapsulation ?

atm-dxi ATM-DXI encapsulation

bstun Block Serial tunneling (BSTUN)

cpp Combinet proprietary protocol

hdlc Serial HDLC synchronous

lapb LAPB (X.25 Level 2)

ppp Point-to-Point protocol

sdlc SDLC

sdlc-primary SDLC (primary)

sdlc-secondary SDLC (secondary)

smds Switched Megabit Data Service (SMDS)

stun Serial tunneling (STUN)

x25 X.25

MICDGWV(config-if)#encapsulation ppp

"%Hardware does not support ISDN data calls; encapsulation not set."

--------------------------------------- sh version --------------------------------------------------

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(7b), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Tue 05-Mar-02 04:40 by pwade

Image text-base: 0x80008088, data-base: 0x813C20E0

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

MICDGWV uptime is 59 minutes

System returned to ROM by power-on

System image file is "flash:c2600-js-mz.122-7b.bin"

cisco 2610 (MPC860) processor (revision 0x203) with 60416K/5120K bytes of memory.

Processor board ID JAD05060EFH (3259457801)

M860 processor: part number 0, mask 49

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

7 Serial network interface(s)

2 Serial(sync/async) network interface(s)

1 Channelized E1/PRI port(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

------------------------------------------------ interface seial1/0:15 ----------------------

MICDGWV#sh int s1/0:15

Serial1/0:15 is up, line protocol is up (spoofing)

Hardware is DSX1

Description: VOIP||ISDN|Y||||||| See E1 Controller for details

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Last input never, output 00:58:48, output hang never

Last clearing of "show interface" counters 00:10:13

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

----------------------sh ru ----------------------

MICDGWV#sh run

Building configuration...

Current configuration : 1953 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname MICDGWV

!

boot system flash c2600-js-mz.122-7b.bin

boot system rom

logging buffered 4096 notifications

enable password xxxx

!

voice-card 1

!

ip subnet-zero

!

!

!

isdn switch-type primary-qsig

call rsvp-sync

cns event-service server

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0

!

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g711alaw

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

dial-control-mib retain-timer 1000

dial-control-mib max-size 1200

!

controller E1 1/0

pri-group timeslots 1-6,16

!

!

!

interface Loopback0

ip address xxxxxxxxxxx 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr xxxxxxxxx

!

interface Ethernet0/0

ip address xxxx.xxx.xxxx.xxx 255.255.255.252

keepalive 4

half-duplex

!

interface Serial0/0

description NOT IN USE |||||||

no ip address

shutdown

!

interface Serial0/1

description NOT IN USE |||||||

no ip address

shutdown

!

interface Serial1/0:15

description VOIP||ISDN|Y||||||| See E1 Controller for details

no ip address

no logging event link-status

no snmp trap link-status

isdn switch-type primary-qsig

isdn incoming-voice voice

isdn T309-enable

fair-queue 64 256 0

no cdp enable

!

router eigrp 4278

network 143.26.0.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

no ip http server

ip pim bidir-enable

!

!

!

voice-port 1/0:15

echo-cancel coverage 32

!

dial-peer cor custom

!

!

!

dial-peer voice 9999 pots

destination-pattern 9663812....

direct-inward-dial

forward-digits all

!

dial-peer voice 6666 pots

!

dial-peer voice 575 pots

destination-pattern 575....

direct-inward-dial

port 1/0:15

!

!

line con 0

exec-timeout 0 0

password xxxxxx

line aux 0

exec-timeout 0 0

password xxxxxx

line vty 0 4

exec-timeout 0 0

password xxxxxx

login

!

end

  • Other Network Infrastructure Subjects
3 REPLIES
Silver

Re: ISDN D-channel Layer 2 Problem !!

Have you considered that your channel 15 is not defined in your time slots in the E1 controllers config ?

Re: ISDN D-channel Layer 2 Problem !!

Hello,

Does the ISDN card on the PBX, supports data calls to be placed. Most probably, the switch (PBX) is configured only for voice calls. Check the PBX setting.

New Member

Re: ISDN D-channel Layer 2 Problem !!

May be you should try

conf t

int s1/0/:15

isdn protocol-emulate network

regards

Farid

245
Views
0
Helpful
3
Replies
This widget could not be displayed.