Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

** ISDN Dial-in quey..... a nice change for all the experts......

Hi all....

Im sure that there is a very simple solution to this problem....

I have a cisco 2610 + BRI in WIC 0/0. I want to allow a ISDN TA dial-in access to my router.

I have configured my router (as below, password ppp) and attempted to dial-in.

more or less every time I get connected for around 11 seconds, then the call gets dropped.

I think the fault could lie in the PPP negotiation phase.

Any of you experts got any ideas....

I have attached the following screen dumps for reference...

RAS Settings + Modem Log

Router Config

Various debug logs.. Dialer, q931, ppp neg, ppp packet

Thank you in advance...

Olagg ;)

=================================================

Dial-in RAS - Windows NT4 Workstation - SETTINGS

=================================================

Phonebook Entry:

Name: Cisco Router Dial

Phone: 70059

Dial Up server Type: PPP Windows NT

Network Protocol: TCP/IP

Enable software compression ON

Enable PPP LCP Extensions ON

idle time before hanging up: 0

DUN Error Code:

Error Code: 678 - there is no answer

Phone Book Log: (Taken from Root Folder)

=======================================

10-12-1998 15:35:21.300 - Pace Ultralink ISDN TA in use.

10-12-1998 15:35:21.300 - Modem type: Pace Ultralink ISDN TA

10-12-1998 15:35:21.300 - Modem inf path: oem2.inf

10-12-1998 15:35:21.300 - Modem inf section: Modem1

10-12-1998 15:35:21.300 - 19200,N,8,1

10-12-1998 15:35:21.300 - 19200,N,8,1

10-12-1998 15:35:21.300 - Initializing modem.

10-12-1998 15:35:21.300 - Send: AT<cr>

10-12-1998 15:35:21.521 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:35:21.521 - Interpreted response: OK

10-12-1998 15:35:21.521 - Send: AT E1 V1 Q0 W2 S95=34<cr>

10-12-1998 15:35:21.531 - Recv: AT E1 V1 Q0 W2 S95=34<cr>

10-12-1998 15:35:21.551 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:35:21.551 - Interpreted response: OK

10-12-1998 15:35:21.551 - Send: ATS7=55\N3%C3&K3X3<cr>

10-12-1998 15:35:21.561 - Recv: ATS7=55\N3%C3&K3X3<cr>

10-12-1998 15:35:21.581 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:35:21.581 - Interpreted response: OK

10-12-1998 15:35:21.581 - Waiting for a call.

10-12-1998 15:35:21.581 - Send: ATS0=0<cr>

10-12-1998 15:35:21.591 - Recv: ATS0=0<cr>

10-12-1998 15:35:21.601 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:35:21.601 - Interpreted response: OK

10-12-1998 15:36:40.815 - 19200,N,8,1

10-12-1998 15:36:40.815 - Initializing modem.

10-12-1998 15:36:40.815 - Send: AT<cr>

10-12-1998 15:36:40.815 - Recv: AT<cr>

10-12-1998 15:36:40.825 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:36:40.825 - Interpreted response: OK

10-12-1998 15:36:40.825 - Send: AT E1 V1 Q0 W2 S95=34<cr>

10-12-1998 15:36:40.835 - Recv: AT E1 V1 Q0 W2 S95=34<cr>

10-12-1998 15:36:40.855 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:36:40.855 - Interpreted response: OK

10-12-1998 15:36:40.855 - Send: ATS7=55\N3%C3&K3X3<cr>

10-12-1998 15:36:40.865 - Recv: ATS7=55\N3%C3&K3X3<cr>

10-12-1998 15:36:40.885 - Recv: <cr><lf>OK<cr><lf>

10-12-1998 15:36:40.885 - Interpreted response: OK

10-12-1998 15:36:40.885 - Dialing.

10-12-1998 15:36:40.885 - Send: ATDT#####<cr>

10-12-1998 15:36:40.895 - Recv: ATDT70059<cr>

10-12-1998 15:36:52.191 - Recv: <cr><lf>NO CARRIER<cr><lf>

10-12-1998 15:36:52.191 - Interpreted response: No Carrier

10-12-1998 15:36:52.191 - 19200,N,8,1

10-12-1998 15:36:52.191 - Initializing modem.

10-12-1998 15:36:52.191 - Send: AT<cr>

10-12-1998 15:36:52.341 - Hanging up the modem.

10-12-1998 15:36:52.341 - Send: ATZ<cr>

10-12-1998 15:36:52.451 - Recv: ATZ<cr>

10-12-1998 15:36:52.451 - Session Statistics:

10-12-1998 15:36:52.451 - Reads : 171 bytes

10-12-1998 15:36:52.451 - Writes: 112 bytes

10-12-1998 15:36:52.461 - Modem closed.

=======================================

=================================================

2610 Router Configuration - Output

=================================================

Current configuration : 1224 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname DMR

!

enable password 7 --moderator edit--

!

username ppp password ppp

ip subnet-zero

!

!

no ip domain-lookup

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0/0

description connected to EthernetLAN

ip address 204.204.7.1 255.255.255.0

no keepalive

half-duplex

!

interface BRI0/0

description connected to Dial-inPCs(ISDN)

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface BRI0/1

no ip address

shutdown

isdn switch-type basic-net3

!

interface Dialer1

description connected to Dial-inPCs(ISDN)

ip unnumbered Ethernet0/0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer-group 1

peer default ip address pool DMR-Group-1

no cdp enable

ppp authentication chap pap callin

ppp multilink

!

router rip

version 2

network 204.204.7.0

no auto-summary

!

ip local pool DMR-Group-1 204.204.7.200 204.204.7.201

ip classless

no ip http server

ip pim bidir-enable

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

password 7 --moderator edit--

login

line aux 0

line vty 0 4

password 7 --moderator edit--

login

!

end

=================================================

DEBUG ISDN Q931 - Output

=================================================

00:49:54: ISDN BR0/0: RX <- SETUP pd = 8 callref = 0x38

00:49:54: Sending Complete

00:49:54: Bearer Capability i = 0x8890

00:49:54: Channel ID i = 0x89

00:49:54: Calling Party Number i = 0x01, 0x81, '70058', Plan:ISDN, Type:Unknown

00:49:54: Called Party Number i = 0xC1, '70059', Plan:ISDN, Type:Subscriber(local)

00:49:54: ISDN BR0/0: Event: Received a DATA call from 70058 on B1 at 64 Kb/s

00:49:54: ISDN BR0/0: Event: Accepting the call id 0xC

00:49:231928233984: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

00:49:54: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 91 changed to up

00:49:54: ISDN BR0/0: TX -> CALL_PROC pd = 8 callref = 0xB8

00:49:54: Channel ID i = 0x89

00:49:54: ISDN BR0/0: TX -> CONNECT pd = 8 callref = 0xB8

00:49:54: ISDN BR0/0: RX <- CONNECT_ACK pd = 8 callref = 0x38

00:50:00: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 70058

00:50:06: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0x38

00:50:06: Cause i = 0x8190 - Normal call clearing

00:50:06: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 70058 , call lasted 11 seconds

00:50:06: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

00:50:06: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0xB8

00:50:06: Cause i = 0x8090 - Normal call clearing

00:50:06: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0x38

00:50:06: Cause i = 0x8190 - Normal call clearing

00:50:08: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 91 changed to down

=================================================

DEBUG DIALER - Output

=================================================

00:51:240518168576: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

00:51:56: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 91 changed to up

00:52:02: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 70058

00:52:07: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 70058 , call lasted 11 seconds

00:52:07: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

00:52:07: BR0/0:1 DDR: disconnecting call

00:52:09: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 91 changed to down

=================================================

DEBUG PPP NEGOTIATION - Output

=================================================

00:53:141733920768: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

00:53:143881404389: BR0/0:1 PPP: Treating connection as a callin

00:53:143894052180: BR0/0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0load]

00:53:143896999452: BR0/0:1 LCP: State is Listen

00:53:33: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 91 changed to up

00:53:35: BR0/0:1 LCP: TIMEout: State Listen

00:53:35: BR0/0:1 LCP: O CONFREQ [Listen] id 37 len 25

00:53:35: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:53:35: BR0/0:1 LCP: MagicNumber 0x02EA50EF (0x050602EA50EF)

00:53:35: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:53:35: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:53:37: BR0/0:1 LCP: TIMEout: State REQsent

00:53:37: BR0/0:1 LCP: O CONFREQ [REQsent] id 38 len 25

00:53:37: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:53:37: BR0/0:1 LCP: MagicNumber 0x02EA50EF (0x050602EA50EF)

00:53:37: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:53:37: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:53:39: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 70058

00:53:39: BR0/0:1 LCP: TIMEout: State REQsent

00:53:39: BR0/0:1 LCP: O CONFREQ [REQsent] id 39 len 25

00:53:39: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:53:39: BR0/0:1 LCP: MagicNumber 0x02EA50EF (0x050602EA50EF)

00:53:39: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:53:39: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:53:41: BR0/0:1 LCP: TIMEout: State REQsent

00:53:41: BR0/0:1 LCP: O CONFREQ [REQsent] id 40 len 25

00:53:41: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:53:41: BR0/0:1 LCP: MagicNumber 0x02EA50EF (0x050602EA50EF)

00:53:41: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:53:41: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:53:43: BR0/0:1 LCP: TIMEout: State REQsent

00:53:43: BR0/0:1 LCP: O CONFREQ [REQsent] id 41 len 25

00:53:43: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:53:43: BR0/0:1 LCP: MagicNumber 0x02EA50EF (0x050602EA50EF)

00:53:43: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:53:43: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:53:44: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 70058 , call lasted 11 seconds

00:53:44: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

00:53:44: BR0/0:1 LCP: State is Closed

00:53:44: BR0/0:1 PPP: Phase is DOWN [0 sess, 0 load]

00:53:46: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 91 changed to down

=================================================

DEBUG PPP AUTHENTICATION - Output

=================================================

00:54:201863462912: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

00:54:204010946533: BR0/0:1 PPP: Treating connection as a callin

00:54:47: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 91 changed to up

00:54:53: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 70058

00:54:58: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 70058 , call lasted 11 seconds

00:54:58: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

00:55:00: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 91 changed to down

=================================================

DEBUG PPP PACKET - Output

=================================================

00:56:77309411328: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

00:56:18: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 91 changed to up

00:56:18: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:18: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:19: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:19: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:20: BR0/0:1 LCP: TIMEout: State Listen

00:56:20: BR0/0:1 LCP: O CONFREQ [Listen] id 47 len 25

00:56:20: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:56:20: BR0/0:1 LCP: MagicNumber 0x02ECD4F7 (0x050602ECD4F7)

00:56:20: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:56:20: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:56:20: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:20: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:21: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:21: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:22: BR0/0:1 LCP: TIMEout: State REQsent

00:56:22: BR0/0:1 LCP: O CONFREQ [REQsent] id 48 len 25

00:56:22: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:56:22: BR0/0:1 LCP: MagicNumber 0x02ECD4F7 (0x050602ECD4F7)

00:56:22: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:56:22: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:56:22: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:22: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:23: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:23: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:24: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 70058

00:56:24: BR0/0:1 LCP: TIMEout: State REQsent

00:56:24: BR0/0:1 LCP: O CONFREQ [REQsent] id 49 len 25

00:56:24: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:56:24: BR0/0:1 LCP: MagicNumber 0x02ECD4F7 (0x050602ECD4F7)

00:56:24: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:56:24: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:56:24: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:24: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:25: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:25: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:26: BR0/0:1 LCP: TIMEout: State REQsent

00:56:26: BR0/0:1 LCP: O CONFREQ [REQsent] id 50 len 25

00:56:26: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:56:26: BR0/0:1 LCP: MagicNumber 0x02ECD4F7 (0x050602ECD4F7)

00:56:26: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:56:26: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:56:26: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:26: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:27: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:27: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:28: BR0/0:1 LCP: TIMEout: State REQsent

00:56:28: BR0/0:1 LCP: O CONFREQ [REQsent] id 51 len 25

00:56:28: BR0/0:1 LCP: AuthProto CHAP (0x0305C22305)

00:56:28: BR0/0:1 LCP: MagicNumber 0x02ECD4F7 (0x050602ECD4F7)

00:56:28: BR0/0:1 LCP: MRRU 1524 (0x110405F4)

00:56:28: BR0/0:1 LCP: EndpointDisc 1 DMR (0x130601444D52)

00:56:28: BR0/0:1 PPP: I pkt type 0x0801, datagramsize 3

00:56:28: BR0/0:1 UNKNOWN(0x0801): Non-NCP packet, discarding

00:56:29: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 70058 , call lasted 11 seconds

00:56:29: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

00:56:31: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 91 changed to down

1 REPLY

Re: ** ISDN Dial-in quey..... a nice change for all the experts.

Often times complex troubleshooting issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it's often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

90
Views
0
Helpful
1
Replies
CreatePlease login to create content