Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN Dial Out

I currently have a 3640 router with an analog modem bank. I have six lines that dial into ISPs (using PPP) over these analog lines. I would like to switch the solution to isdn, and I have 3 BRI interfaces. Can I dial with the ISDN lines into the same ISPs? Or do I need to use ISDN service? I can get the router to accept calls from any phone line, but when I dial out it doesn't work. Thanks in advance

9 REPLIES
Cisco Employee

Re: ISDN Dial Out

You need the ISDN service from your ISP..ISP treats ISDN calls differently then the analog calls.

New Member

Re: ISDN Dial Out

So, I'm using the isdn service, and the call keeps connecting and then disconnecting, never getting to PPP negotiation. The debug trace looks clean, and the call gets established. Any thoughts?

Cisco Employee

Re: ISDN Dial Out

ISDN service means....you need to notify the that you want to use the isdn line to connect to their equipment..At this point, your isp may be rejecting a call..

turn on "debug isdn q931" to see the real cause..and post it here..thx..Tejal

New Member

Re: ISDN Dial Out

It is an ISDN line with Earthlink. As you can see it connects, and then immediatley disconnects. Below is the output:

1d18h: BR0/0 DDR: Attempting to dial 9032000

1d18h: ISDN BR0/0: Outgoing call id = 0x8001, dsl 0

1d18h: ISDN BR0/0: Event: Call to 9032000 at 64 Kb/s

1d18h: ISDN BR0/0: process_bri_call(): call id 0x8001, called_number 9032000, speed 64, call type DATA

1d18h: CCBRI_Go Fr Host InPkgInfo (Len=22) :

1d18h: 1 0 1 80 1 0 4 2 88 90 18 1 83 2C 7 39 30 33 32 30 30 30

1d18h:

1d18h: CC_CHAN_GetIdleChanbri: dsl 0

1d18h: Found idle channel B1

1d18h: ISDN BR0/0: trigger_calling_called_debug, dsl 0, callref 0x1, outgoing TRUE

1d18h: CCBRI_Go Fr L3 pkt (Len=7) :

1d18h: 2 1 1 98 18 1 89

1d18h:

1d18h: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x8001 HOST_PROCEEDING

1d18h: ISDN BR0/0: HOST_PROCEEDING

1d18h: ISDN BR0/0: HOST_MORE_INFO

1d18h: CCBRI_Go Fr L3 pkt (Len=8) :

1d18h: 3 1 1 95 1E 2 84 88

1d18h:

1d18h: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x8001 HOST_PROGRESS

1d18h: ISDN BR0/0: HOST_PROGRESS: Got IE of INBAND or Not End-To-End

1d18h: CCBRI_Go Fr L3 pkt (Len=8) :

1d18h: 7 1 1 91 1E 2 84 82

1d18h:

1d18h: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x8001 HOST_CONNECT

1d18h: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

1d18h: ISDN: get_isdn_service_state(): idb 0x62A8AB9C bchan 2 is_isdn 1 Not a Pri

1d18h: ISDN BR0/0: Event: Connected to 9032000 on B1 at 64 Kb/s

1d18h: CCBRI_Go Fr L3 pkt (Len=8) :

1d18h: 45 1 1 96 8 2 80 90

1d18h:

1d18h: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x8001 HOST_DISCONNECT

1d18h: ISDN BR0/0: Event: Call to was hung up.

1d18h: ISDN BR0/0: process_disc_ack(): call id 0x8001, ces 1, call type DATA cause 0x0

1d18h: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 9032000 00c0.7b8b.5fd2

1d18h: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 9032000 00c0.7b8b.5fd2, call lasted 2 seconds

1d18h: ISDN: get_isdn_service_state(): idb 0x62A8AB9C bchan 2 is_isdn 1 Not a Pri

1d18h: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

1d18h: CCBRI_Go Fr Host InPkgInfo (Len=10) :

1d18h: 6 0 1 80 1 0 8 2 0 8

1d18h:

1d18h: CCBRI_Go Fr L3 pkt (Len=4) :

1d18h: 5A 1 1 99

1d18h:

1d18h: ISDN BR0/0: LIF_EVENT: ces/callid 1/0x8001 HOST_DISCONNECT_ACK

1d18h: ISDN: get_isdn_service_state(): idb 0x62A8AB9C bchan 2 is_isdn 1 Not a Pri

1d18h: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

sc8-ipres#ping 216.207.35.153

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 216.207.35.153, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

sc8-ipres# -- failed, not connected -- failed, not connected -- failed, not connected -- failed, not connected -- failed, not connected -- failed, not connected -- failed, not connected

Cisco Employee

Re: ISDN Dial Out

From the following debug

ISDN BR0/0: Event: Connected to 9032000 on B1 at 64 Kb/s

The isdn line did got connected now we need to know what is going on after that..Need following debug along with the running config and the sh ver

debug isdn q931

debug ppp negotiation

debug ppp authentication

Is the number 9032000 provided by Earthlink or you are using the same as analog dialup?

New Member

Re: ISDN Dial Out

That is it. The debug lines above are enabled, but there was no output. Just the disconnect. This is an ISDN line from Earthlink.

Cisco Employee

Re: ISDN Dial Out

Somehow the PPP didn't started after ISDN CONNECT..Now pl. post the config (sh run) along with version (sh ver) from the router here..Did you talk to earthlink about that?

New Member

Re: ISDN Dial Out

Current configuration : 6036 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxxxxx

!

boot system flash slot0:c3640-ik9s-mz.122-8.T1.bin

logging buffered 4096 informational

!

ip subnet-zero

!

!

no ip domain-lookup

!

!

isdn switch-type basic-ni

!

!

interface Loopback0

ip address 10.41.0.1 255.255.0.0

!

interface BRI0/0

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-ni

isdn spid1 40872735010101

isdn spid2 40872767950101

no cdp enable

!

interface FastEthernet0/0

ip address 10.40.5.1 255.255.0.0

ip nat inside

ip policy route-map DIALER

speed 100

full-duplex

!

interface BRI0/1

no ip address

isdn switch-type basic-ni

isdn spid1 40872739210101

isdn spid2 40872739240101

!

!

interface BRI1/0

no ip address

isdn switch-type basic-ni

isdn spid1 40872723080101

isdn spid2 40872738060101

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip access-group WHOIS_SRV in

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer string 9032000 class DOV

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxx password xxxxxxxxxxxx

ppp multilink

!

interface Dialer2

no ip address

!

interface Dialer3

no ip address

!

interface Dialer4

no ip address

!

interface Dialer5

no ip address

!

interface Dialer6

no ip address

!

router igrp 64

network 192.1.1.0

network 193.1.1.0

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 2 interface Dialer2 overload

ip nat inside source list 3 interface Dialer3 overload

ip nat inside source list 4 interface Dialer4 overload

ip nat inside source list 5 interface Dialer5 overload

ip nat inside source list 6 interface Dialer6 overload

ip classless

ip route 10.5.0.0 255.255.0.0 10.40.1.1

ip route 216.207.35.0 255.255.255.0 10.40.1.1

no ip http server

ip pim bidir-enable

!

!

ip access-list extended WHOIS_SRV

permit tcp any eq whois any

permit icmp any any ttl-exceeded

permit udp any eq domain any

permit icmp any any echo-reply

permit tcp any eq www any

deny ip any any

!

!

map-class dialer DOV

dialer isdn speed 56

access-list 1 permit 10.41.0.1

access-list 1 permit 10.40.5.1 log

access-list 1 permit 10.40.5.101

access-list 2 permit 10.40.5.102

access-list 3 permit 10.40.5.103

access-list 4 permit 10.40.5.104

access-list 5 permit 10.40.5.105

access-list 6 permit 10.40.5.106

access-list 101 remark ***Dialer 1 interesting traffic

access-list 101 permit tcp host 10.40.5.101 any eq whois

access-list 101 permit tcp host 10.40.5.101 any eq www

access-list 101 permit icmp host 10.40.5.101 any echo

access-list 101 permit icmp host 10.41.0.1 any echo

access-list 101 permit ip host 10.41.0.1 any log

access-list 101 permit icmp host 10.40.5.1 any echo log

access-list 101 remark ***Dialer 1 interesting traffic

access-list 101 remark ***Dialer 1 interesting traffic

access-list 102 remark ***Dialer 2 interesting traffic

access-list 102 permit tcp host 10.40.5.102 any eq whois

access-list 102 permit icmp host 10.40.5.102 any echo

access-list 102 permit tcp host 10.40.5.102 any eq www

access-list 102 remark ***Dialer 2 interesting traffic

access-list 102 remark ***Dialer 2 interesting traffic

access-list 103 remark ***Dialer 3 interesting traffic

access-list 103 permit tcp host 10.40.5.103 any eq whois

access-list 103 permit icmp host 10.40.5.103 any echo

access-list 103 permit tcp host 10.40.5.103 any eq www

access-list 103 remark ***Dialer 3 interesting traffic

access-list 103 remark ***Dialer 3 interesting traffic

access-list 104 remark ***Dialer 4 interesting traffic

access-list 104 permit tcp host 10.40.5.104 any eq whois

access-list 104 permit icmp host 10.40.5.104 any echo

access-list 104 permit tcp host 10.40.5.104 any eq www

access-list 104 remark ***Dialer 4 interesting traffic

access-list 104 remark ***Dialer 4 interesting traffic

access-list 105 remark ***Dialer 5 interesting traffic

access-list 105 permit tcp host 10.40.5.105 any eq whois

access-list 105 permit icmp host 10.40.5.105 any echo

access-list 105 permit tcp host 10.40.5.105 any eq www

access-list 105 remark ***Dialer 5 interesting traffic

access-list 105 remark ***Dialer 5 interesting traffic

access-list 106 remark ***Dialer 6 interesting traffic

access-list 106 permit tcp host 10.40.5.106 any eq whois

access-list 106 permit icmp host 10.40.5.106 any echo

access-list 106 permit tcp host 10.40.5.106 any eq www

access-list 106 remark ***Dialer 6 interesting traffic

access-list 106 remark ***Dialer 6 interesting traffic

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

dialer-list 3 protocol ip list 103

dialer-list 4 protocol ip list 104

dialer-list 5 protocol ip list 105

dialer-list 6 protocol ip list 106

!

route-map DIALER permit 10

match ip address 101

set interface Dialer1

!

route-map DIALER permit 20

match ip address 102

set interface Dialer2

!

route-map DIALER permit 30

match ip address 103

set interface Dialer3

!

route-map DIALER permit 40

match ip address 104

set interface Dialer4

!

route-map DIALER permit 50

match ip address 105

set interface Dialer5

!

route-map DIALER permit 60

match ip address 106

set interface Dialer6

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

SH VER:

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IK9S-M), Version 12.2(8)T1, RELEASE SOFTWARE (fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sat 30-Mar-02 23:30 by ccai

Image text-base: 0x60008930, data-base: 0x616DA000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

sc8-ipres uptime is 20 minutes

System returned to ROM by reload

System image file is "slot0:c3640-ik9s-mz.122-8.T1.bin"

cisco 3640 (R4700) processor (revision 0x00) with 124928K/6144K bytes of memory.

Processor board ID 17147750

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

Basic Rate ISDN software, Version 1.1.

4 FastEthernet/IEEE 802.3 interface(s)

3 ISDN Basic Rate interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

20480K bytes of processor board PCMCIA Slot0 flash (Read/Write)

Configuration register is 0x2102

Cisco Employee

Re: ISDN Dial Out

The config looks ok..I would start with the basic config..removing all the access-list and dialer interface and map-class.. leaving only BRI and dialer 1 config...

Looks like the debug that you have posted earlier is for "debug isdn events" and not for "debug isdn q931" right???

We need for "debug isdn q931" along with "debug ppp nego" (if we reach to ppp stage during the call)

BUT who is the internet service provider..Earthlink had provided the isdn lines along with internet service or else..?? You do need to talk to them about internet access over isdn..

191
Views
0
Helpful
9
Replies
CreatePlease to create content