Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ISDN Error: Illegal Interface BR0:1

hi

can someone tellme y i m getting this error while trying to connect to my ISP ?

its a working config and started behavin like this since ydy.

2d19h: %DIALER-6-BIND: Interface BRI0:1 bound to profile BRI0

2d19h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 24325585

2d19h: BR0:1 PPP: Treating connection as a callout

2d19h: BR0:1 PPP: Phase is ESTABLISHING, Active Open

2d19h: BR0:1 LCP: O CONFREQ [Closed] id 231 len 26

2d19h: BR0:1 LCP: MagicNumber 0x1A6DB94B (0x05061A6DB94B)

2d19h: BR0:1 LCP: MRRU 1524 (0x110405F4)

2d19h: BR0:1 LCP: EndpointDisc 1 Local (0x130C016164696461736D756D)

2d19h: ISDN BR0: Event: Connected to 24325585 on B1 at 64 Kb/s

2d19h: ISDN Error: Illegal Interface BR0:1

2d19h: ISDN Error: Illegal Interface BR0:1

2d19h: BR0:1 LCP: TIMEout: State REQsent

thx in adv

prem

3 REPLIES
VIP Purple

Re: ISDN Error: Illegal Interface BR0:1

Hello Prem,

your trace shows only outbound LCP CONFREQ messages and no inbound messages. This could be caused by an ISDN speed mismatch. Possibly your local or remote circuit does not support the 64K default speed.

Try to configure a map class (for dialer profiles), or adjust your dialer map statement (for legacy DDR) on both sides of the circuit.

Here is an example from CCO on how to configure this:

For Dialer Profiles:

maui-soho-01(config)#interface Dialer1

maui-soho-01(config-if)#dialer string 81560 class 56k! -- Dial 81560 and use the map-class named "56k" (defined below)

maui-soho-01(config-if)#exit

maui-soho-01(config)#map-class dialer 56k! -- map-class named "56k" that was used with the dialer string in int Dialer1maui-soho-01(config-map-clas)#dialer isdn speed 56! -- Set the speed of the call to be 56k (default is 64k)

For Legacy DDR (dialer maps):

maui-soho-01(config)#interface bri 0

maui-soho-01(config-if)#dialer map ip 10.1.1.1 name maui-nas-08 speed 56 81560

!-- The keyword speed 56 sets the outgoing call rate at 56k

Also, check if all interfaces (physical and dialer) are configured for ppp encapsulation.

Regards,

Georg Pauwen

Re: ISDN Error: Illegal Interface BR0:1

hi

to hve clear picture i hve attached the config here.

one channel is used for internet and the second channel is being used for vpn.

interface Tunnel0

ip address 10.1.1.6 255.255.255.252

no ip directed-broadcast

tunnel source x.x.x.x

tunnel destination y.y.y.y

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

no ip directed-broadcast

ip accounting output-packets

ip nat inside

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp multilink

!

interface Dialer0

ip address negotiated

ip access-group 177 in

ip access-group 178 out

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 900

dialer wait-for-carrier-time 10000

dialer string 12345678

dialer-group 1

ppp authentication pap callin

ppp pap sent-username yyyyyy password yyyyyyyy

!

interface Dialer1

ip address negotiated

no ip directed-broadcast

encapsulation ppp

dialer pool 1

dialer idle-timeout 900

dialer wait-for-carrier-time 10000

dialer string 12345678

dialer-group 1

ppp authentication pap callin

ppp pap sent-username ddddddd password ddddddd

!

ip nat inside source list 1 interface Dialer0 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 192.168.3.0 255.255.255.0 Tunnel0

ip route 192.168.4.0 255.255.255.0 Tunnel0

ip route 10.2.1.0 255.255.255.0 Dialer1

!

access-list 1 permit 192.168.1.0 0.0.0.255

prem

VIP Purple

Re: ISDN Error: Illegal Interface BR0:1

Hello Prem,

take the ppp multilink out of the physical BRI configuration, or leave it in and add it to your dialers as well.

Regards,

Georg

211
Views
0
Helpful
3
Replies
CreatePlease login to create content