Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Gurus HElp!

Halo CIscoer, help me on this ISDN debug:

12:24:38: CALL_PROC pd = 8 callref = 0xF5

12:24:163208757248: ISDN BR1/4: TX -> RRr sapi = 0 tei = 64 nr = 2

12:24:45: ISDN BR1/4: RX <- INFOc sapi = 0 tei = 64 ns = 2 nr = 1 i = 0x080

1F54508028090

12:24:45: DISCONNECT pd = 8 callref = 0xF5

12:24:45: Cause i = 0x8090 - Normal call clearing

12:24:193273528320: ISDN BR1/4: TX -> RRr sapi = 0 tei = 64 nr = 3

12:24:193273528320: BRI1/4: wait for isdn carrier timeout, call id=0x817F

12:24:195440255788: DDR: Dialing failed, 5 packets unqueued and discarded

12:24:195440239956: ISDN BR1/4: TX -> INFOc sapi = 0 tei = 64 ns = 1 nr = 3

i = 0x0801754D08028090

12:24:193273528320: RELEASE pd = 8 callref = 0x75

12:24:195440240252: Cause i = 0x8090 - Normal call clearing

12:24:45: ISDN BR1/4: RX <- RRr sapi = 0 tei = 64 nr = 2

12:24:45: ISDN BR1/4: RX <- INFOc sapi = 0 tei = 64 ns = 3 nr = 2 i = 0x080

1F55A08028090

12:24:45: RELEASE_COMP pd = 8 callref = 0xF5

12:24:45: Cause i = 0x8090 - Normal call clearing

12:24:195440239868: ISDN BR1/4: TX -> RRr sapi = 0 tei

Thank YOu

HATO

5 REPLIES
Silver

Re: ISDN Gurus HElp!

Cause i = 0x8090 - Normal call clearing ....80 means the cause code originator is the router itself.

90 means the call is most likely failing at a higher layer protocol such as PPP, authentication or idle timeout related issues. will need to verify the router configuration.

deb isdn q931 / deb ppp nego at both the end routers will be helpful + the show run on both.

Thanks, Mak.

New Member

Re: ISDN Gurus HElp!

This is the Center COnfig:

------------------------------------------

interface BRI1/3

description Connected to ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 4

isdn switch-type basic-net3

no cdp enable

interface Dialer4

description Connected from Bandung Branch using ISDN

ip address 192.168.252.13 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 040_RO_01 broadcast

dialer map ip 192.168.252.14 name 040_RO_01 broadcast 0224250099

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

This the Remote COnfig:

----------------------------------------

interface BRI0/0

description Connected to HQ using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Dialer1

description Connected to HQ using ISDN

ip address 192.168.252.18 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 010_RO_01 broadcast 02125530222

dialer map ip 192.168.252.17 name 010_RO_01 broadcast 02125530222

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

ppp authentication chap

ppp multilink

Please check this configuration, just wanna know: do I have to set a command at the physical interface with "ppp authentication chap"?

Thank YOu,

HATO

Cisco Employee

Re: ISDN Gurus HElp!

yes..You do need to have "ppp authentication chap" under the physical interface..With that command, config looks ok..So need to see the following debug as pointed by makchitale..

debug isdn q931

debug ppp authentication

debug ppp negotiation

term mon

Thanks...Tejal

Silver

Re: ISDN Gurus HElp!

The configs shown here do not seem to be for a matching pair (central & remote)...the dialer ip address do not match the dialer map next hop ip address commands.....Please collect the debugs on both the sides with msec timestamps.

Thanks, Mak.

New Member

Re: ISDN Gurus HElp!

--CENTRAL SITE------

-----------------------------

hostname 010_RO_01

!

enable secret 5

enable password 7

!

username 011_RO_01 password 7

username 012_RO_01 password 7

username 013_RO_01 password 7

username 040_RO_01 password 7

username 030_RO_01 password 7

username 050_RO_01 password 7

username 010_RO_02 password 7

!

!

!

!

no ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.10.254 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

bridge-group 1

!

interface Serial0/0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no fair-queue

bridge-group 1

!

interface Serial0/0.1 multipoint

ip address 192.168.253.1 255.255.255.0

no ip directed-broadcast

frame-relay map bridge 80 broadcast

frame-relay map bridge 70 broadcast

frame-relay map bridge 60 broadcast

frame-relay map bridge 50 broadcast

frame-relay map bridge 30 broadcast

frame-relay map bridge 20 broadcast

frame-relay map bridge 40 broadcast

frame-relay map ip 192.168.253.2 60 broadcast

frame-relay map ip 192.168.253.4 50 broadcast

frame-relay map ip 192.168.253.5 40 broadcast

frame-relay map ip 192.168.253.6 20 broadcast

frame-relay map ip 192.168.253.7 30 broadcast

frame-relay map ip 192.168.253.8 70 broadcast

frame-relay map ip 192.168.253.9 80 broadcast

bridge-group 1

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0/2

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0/3

no ip address

no ip directed-broadcast

shutdown

!

interface BRI1/0

description Connected from Cikarang Branch using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface BRI1/1

description Connected from Thamrin Branch using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 2

isdn switch-type basic-net3

no cdp enable

!

interface BRI1/2

description Connected from Kota Branch using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 3

isdn switch-type basic-net3

no cdp enable

!

interface BRI1/3

description Connected to Bandung using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 4

isdn switch-type basic-net3

no cdp enable

!

interface BRI1/4

description Connected to Surabaya Branch usingISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer rotary-group 5

isdn switch-type basic-net3

no cdp enable

!

interface BRI1/5

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

isdn switch-type basic-net3

!

interface BRI1/6

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface Dialer1

description Connected from Cikarang Branch using ISDN

ip address 192.168.252.5 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 013_RO_01 broadcast

dialer map ip 192.168.252.6 name 013_RO_01 broadcast 28600056

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer2

description Connected from Thamrin Branch using ISDN

ip address 192.168.252.25 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 012_RO_01 broadcast

dialer map ip 192.168.252.26 name 012_RO_01 broadcast 23550106

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer3

description Connected from Kota Branch using ISDN

ip address 192.168.252.9 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 011_RO_01 broadcast

dialer map ip 192.168.252.10 name 011_RO_01 broadcast 26500071

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer4

description Connected from Bandung Branch using ISDN

ip address 192.168.252.13 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 040_RO_01 broadcast

dialer map ip 192.168.252.14 name 040_RO_01 broadcast 0224250099

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer5

description Connected from Surabaya Branch using ISDN

ip address 192.168.252.17 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 030_RO_01 broadcast

dialer map ip 192.168.252.18 name 030_RO_01 broadcast 0315600119

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot server 15 dialer

no cdp enable

ppp authentication chap

ppp multilink

!

router igrp 1

network 192.168.10.0

network 192.168.252.0

network 192.168.253.0

!

ip classless

ip route 192.168.11.0 255.255.255.0 192.168.252.10 150

ip route 192.168.12.0 255.255.255.0 192.168.252.26 150

ip route 192.168.13.0 255.255.255.0 192.168.252.6 150

ip route 192.168.30.0 255.255.255.0 192.168.252.18 150

ip route 192.168.40.0 255.255.255.0 192.168.252.14 150

ip route 192.168.50.0 255.255.255.0 192.168.252.22 150

no ip http server

!

access-list 101 deny igrp any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

---REMOTESITE_1----

------------------------------

hostname 040_RO_01

!

boot system flash:c2600-i-mz.120-7.T

enable secret 5

enable password 7

!

username 010_RO_01 password 7

username 010_RO_02 password 7

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

isdn voice-call-failure 0

chat-script default ABORT ERROR ABORT BUSY ABORT "NO ANSWER" "" "ATDT\T" TIMEOUT

60 CONNECT \c

!

!

!

interface FastEthernet0/0

ip address 192.168.40.254 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

speed auto

half-duplex

bridge-group 1

!

interface Serial0/0

backup delay 1 120

backup interface Dialer1

ip address 192.168.253.5 255.255.255.0

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no fair-queue

frame-relay map ip 192.168.253.1 40 broadcast

bridge-group 1

!

interface BRI0/0

description Connected to HQ using ISDN

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Serial0/1

physical-layer async

description connected to 010_RO_02

no ip address

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer rotary-group 2

async mode dedicated

fair-queue 64 16 0

no cdp enable

!

interface Dialer1

description Connected to HQ using ISDN

ip address 192.168.252.14 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer map snapshot 1 name 010_RO_01 broadcast 02125530221

dialer map ip 192.168.252.13 name 010_RO_01 broadcast 02125530221

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer2

description connected to 010_RO_02

ip address 192.168.251.14 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer hold-queue 10

dialer-group 1

snapshot client 15 360 suppress-statechange-update dialer

pulse-time 3

no cdp enable

ppp authentication chap

!

router igrp 1

network 192.168.40.0

network 192.168.252.0

network 192.168.253.0

!

ip classless

ip route 192.168.10.0 255.255.255.0 192.168.252.13 150

ip route 192.168.10.0 255.255.255.0 192.168.251.13 200

-------------------------------------------------------------------------------------------------

1.When I try config using Config Maker...... the remote site do not have these command:

-dialer map snapshot 1 name 010_RO_01 broadcast xxxxxxxxxxx

-snapshot client 15 360 suppress-statechange-update dialer

and the "backup delay 1 1".

2.When I do a shutdown on the serial0/0 at central site. Debug only show that bri1/3 and bri1/4 make a call.

3.Why the remote router do not make a dial first.

Thank You

HATO

101
Views
0
Helpful
5
Replies