Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN Layer 2 Problem & Bus Error (australia)

Hi All,

I am having problems getting multi-frame established... I have a 1603R and am ultimately trying to make a DoV connection - but I'll settle for a data one as well. Layer 2 comes up and then goes down almost immediately - then when it dials I get a bus error? I assume because the frame is not established?

If I try a std data call I get the same problem. Have tried setting setting tei to neg on first call to no avail - bus error on dial as well. Called Telstra (telco) and they say it is setup as point to multi-point. Others have tried my config and say it is fine. Any ideas what to try next?

Details below...

droopa#show isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 104, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

I_Queue_Len 0, UI_Queue_Len 0

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Number of L2 Discards = 0, L2 Session ID = 6

0:02:51: ISDN BR0: L1 is IF_ACTIVE

00:02:51: ISDN BR0 EVENT: isdn_sw_cstate: State = 4, Old State = 4

00:02:51: ISDN BR0: Incoming call id = 0x0003, dsl 0

00:02:51: ISDN BR0: Shutting down ME

00:02:51: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 84 changed to down

00:02:51: ISDN BR0: Shutting down ISDN Layer 3

00:02:51: ISDN BR0: TX -> IDREQ ri=1463 ai=127

00:02:51: ISDN BR0: RX <- IDASSN ri=1463 ai=85

00:02:51: ISDN BR0: TX -> SABMEp c/r=0 sapi=0 tei=85

00:02:51: ISDN BR0: RX <- UAf c/r=0 sapi=0 tei=85

00:02:51: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 85 changed to up

00:02:51: L3: L3_GetUser_NLCB returned NULL, message ignored cid 0x0 cr 0x0 ev 0

x203 ces 1 dsl 0

00:03:01: ISDN BR0: TX -> RRp sapi=0 tei=85 nr=0

00:03:01: ISDN BR0: RX <- RRf sapi=0 tei=85 nr=0

00:03:06: ISDN BR0: RX <- DISCp c/r=1 sapi=0 tei=85

00:03:06: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 85 changed to down

00:03:06: ISDN BR0: TX -> UAf c/r=1 sapi=0 tei=85

00:26:33: BR0 DDR: rotor dialout [priority]

00:26:33: BR0 DDR: Dialing cause ip (s=192.168.0.2, d=172.16.20.53)

00:26:33: BR0 DDR: Attempting to dial 0243375600

00:26:33: ISDN BR0: Outgoing call id = 0x8001, dsl 0

00:26:33: ISDN BR0: Event: Call to 0243375600 at 64 Kb/s

00:26:33: ISDN BR0: process_bri_call(): call id 0x8001, called_number 0243375600

, speed 64, call type DATA

*** BUS ERROR ***

access address = 0xffffffff

program counter = 0x240ab60

status register = 0x2700

vbr at time of exception = 0x4000000

special status word = 0x006d

faulted cycle was a byte read

Using 2729 out of 7506 bytes!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

! ISP 56K Phone Number 0243375608

! ISP 64K Phone Number 0243375609

! DNS 1 203.24.133.1

! DNS 2 203.24.133.2

!

hostname droopa

!

enable secret xxxxxxx

enable password yyyyyy

!

username user password pass

clock timezone aest 10

ip subnet-zero

!

no ip domain-lookup

ip name-server 203.24.133.1

ip name-server 203.24.133.2

!

! basic-net3 is the correct ISDN switch type for use in Australia

! Cisco Fast Step includes the incorrect type.

!

isdn switch-type basic-net3

!

! Configure internal Ethernet interface

! Set IP and configure NAT

!

interface Ethernet0

description Private LAN Interface

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

! Configure BRI interface

!

interface BRI0

description ISDN WAN Interface

no ip address

!ip nat outside -- m again

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

!

! Configure Dialer1

!

interface Dialer1

description Connect to ECN Internet

ip address negotiated

ip nat outside

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer in-band

dialer idle-timeout 2147483

dialer string 0243375609 class DOV

dialer hold-queue 25

dialer load-threshold 10

dialer-group 4

no cdp enable

!ppp authentication pap callin

ppp authentication chap

ppp chap hostname narara

ppp chap password 7 045F110B5E711519

ppp pap sent-username user password pass

ppp multilink

!

! Added on M

!

dialer-list 4 protocol appletalk deny

dialer-list 4 protocol ipx deny

dialer-list 4 protocol netbios deny

dialer-list 4 protocol ip permit

!

! Enable NAT for the Dialer 1 interface

!

ip nat inside source list 1 interface Dialer1 overload

!

! To enable passthrough for incoming IKE VPN traffic

!

!ip nat inside source static esp 192.168.0.1 interface Dialer1

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!Enable DoV - and set speed to 56k (if required)

!

map-class dialer DOV

dialer voice-call

dialer isdn speed 56 spc

!

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 5 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

!

! Set console and telnet access + password

!

line con 0

login

stopbits 1

line vty 0 4

access-class 5 in

exec-timeout 0 0

password pass

login

!

no rcapi server

!

end

System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

C1600 platform with 16384 Kbytes of main memory

program load complete, entry point: 0x4020060, size: 0x165eac

%SYS-4-CONFIG_NEWER: Configuration from version 12.2 may not be correctly unders

tood

%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.

program load complete, entry point: 0x2005000, size: 0x31dd08

Self decompressing the image : ####################### [OK]

Cisco Internetwork Operating System Software

IOS (tm) 1600 Software (C1600-Y-M), Version 12.2(12a), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Tue 24-Sep-02 05:06 by pwade

Image text-base: 0x02005000, data-base: 0x026602A4

cisco 1603 (68360) processor (revision C) with 12288K/4096K bytes of memory.

Processor board ID 16315448, with hardware revision 00000002

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

1 ISDN Basic Rate interface(s)

System/IO memory with parity disabled

8192K bytes of DRAM onboard 8192K bytes of DRAM on SIMM

System running from RAM

7K bytes of non-volatile configuration memory.

4096K bytes of processor board PCMCIA flash (Read/Write)

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: ISDN Layer 2 Problem & Bus Error (australia)

My mistake..bootstrep version is fine..I have just overlooked that as ios version..CSCin10546 is fixed in 12.2.11.T2 so i think thats the best choice for ios on 1600 to resolve this issue.

6 REPLIES
Cisco Employee

Re: ISDN Layer 2 Problem & Bus Error (australia)

Here is the url which has a sample config for DOV call.

http://www.cisco.com/warp/public/793/access_dial/8.html

I would say 12.0.3.T is bit old ios so pl. try to go near the latest ios based on the memory requirement. OR Pl. post the "sh stack" to know what process is causing the crash.

New Member

Re: ISDN Layer 2 Problem & Bus Error (australia)

I have a 12.2 image but do I have to do something different to update the bootstrap? I will post the stack tonight (in a few hours)

New Member

Re: ISDN Layer 2 Problem & Bus Error (australia)

Here is the stack trace

router#sh stack

Minimum process stacks:

Free/Size Name

768/1000 c1000 LED

1912/4000 Init

3460/4000 RADIUS INITCONFIG

Interrupt level stacks:

Level Called Unused/Size Name

4 393 2600/3000 CPIC interrupts

7 0 2976/3000 Programmable Interval Timer

System was restarted by bus error at PC 0x240AB66, address 0x5F

1600 Software (C1600-Y-M), Version 12.2(12a), RELEASE SOFTWARE (fc1)

Compiled Tue 24-Sep-02 05:06 by pwade (current version)

Image text-base: 0x02005000, data-base: 0x026602A4

Stack trace from system failure:

FP: 0x26D6598, RA: 0x2415AA4

FP: 0x26D65C8, RA: 0x23975F4

FP: 0x26D65E0, RA: 0x2396F06

FP: 0x26D65E8, RA: 0xFFFFFFFF

***************************************************

******* Information of Last System Crash **********

***************************************************

Cisco Employee

Re: ISDN Layer 2 Problem & Bus Error (australia)

CSCdy47444 (which is duped to CSCin10546) is the perfact match for that crash. Pl. view that in bug toolkit and upgrade the 1600 with the one of the resolved image to solve the problem.

Cisco Employee

Re: ISDN Layer 2 Problem & Bus Error (australia)

My mistake..bootstrep version is fine..I have just overlooked that as ios version..CSCin10546 is fixed in 12.2.11.T2 so i think thats the best choice for ios on 1600 to resolve this issue.

New Member

Re: ISDN Layer 2 Problem & Bus Error (australia)

problem with RAM...try replacing it..atleast u can make a test call with the new one.

242
Views
0
Helpful
6
Replies
CreatePlease login to create content