Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN leased line config in CISCO 1603 router

Hi everybody,

After having read the documentation and wandered through the Cisco's site I turn to this forum as the last resort.

I have a task of configuring a leased ISDN line attached to 1603 which will be accessed by a single PC connected directly to the router's Ethernet port. The ISDN switch type is not important because I use an NT-1 terminal connected to a U-interface simulator that can set/unset a loopback, activate and deactivate the link. The router has IOS version 12 which seems to be slightly different from what the S/W Config Guide is based on. In particular, the document refers to ISDN subinterfaces which are not supported by this S/W version.

I managed to configure the Ethernet port and ping the connection to the PC in both direction. Now I am stuck at the virtual template interface configuration: ping does not goes through it at all and fails on timeout.

I would appreciate if someone answers me the following questions:

- How do I choose an IP address and subnet mask for a virtual template interface that represents the ISDN line?

- What debug commands should I use and what should I watch in their printout so that to trace the overall ping path?

3 REPLIES
New Member

Re: ISDN leased line config in CISCO 1603 router

hello Yuryburk,

If you connect to isp with isdn and isp give you fixed ip address a /30 should be enough.

If this is not fixed ip address, the you can configure your dialer interface like this:

interface bri 0

encapsulation PPP

dialer pool-member 1

ppp authentication chap

interface Dialer1

description Dialer to ISP

bandwidth 2000

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname aaaaaa

ppp chap password xxxxxxxx

ppp ipcp dns request

ppp ipcp mask request

ppp ipcp address accept

dialer-list 1 protocol ip permit

for the debug commands use

debug isdn q921 - layer 2

debug isdn q931 - layer 3

debug dialer

debug ppp negotiation

debug ppp athentication

you may need NAT also to translate your lan ip address to public (dialer) ip address.

Please rate if this help

Cisand2002

New Member

Re: ISDN leased line config in CISCO 1603 router

Hi Cisand,

Thanks for your prompt reply. It gives me some directions but unfortunately does not relate exactly to my job: I am asked to establish a leased line while your answer considers the ISDN dialer interface.

Nevertheless, what you write is very interesting to me.

You wrote:

- if... isp give you fixed ip address a /30 should be enough.

How do I set the /30 configuration?

- you may need NAT also to translate your lan ip address to public (dialer) ip address.

Should I create the NAT in the router or it is enough to provide the appropriate routing rule in the client PC?

Your answers will be very appreciated.

New Member

Re: ISDN leased line config in CISCO 1603 router

Hello,

A leased line? ok what type of interface you have to the isp ? maybe if you put the router config it can clarify. but let me answer using dialer example

if ISP provide with with /30 you can configure it under the interface. you should be able to ping remote end.

then you configure your lan :

============

int fastethernet 0/0

ip address 192.168.1.0 255.255.255.0

ip nat inside

interface dialer 1

ip nat outside

ip nat inside source list 101 interface Dialer1 overload

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

============

This will translate any private address from you lan to a registred ip address (provided by ISP and configured under Dialer1)

HTH

regards,

Cisand

237
Views
3
Helpful
3
Replies
CreatePlease to create content