Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN;Mandatory IE missing

Greetings,

I have two 2500 series routers with BRI/NT1. I am trying to set them up in a lab scenario using a Emutel ISDN switch simulator. Everything looks good up through layer 2. When I try and ping the other the remote side I get:

%SYS-5-CONFIG_I: Configured from console by console

ISDN BR0: TX -> SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x8890

Channel ID i = 0x83

Keypad Facility i = '3840000'

ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x81

Channel ID i = 0x89

Signal i = 0x05 - Confirm tone on

ISDN BR0: RX <- PROGRESS pd = 8 callref = 0x81

Cause i = 0x8092 - No user responding

Progress Ind i = 0x8088 - In-band info or appropriate now available

Signal i = 0x01 - Ring back tone on

ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x81

Cause i = 0x8092 - No user responding

Signal i = 0x03 - Network congestion tone on

ISDN BR0: TX -> RELEASE pd = 8 callref = 0x01

Cause i = 0x8090 - Normal call clearing

ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x81

Signal i = 0x3F - Tones off

The remote side get's:

%SYS-5-CONFIG_I: Configured from console by console

ISDN BR0: RX <- SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x8890

Channel ID i = 0x89

Signal i = 0x40 - Alerting on - pattern 0

Calling Party Number i = 0x0083, '3840200'

Called Party Number i = 0x80, '3840000'

Locking Shift to Codeset 6

Codeset 6 IE 0x26 i = 0x0101

%LINK-3-UPDOWN: Interface BRI0:1, changed state to up

%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 3840200

ISDN BR0: TX -> CONNECT pd = 8 callref = 0x81

ISDN BR0: RX <- RELEASE pd = 8 callref = 0x01

Cause i = 0x80E0 - Mandatory IE missing

Signal i = 0x4F - Alerting off

%LINK-3-UPDOWN: Interface BRI0:1, changed state to down

I have tried looking up this "Mandatory IE missing" with no luck. Anyone have any idea's?

Thanks.

1 REPLY

Re: ISDN;Mandatory IE missing

Remote side did not send Alerting therefore calling side terminate call.

Why ?

I don't know, very little info. First you must check you configuration

then evaluate for IOS bug

Try to confige isdn send-alerting.

667
Views
0
Helpful
1
Replies
CreatePlease login to create content