Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN PRI and BRI

Hi,

Currently, we've a customer running FR over EIGRP and being backup by ISDN, which means when the serial is down, the isdn should take over, but it doesn't. Below are the config and version for the HQ and branch router.

Thanks in advance.

HQ

--

HQ#sh run

Building configuration...

Current configuration : 6416 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname HQ

!

enable secret 5 $1$IAZJ$yv.lrWLgr5sEGdHl/46vg.

!

username branch password 7 branch

clock timezone MAS 8

ip subnet-zero

!

!

no ip domain-lookup

!

isdn switch-type primary-net5

!

controller E1 2/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

interface Loopback0

ip address 20.20.20.1 255.255.255.224

!

interface FastEthernet0/0

ip address 128.128.1.251 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

bandwidth 512

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.301 point-to-point

description **connection to branch**

ip address 192.168.25.5 255.255.255.252

frame-relay interface-dlci 301

!

interface Serial0/0.302 point-to-point

description **connection to branch2**

ip address 192.168.25.9 255.255.255.252

frame-relay interface-dlci 302

!

interface Serial0/0.303 point-to-point

description **connection to branch3**

ip address 192.168.25.13 255.255.255.252

frame-relay interface-dlci 303

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clockrate 2000000

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial2/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

ppp authentication chap

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap

!

router eigrp 1

network 20.0.0.0

network 128.128.0.0

network 192.168.25.0

no auto-summary

no eigrp log-neighbor-changes

no eigrp log-neighbor-warnings

!

ip classless

ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

!

end

HQ# sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3700 Software (C3745-I-M), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Thu 20-Jun-02 14:50 by ccai

Image text-base: 0x60008940, data-base: 0x60AEC000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

HQ uptime is 2 minutes

System returned to ROM by power-on

System image file is "flash:c3745-i-mz.122-8.T5.bin"

cisco 3745 (R7000) processor (revision 53.51) with 131072K/13312K bytes of memor

y.

Processor board ID

R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

3 FastEthernet/IEEE 802.3 interface(s)

31 Serial network interface(s)

2 Serial(sync/async) network interface(s)

1 Channelized E1/PRI port(s)

DRAM configuration is 64 bits wide with parity disabled.

151K bytes of non-volatile configuration memory.

31360K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x101

BRANCH

------

branch#sh run

Building configuration...

Current configuration : 3451 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname branch

!

enable secret 5 branch

!

username HQ password 7 branch

ip subnet-zero

!

!

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 20.20.20.2 255.255.255.224

!

interface FastEthernet0/0

ip address 128.128.26.251 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

bandwidth 64

no ip address

encapsulation frame-relay IETF

shutdown

frame-relay lmi-type ansi

!

interface Serial0/0.300 point-to-point

description ***(HQ1)**

ip address 192.168.25.6 255.255.255.252

frame-relay interface-dlci 300

!

interface Serial0/0.301 point-to-point

description *** (HQ2)**

ip address 192.168.26.6 255.255.255.252

frame-relay interface-dlci 301

!

interface Serial0/0.302 point-to-point

description *** (HQ3)**

ip address 192.168.27.6 255.255.255.252

frame-relay interface-dlci 302

!

interface Serial0/0.400 point-to-point

description *** (NCC)**

ip address 192.168.30.6 255.255.255.252

frame-relay interface-dlci 400

!

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface Serial0/1

bandwidth 64

backup delay 5 60

backup interface BRI0/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Dialer1

description **Backup HQ1**

ip unnumbered Loopback0

ip access-group ISDN_Backup out

encapsulation ppp

dialer pool 1

dialer idle-timeout 180

dialer string 0326170160

dialer-group 1

ppp authentication chap

!

router eigrp 1

network 20.0.0.0

network 128.128.0.0

network 192.168.25.0

network 192.168.26.0

network 192.168.27.0

network 192.168.30.0

network 192.168.31.0

distribute-list 1 in

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

ip access-list extended ISDN_Backup

permit ip any any

!

access-list 1 permit 128.128.1.0 0.0.0.255

access-list 1 permit 128.128.11.0 0.0.0.255

access-list 1 permit 161.72.0.0 0.0.255.255

access-list 1 permit 161.80.0.0 0.0.255.255

access-list 1 permit 10.10.0.0 0.0.255.255

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

!

time-range ISDN_Backup

periodic weekdays 8:00 to 20:00

periodic Saturday 8:00 to 20:00

!

!

end

branch>sh version

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Fri 21-Jun-02 08:50 by ccai

Image text-base: 0x80008074, data-base: 0x80A2BD40

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

Branch uptime is 3 days, 8 hours, 24 minutes

System returned to ROM by power-on

System image file is "flash:c2600-i-mz.122-8.T5.bin"

cisco 2620XM (MPC860P) processor (revision 0x100) with 28672K/4096K bytes of mem

ory.

Processor board ID JAD06470HD7 (914285734)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

  • Other Network Infrastructure Subjects
13 REPLIES
Bronze

Re: ISDN PRI and BRI

Hi

Does the bri interface come up if the FR is down?

So if it comes up the call is placed but the routing over it possibly does not work. If the bri just stays down no call is placed.

What does "debug dialer" show?

Regards

Roger

New Member

Re: ISDN PRI and BRI

Roger,

Before the fr is down, the bri0/0 is in standby mode, but when the fr is down, the bri0/0 is up but it does not dial. Debug dialer doesn't shows anything.

Is there anything wrong with the config or the version?

Thanks.

Bronze

Re: ISDN PRI and BRI

HI

So it looks as there are no interesting packet to bring up the isdn. So could be about the routing.

You are running EIGRP...do you want to run EIGRP also

over the isdn?

You also work with ip unnumbered.

Can you give it an ip address also on the remote site. Then define a static route to the dialer interface with a high admin distance.

like:

interface dialer 1

ip address 172.16.1.1 255.255.255.252

encapsulation ppp

dialer pool 1

dialer idle-timeout 180

dialer string 0326170160

dialer-group 1

ppp authentication chap

!

ip route 0.0.0.0 0.0.0.0 172.16.1.2 180

!

Now do the debug dialer again. Now if there is traffic and the serial is down the static route shoul kick in and bring bring up the bri.

Can you try that?

Here also a link on how to configure ddr with dialer profiles.

http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080093c2e.shtml

Hope it helps

Roger

Silver

Re: ISDN PRI and BRI

On the branch side you do not need the ACL ISDN_Backup out on the dialer ,

Add this to the ACL that defines interesting traffic

permit ip any any time-range ISDN_Backup .

turn on debug dialer

Could you ping 20.20.20.1 and source it from the dialer 1 .

On the branch the sh ver shows that the BRI does not have an internal NT1 , is this in North America ? if it is you will need an external NT1

could you paste in sh isdn st from both sides , also debug isdn q921 & isdn q931

New Member

Re: ISDN PRI and BRI

Didnt understand why you have given backup interface on serial 0/1 when you have configured serial 0/0 with frame relay and connected to HQ with subinterfaces.

give the back up interface on the subinterface on the subinterface which needs back up.

i think what u have given is misconfiguration

snippet from ur configuration shows serial 0/0 is configured with HQ but s0/1 is provided with backup interface.

interface Serial0/0

bandwidth 64

no ip address

encapsulation frame-relay IETF

shutdown

frame-relay lmi-type ansi

!

interface Serial0/0.300 point-to-point

description ***(HQ1)**

ip address 192.168.25.6 255.255.255.252

frame-relay interface-dlci 300

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface Serial0/1

bandwidth 64

backup delay 5 60

backup interface BRI0/0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

-Deepu

New Member

Re: ISDN PRI and BRI

Guys,

Actually I'm trying to do an isdn backup on the serial interface or the frame relay, but it seems that the isdn doesn't initiate the call until i rebooted the router. I've removed all the access-list on the time range.

One more question, how do i configure the date/time for the router ? I used the 'clock set' command, but when the router is rebooted, the date/time is changed back to default.

Thanks..

Bronze

Re: ISDN PRI and BRI

Hi

Time will be lost whenever you reboot a router and you have set the time manually.

You could enable NTP/SNTP so you router will synchronise the time from an NTP source. Check the config guides on NTP/SNTP:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/fcfprt3/fcf012.htm#1001170

Regards

Roger

New Member

Re: ISDN PRI and BRI

Hi Roger,

What if there's not NTP server available ? Any other options ?

Thanks..

New Member

Re: ISDN PRI and BRI

Hi,

Since the time cannot be saved, I think i've no choice but to use access list to control the dialing, but the isdn backup will be running on eigrp also, which there'll be a hello packet every 60 seconds, which is irrelavant if there's no interesting traffic, i've tried to deny the hello packet in the access list and permit other ip packet, but its still dialing when there's an eigrp hello packet.

access-list 101 deny ip any 224.0.0.10

access-list permit ip any any

Is the access list correct, or do we have other way ?

Thanks in advance..

286
Views
0
Helpful
13
Replies