Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
t1b
New Member

isdn problem

Hi all,

I have a 1750 and 1751 router setup for isdn. I can make a call from the 1751 to the 1750 with no problem, however when I make a call from the 1750 to the 1751 I get the following error:

Received a call with a bad bearer cap

Does anyone know what that means? I think long distance carrier may have the circuit setup as voice, but I am not sure.

9 REPLIES
Silver

Re: isdn problem

can you paste in a sh run from each

t1b
New Member

Re: isdn problem

Here they are:

1751

Current configuration : 1362 b

!

version 12.2

service timestamps debug uptim

service timestamps log datetim

no service password-encryption

!

hostname DCrtr

!

!

username GoshenRTR password 0

username DCrtr password 0 conn

memory-size iomem 25

clock timezone est 5

ip subnet-zero

!

ipx routing 0004.2722.bc3a

!

isdn switch-type basic-dms100

!

interface FastEthernet0/0

ip address 172.16.100.254 255.255.255.0

ip helper-address 172.16.10.224

speed auto

ipx network E000000F

!

interface Serial0/0

ip address 172.16.250.2 255.255.255.252

ipx network 2501

no fair-queue

!

interface BRI1/0

ip address 172.16.251.1 255.255.255.252

encapsulation ppp

dialer idle-timeout 300

dialer map ip 172.16.251.2 11232344567

dialer-group 1

isdn switch-type basic-dms100

isdn spid1 12312312330101 12312330101

isdn spid2 12312312340101 12312340101

isdn incoming-voice data 64

ppp authentication chap

ppp multilink

!

router eigrp 1

network 172.16.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.250.1

no ip http server

!

!

logging trap debugging

dialer-list 1 protocol ip permit

!

!

!

snmp-server community cisco RO

1750

Current configuration : 1252 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname GoshenRTR

!

enable secret 5 $1$mlMX$KtTNUI6Sa6WdJ5wrYPI0z1

!

username DCrtr password 0 connect

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip finger

!

ipx routing 0004.2722.ba2f

isdn switch-type basic-5ess

!

!

interface Serial0

ip address 172.16.250.6 255.255.255.252

ipx network 2502

!

interface BRI0

ip address 172.16.251.2 255.255.255.252

encapsulation ppp

dialer idle-timeout 300

dialer map ip 172.16.251.1 11231231233

dialer map ip 172.16.251.1 11231231234

dialer-group 1

isdn switch-type basic-5ess

isdn spid1 0123456790

isdn spid2 0123456780

ppp authentication chap

ppp multilink

!

interface FastEthernet0

ip address 172.16.110.254 255.255.255.0

ip helper-address 172.16.10.224

speed auto

ipx network 4000000A

!

router eigrp 1

network 172.16.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.250.5

no ip http server

!

dialer-list 1 protocol ip permit

!

!

!

snmp-server community cisco RO

snmp-server community ciscocisco RW

!

line con 0

transport input none

line aux 0

line vty 0 4

Re: isdn problem

Hi,

Can you paste outputs of a debug isdn q931 on this router ? Dont give the debug during peak hours. ( it can hamper router performance)

t1b
New Member

Re: isdn problem

Here is the 1750, it is the one initiating the call:

30w6d: ISDN BR0: TX -> SETUP pd = 8 callref = 0x1F

30w6d: Bearer Capability i = 0x8890

30w6d: Channel ID i = 0x83

30w6d: Keypad Facility i = '11231231234'

30w6d: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x9F

30w6d: Channel ID i = 0x89...

30w6d: ISDN BR0: RX <- PROGRESS pd = 8 callref = 0x9F

30w6d: Progress Ind i = 0xC48A - Delay in response at called interface

30w6d: Signal i = 0x01 - Ring back tone on

30w6d: ISDN BR0: HOST_PROGRESS: Got IE of INBAND or Not End-To-End.

30w6d: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x9F

30w6d: Cause i = 0x8492 - No user responding

30w6d: Signal i = 0x01 - Ring back tone on

30w6d: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x1F

30w6d: Cause i = 0x8090 - Normal call clearing

30w6d: ISDN BR0: TX -> SETUP pd = 8 callref = 0x20

30w6d: Bearer Capability i = 0x8890

30w6d: Channel ID i = 0x83

30w6d: Keypad Facility i = '11231231234'

30w6d: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x9F

30w6d: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xA0

30w6d: Channel ID i = 0x89.

Success rate is 0 percent (0/5)

GoshenRTR#u

30w6d: ISDN BR0: RX <- PROGRESS pd = 8 callref = 0xA0

30w6d: Progress Ind i = 0xC48A - Delay in response at called interface

30w6d: Signal i = 0x01 - Ring back tone on

30w6d: ISDN BR0: HOST_PROGRESS: Got IE of INBAND or Not End-To-Endndebug a

30w6d: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0xA0

30w6d: Cause i = 0x8492 - No user responding

30w6d: Signal i = 0x01 - Ring back tone on

30w6d: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x20

30w6d: Cause i = 0x8090 - Normal call clearing

30w6d: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0xA0

Here is the 1751, the receiving router:

6d20h: ISDN BR1/0 Q931: RX <- SETUP pd = 8 callref = 0x53

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Signal i = 0x40 - Alerting on - pattern 0

Calling Party Number i = 0x21, 0x83, '2342342345'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '1231233'

Plan:ISDN, Type:Subscriber(local)

6d20h: ISDN BR1/0 **ERROR**: host_incoming_call: Received a call with a bad bearer cap from 2342342345 on B1

6d20h: ISDN BR1/0 Q931: RX <- SETUP pd = 8 callref = 0x53

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Signal i = 0x40 - Alerting on - pattern 0

Calling Party Number i = 0x21, 0x83, '2342342345'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '1231233'

Plan:ISDN, Type:Subscriber(local)

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808001038D0E, 'COMPANY NAME', 0x8001038B0C, '

845 294-6253', 0x8001088001, '('

6d20h: ISDN BR1/0 **ERROR**: host_incoming_call: Received a call with a bad bearer cap from 2342342345 on B1

6d20h: ISDN BR1/0 Q931: RX <- SETUP pd = 8 callref = 0x54

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Signal i = 0x40 - Alerting on - pattern 0

Calling Party Number i = 0x21, 0x83, '2342342345'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '1231234'

Plan:ISDN, Type:Subscriber(local)

6d20h: ISDN BR1/0 **ERROR**: host_incoming_call: Received a call with a bad bearer cap from 2342342345 on B1

6d20h: ISDN BR1/0 Q931: RX <- SETUP pd = 8 callref = 0x54

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Signal i = 0x40 - Alerting on - pattern 0

Calling Party Number i = 0x21, 0x83, '2342342345'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '1231234'

Plan:ISDN, Type:Subscriber(local)

Locking Shift to Codeset 5

Codeset 5 IE 0x2A i = 0x808001038D0E, 'COMPANY NAME', 0x8001038B0C, '

234 234-2345', 0x8001088001, '('

6d20h: ISDN BR1/0 **ERROR**: host_incoming_call: Received a call with a bad bearer cap from 2342342345 on B1

Re: isdn problem

I think, you should verify the number that's being called by the 1750 with the service provider. The error code 0x8492 (: Cause i = 0x8492 - No user responding ) denotes that the number the 1750 dialed is not reachable. You should check the number you have configured as well as whether that number is a valid one. Also check if you need to dial a 9 (for the pbx) or a 1010220, because the number you might be calling needs a long distance code to be prefixed.

t1b
New Member

Re: isdn problem

I don't think that is the problem. The call makes it to the other router, but it won't connect because of "bad bearer cap". If I make a voice call to the number, I get the same error message, even though the call is never connected.

Silver

Re: isdn problem

try a map class to force 56K some legacy switches will nnot support 64K

global

map-class dialer test

dialer isdn speed 56

on the interface

dialer string 5551212 class test

dialer string 5551212 class test

Bronze

Re: isdn problem

This error usually indcates a discrepency between how the line has been configured and how it was provisioned. It think you need to remove the "isdn incomng-voice data 64" statement from the 1751. It is receiving calls on a line that is not capable of carrying voice calls but it is configured to handle voice calls.

t1b
New Member

Re: isdn problem

I tend to agree with you about the provisioning. I added the incoming-voice statement as a test. I am contacting the provider now to make sure it is done correctly. To me it looks like the call is coming in as a voice call not data. The calling router says it is a "data" call so I am thinking the receiving switch is the problem.

278
Views
0
Helpful
9
Replies
CreatePlease to create content