Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ISDN to only come up at certain Times of Day

Hello,

Does anyone know of a way for an ISDN to backup and interface, or watched network but only activates the link if the cct/route failure is between certain hours of the day, ie 9-5.

Is this in fact possible to do?

I am tinkering with the idea below, but this still brings up the ISDN on a watched route failure which I dont want, and then I set "interesting traffic within a time range"

I would like a fail safe way to do this so that the ISDN does not come up between 18:00 and 08:59 on weekdays.

!

interface BRI0/0

description ISDN Number 384000

ip address 155.195.10.1 255.255.255.0

no ip directed-broadcast

encapsulation ppp

dialer map ip 155.195.10.2 name R2 broadcast 384020

dialer map ip 155.195.20.0 name R2 broadcast 384020

dialer watch-group 10

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

!

access-list 101 deny ospf any any

access-list 101 permit ip any any time-range ISDN <--------------- time range

!

dialer-list 1 protocol ip list 101

dialer watch-list 10 ip 155.195.20.0 255.255.255.0

!

time-range ISDN

periodic weekdays 9:00 to 17:00

6 REPLIES
VIP Purple

Re: ISDN to only come up at certain Times of Day

Hello,

not sure if you use CiscoWorks but if you do can you use the NetConfig utility to add and remove dialer watch commands at periodic or recurrent time intervals (Resource Manager Essentials > Configuration Management > NetConfig).

Regards,

Georg

New Member

Re: ISDN to only come up at certain Times of Day

Thx for the reply, but there is no NMS on this network. Its for a client test network which has an ISDN dialing from London to (guess where) Sydney! Ha! its gonna be expensive :)

Hope there is a way :))

New Member

Re: ISDN to only come up at certain Times of Day

time-of-day based ACL's were introduced in 12.0.1.T

Check out this url for details.

http://www.cisco.com/en/US/products/sw/secursw/ps1018/products_tech_note09186a00800a5b9a.shtml

New Member

Re: ISDN to only come up at certain Times of Day

I need to do the same thing, I've applied a time based ACL to the dialer but this doesn't stop the call being made when using dialer watch.

interface Dialer0

ip address 10.16.0.254 255.255.252.0

encapsulation ppp

ip ospf network point-to-multipoint

dialer idle-timeout 30

dialer watch-disable 15

dialer string ***********

dialer pool 1

dialer watch-group 1

dialer-group 1

no cdp enable

ppp authentication chap

access-list 101 deny ospf any any

access-list 101 deny ip any any time-range Night

access-list 101 permit icmp any any

access-list 101 permit ip any any

dialer watch-list 1 ip 10.25.4.0 255.255.252.0

dialer-list 1 protocol ip list 101

time-range Night

periodic weekdays 18:00 to 23:59

periodic weekdays 0:00 to 8:00

Here is the output

Nov 23 00:13:47: Dialer0: ip (s=10.16.0.254, d=224.0.0.5), 64 bytes, outgoing uninteresting (list 101)

Nov 23 00:14:11: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

Nov 23 00:14:12: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up

Nov 23 00:14:12: Dialer Watch: watch-group = 1

Nov 23 00:14:12: network 10.25.4.0/255.255.252.0 DOWN,

Nov 23 00:14:12: primary DOWN

Nov 23 00:14:12: Dialer Watch: Dial Reason: Primary of group 1 DOWN

Nov 23 00:14:12: Dialer Watch: watch-group = 1,

Nov 23 00:14:12: BRI0/0: rotor dialout [priority]

Nov 23 00:14:12: dialing secondary by dialer string **************** on Dialer0

Nov 23 00:14:12: BRI0/0: Attempting to dial ****************

Nov 23 00:14:12: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 69 changed to up

Nov 23 00:14:14: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state to up

Nov 23 00:14:14: Dialer Watch: resetting call in progress on BR0/0:2

Nov 23 00:14:14: %DIALER-6-BIND: Interface BRI0/0:2 bound to profile Dialer0

Nov 23 00:14:14: dialer Protocol up for BR0/0:2

Nov 23 00:14:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:2, changed state to up

Nov 23 00:14:17: Dialer0: ip (s=10.16.0.254, d=224.0.0.5), 64 bytes, outgoing uninteresting (list 101)

Nov 23 00:14:20: %ISDN-6-CONNECT: Interface BRI0/0:2 is now connected to **************** PRI

Nov 23 00:14:28: Dialer0: ip (s=10.16.0.254, d=10.16.0.1), 52 bytes, outgoing uninteresting (list 101)

Nov 23 00:14:28: Dialer0: ip (s=10.16.0.254, d=10.16.0.1), 1492 bytes, outgoing uninteresting (list 101)

Nov 23 00:14:29: Dialer0: ip (s=10.16.0.254, d=10.16.0.1), 1492 bytes, outgoing uninteresting (list 101)

Remote-bot#

Nov 23 00:14:34: Dialer0: ip (s=10.16.0.254, d=10.16.0.1), 104 bytes, outgoing uninteresting (list 101)

sh isdn act

--------------------------------------------------------------------------------

ISDN ACTIVE CALLS

--------------------------------------------------------------------------------

History table has a maximum of 100 entries.

History table data is retained for a maximum of 15 Minutes.

--------------------------------------------------------------------------------

Call Calling or Called Remote Seconds Seconds Seconds Recorded Charges

--------------------------------------------------------------------------------

Out **************** PRI 26 29 0 0

--------------------------------------------------------------------------------

Remote-bot#

Remote-bot#

Remote-bot#

Remote-bot#

Remote-bot#

Nov 23 00:14:45: Dialer0: ip (s=10.15.28.1, d=10.25.4.119), 60 bytes, outgoing interesting (list 101)

Nov 23 00:14:46: Dialer0: ip (s=10.15.28.1, d=10.25.4.119), 60 bytes, outgoing interesting (list 101)

New Member

Re: ISDN to only come up at certain Times of Day

Just found this

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.ee94ccc

The cisco chap said this is a feature request so it can't be done yet.

Steve

New Member

Re: ISDN to only come up at certain Times of Day

so use the backup interface command instead of dialer watch

109
Views
0
Helpful
6
Replies
CreatePlease to create content