Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Issue configuring Soho97 - ADSL with pppoa

I'm trying to configure my soho97 router with adsl, but it doesn't works. I'm in the UK with a fixed IP address and using pppoa, chap, vc-mux and pvc 0/38.

from the internal lan I can ping int e0(10.10.10.1) and int d1(82.x.x.x) with no issues, but 1 cannot the isp’s dns server 212.23.8.1.

from the router console I can only ping 10.10.10.1 with success. int d1 and isp dns no good..

Sample below

Building configuration...

Current configuration : 1685 bytes

!

version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterSOHO97

!

ip subnet-zero

ip name-server 212.x.8.1

ip name-server 212.23.8.6

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool CLIENT

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 212.x.x.x.23.8.6

lease 0 2

!

!

no aaa new-model

!

interface Ethernet0

ip address 10.10.x.x.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

atm vc-per-vp 128

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

!

dsl operating-mode auto

!

interface Dialer1

ip address 82.x.x.x 255.255.255.248

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxx

ppp chap password xxxx

ppp pap sent-username xxxxxx password xxxx!

ip nat inside source list 102 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

no ip http secure-server

!

access-list 23 permit 10.10.10.0 0.0.0.255

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 120 0

no modem enable

stopbits 1

line aux 0

line vty 0 4

access-class 23 in

exec-timeout 120 0

login local

length 0

!

scheduler max-task-time 5000

!

End

Below some diags samples;

show int atm 0

ATM0 is up, line protocol is up

Hardware is PQUICC_SAR (with Alcatel ADSL Module)

MTU 1500 bytes, sub MTU 1500, BW 288 Kbit, DLY 80 usec,

reliability 68/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

10 maximum active VCs, 128 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input never, output 00:14:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

16 packets output, 1120 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 output buffer failures, 0 output buffers swapped out

RouterSOHO97#

sh atm int atm0

Interface ATM0:

AAL enabled: AAL5 AAL2, Maximum VCs: 10, Current VCCs: 1

Maximum Transmit Channels: 0

VCIs per VPI: 128,

Max. Datagram Size: 1528

PLIM Type: ADSL - 800Kbps Upstream, DMT, TX clocking: LINE

0 input, 16 output, 0 IN fast, 0 OUT fast

Avail bw = 800

Config. is ACTIVE

RouterSOHO97#

sh ip int bri

Interface IP-Address OK? Method Status Protocol

ATM0 unassigned YES NVRAM up up

Dialer1 82.x.x.x YES manual up up

Ethernet0 10.10.10.1 YES NVRAM up up

RouterSOHO97#

Sorry for the large amount of info. hopefully it will help solve my problems..

Thanx

:)

4 REPLIES
VIP Purple

Re: Issue configuring Soho97 - ADSL with pppoa

Hello,

from what I can see you need to bind your ATM interface to your dialer:

interface ATM0

no ip address

atm vc-per-vp 128

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

-->dialer pool-member 1

Can you add this to your configuration and see if it works ?

Regards,

GP

Community Member

Re: Issue configuring Soho97 - ADSL with pppoa

GP,

Thanks for your advice.

I have tried your suggestion and I still have the same symptons??

:(

Community Member

Re: Issue configuring Soho97 - ADSL with pppoa

further on from that i ran "debug ppp negotiation" and i attached the output. there is an Authentication failure. could this be the isp issue.

thanks in advance

:)

Community Member

Re: Issue configuring Soho97 - ADSL with pppoa

Thanks for all your help.

It wasn't anything to with my configs. My account was incorrectly configured at my ISP.

nickymo

112
Views
0
Helpful
4
Replies
CreatePlease to create content