Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

L2 Troubleshooting 4507

I am trying to troubleshoot a layer 2 problem on4507. We have some non Cisco equipment we are phasing out but in the meantime it is running production services. We have four 4507s one acting as a master switch and the three others connect to it. We have multiple VLANs going to each switch. The problem is that devices on one VLAN are not working on one of the edge 4507s the other VLANs appear to be OK. I have used CDP to check connectivity, which is OK as the other VLANs work I have done a Show Mac-address-table Vlan 4 and this shows me mac addressess based on that vlan. However I cannot ping these devices and they cannot ping other devices.

Are their any ways to troubleshoot this problem understanding that these vlans are bridged and not routed. So I am looking at ways to trouble shoot from a layer 2 connectivity. The config is the same as the other two edge 4507s and they work fine.

Any suggestions appreciated.

3 REPLIES
New Member

Re: L2 Troubleshooting 4507

Please post configs for each of the 4 switches.

- Matt

New Member

Re: L2 Troubleshooting 4507

Here are the configs Switch C and D are the same as B. B is the one with the problem.

version 12.1

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service compress-config

service pt-vty-logging

!

hostname SwitchA

!

boot system bootflash:cat4000-ik2s-mz.121-13.EW.bin

aaa new-model

aaa authentication login default local

enable secret

!

username username1 password

username username2 password

username username3 password

username username4 password

username username5 password

clock timezone PST -8

vtp mode transparent

ip subnet-zero

no ip routing

ip domain-name wireless.ubc.ca

ip name-server 192.168.1.1

ip name-server 192.168.2.1

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree extend system-id

spanning-tree vlan 900,910,950 priority 24576

!

redundancy

mode rpr

main-cpu

auto-sync standard

!

!

vlan 900

name OPEN

!

vlan 910

name SECURE

!

vlan 950

name MGMT

!

vlan 952,956,958

!

interface GigabitEthernet1/1

description "Link to Router"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet1/2

!

interface GigabitEthernet2/1

switchport access vlan 952

switchport mode access

speed nonegotiate

!

interface GigabitEthernet2/2

!

interface FastEthernet3/1

switchport access vlan 900

switchport mode access

duplex full

!

interface FastEthernet3/2

switchport access vlan 900

switchport mode access

duplex full

!

!

interface GigabitEthernet4/1

switchport access vlan 952

switchport mode access

!

interface GigabitEthernet4/2

switchport access vlan 952

switchport mode access

!

!

interface GigabitEthernet5/1

description "Link to SwitchC"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet5/2

description "Link to SwitchB"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet5/3

description "Link to SwitchD"

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet5/7

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan950

description "Management VLAN"

ip address 192.168.250.1 255.255.255.0

!

ip default-gateway 192.168.250.254

ip classless

no ip http server

!

!

logging trap debugging

logging facility local5

!

end

_____________________________________________________

version 12.1

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service compress-config

!

hostname SwitchB

!

boot system bootflash:cat4000-ik2s-mz.121-13.EW.bin

aaa new-model

aaa authentication login default local

enable secret

!

username username1 password

username username2 password

username username3 password

username username4 password

username username5 password

clock timezone PST -8

vtp mode transparent

ip subnet-zero

no ip routing

ip domain-name wireless.ubc.ca

ip name-server 192.168.1.1

ip name-server 192.168.2.1

!

ip ssh time-out 120

ip ssh authentication-retries 3

spanning-tree extend system-id

!

redundancy

mode rpr

main-cpu

auto-sync standard

!

!

vlan 900

name OPEN

!

vlan 910

name SECURE

!

vlan 950

name MGMT

!

vlan 952,956,958

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet2/2

!

interface FastEthernet3/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 950

switchport mode trunk

duplex full

!

interface FastEthernet3/2

!

interface GigabitEthernet4/1

switchport access vlan 900

switchport mode access

duplex full

speed 100

no cdp enable

!

interface GigabitEthernet4/2

!

interface GigabitEthernet4/3

!

!

interface GigabitEthernet5/7

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

interface GigabitEthernet5/8

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 900,910,950

switchport mode trunk

!

!

interface Vlan1

no ip address

shutdown

!

interface Vlan950

description "Management VLAN"

ip address 192.168.250.2 255.255.255.0

!

ip default-gateway 192.168.250.254

ip classless

no ip http server

!

!

logging trap debugging

logging facility local5

!

end

Any ideas appreciated.

Thanks

New Member

Re: L2 Troubleshooting 4507

This was a similar problem with our 4507R, what I did was I added speed nonegotiate to the gig interfaces, and On switchport trunk allowed I set mine to ALL and this clear the problems. These are just some suggestions.

162
Views
0
Helpful
3
Replies
CreatePlease login to create content