Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

L3 portchannel => L2 portchannel

Hi,

I have some questions regading portchannels. (Ether channels)

Is it possible to connected a L3 portchannel and a L2 portchannel.

Where on the L3 switch the portchannel is a L3 port-channel and on the L2 switch a L2 port-channel.

L3 switch, for example a 3550 (L3 port-channel) => L2 Switch 2950 (L2 port-channel)

I have tested this and it seems to work.

But I am not sure about the loadbalancing. Both the port are up on both switches en are forwarding traffic.

But mine logic says L2 <=> L2 And L3 <=> L3

I searched the cisco but could't find a document about this isseu. Or any example describing a similar setup.

Want i like to know if this a valid configuration or not?

5 REPLIES
Blue

Re: L3 portchannel => L2 portchannel

just to be sure we're all on the same page, paste the configs for the two devices so we can know how they're configured.

then we should be able to tell you if your specific configuration is valid or not; and we can provide any additional input if required.

New Member

Re: L3 portchannel => L2 portchannel

Here's an example config

On the L3 switch:

interface Port-channel1

no switchport

ip address 10.10.10.1 255.255.255.0

!

interface FastEthernet0/1

no switchport

no ip address

channel-group 1 mode desirable

!

interface FastEthernet0/2

no switchport

no ip address

channel-group 1 mode desirable

On the L2 switch

interface Port-channel1

!

interface FastEthernet0/1

channel-group 1 mode desirable

!

interface FastEthernet0/2

channel-group 1 mode desirable

Int vlan 1

ip addr 10.10.10.2 255.255.255.0

Hall of Fame Super Bronze

Re: L3 portchannel => L2 portchannel

Roy,

That's a valid configuration and load balancing should work at both L3 and L2.

New Member

Re: L3 portchannel => L2 portchannel

Configs OK. Logic may say L3 <=> L3, and L2 <=> L2. But, if you think of it this way: L3 portchannel is equivalent to server with multiple teamed NICs, and the L2 port-channel is, well, the switch that the server connects to. Y'dig? :)

New Member

Re: L3 portchannel => L2 portchannel

Well, thanks for sharing ur thoughts with me, and clearing this up.

I just wanted to be sure, since i couldn't find any documents (or config examples)

explaining if this setup was valid (or not).

Only one i found was an example for a L3 portchannel between a 7600 router and a Cat6K

1351
Views
6
Helpful
5
Replies
CreatePlease to create content