Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Limiting bandwidth on a 2950 switch

Hello,

In order to set-up a new customer link between two buildings, we'd like to simulate a 25 Mbps connection between two servers connected through a Cisco 2950 switch.

To do so, I tried to set-up a QoS policy as explained on this page : http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a008007e8de.html#48475

Here is my running configuration :

Switch#sh run

Building configuration...

Current configuration : 2054 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

enable secret xxxx

enable password class

!

!

class-map match-all ipclass1

match access-group 1

!

!

policy-map flow1t

class ipclass1

police 25000000 65536 exceed-action drop

!

ip subnet-zero

!

vtp mode transparent

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

switchport mode access

no ip address

duplex full

speed 100

!

interface FastEthernet0/2

switchport mode access

no ip address

duplex full

speed 100

!

interface FastEthernet0/3

switchport mode access

no ip address

!

interface FastEthernet0/4

no ip address

service-policy input flow1t

!

access-list 1 permit any

!

Typically, I connected the two servers on ports 3 and 4. With "police 25000000 65536 exceed-action drop", I expected to get an average rate of 25 Mbps but in fact, it's not at all :\

When trying to transfer a file between the two machines using FTP, I just got a 200 KB/s tranfert rate (1.6 Mbps)... Very far from my 25 Mbps link, isn't it?

Did I forget something? Is my configuration wrong?

Thanks for helping,

Regards,

Gaëtan

  • Other Network Infrastructure Subjects
1 REPLY
Bronze

Re: Limiting bandwidth on a 2950 switch

Your normal burst value seems too low. For rate-limiting, the formula for the burst is normaly (bits-per-second-value)/8 * 1.5. Based on the formula, your statement would look like this:

police 25600000 2000000 exceed-action drop

The burst here is defined as 2000000 since that is the max amount allowed on the switch. If you are not getting the desired results, try lowering your burst value a little and testing again.

131
Views
3
Helpful
1
Replies
This widget could not be displayed.