Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Line Appears Looped - every other time

Hi People,

A problem here that's got me stumped. Two 800 routers, over an ISDN simulator. Now every OTHER time you try and ping each other, it doesn't work.

PPP negotiation says:

Line appears to be looped back.

and it drops the call after 10-20 seconds.

Full PPP negotiation shown here:

stuart#ping 192.1.12.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.1.12.2, timeout is 2 seconds:

00:30:09: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:30:09: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

00:30:09: BR0:1 PPP: Treating connection as a callout

00:30:09: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

00:30:09: BR0:1 LCP: O CONFREQ [Closed] id 37 len 28

00:30:09: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:09: BR0:1 LCP: MagicNumber 0x50701AB4 (0x050650701AB4)

00:30:09: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:09: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:09: BR0:1 LCP: I CONFREQ [REQsent] id 37 len 28

00:30:09: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:09: BR0:1 LCP: MagicNumber 0x50701AB4 (0x050650701AB4)

00:30:09: BR0:1 LCP: MRRU 1524 (0x110405F4).

00:30:09: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:09: BR0:1 LCP: O CONFNAK [REQsent] id 37 len 10

00:30:09: BR0:1 LCP: MagicNumber 0x50701B31 (0x050650701B31)

00:30:09: BR0:1 LCP: I CONFNAK [REQsent] id 37 len 10

00:30:09: BR0:1 LCP: MagicNumber 0x50701B31 (0x050650701B31)

00:30:09: BR0:1 PPP: Line appears to be looped back

00:30:11: BR0:1 LCP: TIMEout: State REQsent

00:30:11: BR0:1 LCP: O CONFREQ [REQsent] id 38 len 28

00:30:11: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:11: BR0:1 LCP: MagicNumber 0x50701B52 (0x050650701B52)

00:30:11: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:11: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:11: BR0:1 LCP: I CONFREQ [REQsent] id 38 len 28

00:30:11: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:11: BR0:1 LCP: MagicNumber 0x50701B52 (0x050650701B52)

00:30:11: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:11: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:11: BR0:1 LCP: O CONFNAK [REQsent] id 38 len 10.

00:30:11: BR0:1 LCP: MagicNumber 0x507022BF (0x0506507022BF)

00:30:11: BR0:1 LCP: I CONFNAK [REQsent] id 38 len 10

00:30:11: BR0:1 LCP: MagicNumber 0x507022BF (0x0506507022BF)

00:30:11: BR0:1 PPP: Line appears to be looped back

00:30:13: BR0:1 LCP: TIMEout: State REQsent

00:30:13: BR0:1 LCP: O CONFREQ [REQsent] id 39 len 28

00:30:13: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:13: BR0:1 LCP: MagicNumber 0x507022CC (0x0506507022CC)

00:30:13: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:13: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:13: BR0:1 LCP: I CONFREQ [REQsent] id 39 len 28

00:30:13: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:13: BR0:1 LCP: MagicNumber 0x507022CC (0x0506507022CC)

00:30:13: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:13: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:13: BR0:1 LCP: O CONFNAK [REQsent] id 39 len 10.

00:30:13: BR0:1 LCP: MagicNumber 0x50702A91 (0x050650702A91)

00:30:13: BR0:1 LCP: I CONFNAK [REQsent] id 39 len 10

00:30:13: BR0:1 LCP: MagicNumber 0x50702A91 (0x050650702A91)

00:30:13: BR0:1 PPP: Line appears to be looped back

00:30:15: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01628500453 stuart

00:30:15: BR0:1 LCP: TIMEout: State REQsent

00:30:15: BR0:1 LCP: O CONFREQ [REQsent] id 40 len 28

00:30:15: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:15: BR0:1 LCP: MagicNumber 0x50702A9E (0x050650702A9E)

00:30:15: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:15: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:15: BR0:1 LCP: I CONFREQ [REQsent] id 40 len 28

00:30:15: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:15: BR0:1 LCP: MagicNumber 0x50702A9E (0x050650702A9E)

00:30:15: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:15: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:15: BR0:1 LCP: O CONFNAK [REQsent] id 40 len 10.

00:30:15: BR0:1 LCP: MagicNumber 0x50703263 (0x050650703263)

00:30:15: BR0:1 LCP: I CONFNAK [REQsent] id 40 len 10

00:30:15: BR0:1 LCP: MagicNumber 0x50703263 (0x050650703263)

00:30:15: BR0:1 PPP: Line appears to be looped back

00:30:17: BR0:1 LCP: TIMEout: State REQsent

00:30:17: BR0:1 LCP: O CONFREQ [REQsent] id 41 len 28

00:30:17: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:17: BR0:1 LCP: MagicNumber 0x50703270 (0x050650703270)

00:30:17: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:17: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:17: BR0:1 LCP: I CONFREQ [REQsent] id 41 len 28

00:30:17: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:17: BR0:1 LCP: MagicNumber 0x50703270 (0x050650703270)

00:30:17: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:17: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:17: BR0:1 LCP: O CONFNAK [REQsent] id 41 len 10.

Success rate is 0 percent (0/5)

stuart#

00:30:17: BR0:1 LCP: MagicNumber 0x50703A35 (0x050650703A35)

00:30:17: BR0:1 LCP: I CONFNAK [REQsent] id 41 len 10

00:30:17: BR0:1 LCP: MagicNumber 0x50703A35 (0x050650703A35)

00:30:17: BR0:1 PPP: Line appears to be looped back

00:30:81604419584: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 01628500453 stuart, call lasted 10 seconds

00:30:19: BR0:1 LCP: TIMEout: State REQsent

00:30:19: BR0:1 LCP: O CONFREQ [REQsent] id 42 len 28

00:30:19: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:30:19: BR0:1 LCP: MagicNumber 0x50703A42 (0x050650703A42)

00:30:19: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:19: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:19: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

00:30:19: BR0:1 PPP: No remote authentication for call-out

00:30:19: BR0:1 LCP: O CONFREQ [Closed] id 43 len 23

00:30:19: BR0:1 LCP: MagicNumber 0x5070424B (0x05065070424B)

00:30:19: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:30:19: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:30:19: BR0:1 LCP: State is Closed

00:30:19: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]

00:30:19: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di1

stuart#

stuart#

stuart#

Then all you do is run a ping again, and it works:

00:25:56: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di1

stuart#

stuart#

stuart#

stuart#

stuart#ping 192.1.12.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.1.12.2, timeout is 2 seconds:

00:29:27: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

00:29:27: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

00:29:27: BR0:1 PPP: Treating connection as a callout

00:29:27: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]

00:29:27: BR0:1 LCP: O CONFREQ [Closed] id 35 len 28

00:29:27: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:29:27: BR0:1 LCP: MagicNumber 0x506F7631 (0x0506506F7631)

00:29:27: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:29:27: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:29:27: BR0:1 LCP: I CONFREQ [REQsent] id 48 len 27

00:29:27: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:29:27: BR0:1 LCP: MagicNumber 0xB13EFD3F (0x0506B13EFD3F)

00:29:27: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:29:27: BR0:1 LCP: EndpointDisc 1 creed (0x1308016372656564)

00:29:27: BR0:1 LCP: O CONFACK [REQsent] id 48 len 27

00:29:27: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:29:27: BR0:1 LCP: MagicNumber 0xB13EFD3F .!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 32/49/96 ms

stuart#(0x0506B13EFD3F)

00:29:27: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:29:27: BR0:1 LCP: EndpointDisc 1 creed (0x1308016372656564)

00:29:27: BR0:1 LCP: I CONFACK [ACKsent] id 35 len 28

00:29:27: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

00:29:27: BR0:1 LCP: MagicNumber 0x506F7631 (0x0506506F7631)

00:29:27: BR0:1 LCP: MRRU 1524 (0x110405F4)

00:29:27: BR0:1 LCP: EndpointDisc 1 stuart (0x130901737475617274)

00:29:27: BR0:1 LCP: State is Open

00:29:27: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]

00:29:27: BR0:1 CHAP: O CHALLENGE id 5 len 27 from "stuart"

00:29:27: BR0:1 CHAP: I CHALLENGE id 23 len 26 from "creed"

00:29:27: BR0:1 CHAP: O RESPONSE id 23 len 27 from "stuart"

00:29:27: BR0:1 CHAP: I SUCCESS id 23 len 4

00:29:27: BR0:1 CHAP: I RESPONSE id 5 len 26 from "creed"

00:29:27: BR0:1 CHAP: O SUCCESS id 5 len 4

00:29:27: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

00:29:27: Di1 PPP: Phase is UP [0 sess, 1 load]

00:29:27: Di1 CDPCP: O CONFREQ [Closed] id 3 len 4

00:29:28: Di1 IPCP: O CONFREQ [Closed] id 3 len 10

00:29:28: Di1 IPCP: Address 192.1.12.1 (0x0306C0010C01)

00:29:28: Di1 MLP: Added first link BR0:1 to bundle creed

00:29:28: Di1 PPP: Treating connection as a callout

00:29:28: BR0:1 CDPCP: MLP bundle interface is built, process packets now

00:29:28: BR0:1 CDPCP: Redirect packet to Di1

00:29:28: Di1 CDPCP: I CONFREQ [REQsent] id 3 len 4

00:29:28: Di1 CDPCP: O CONFACK [REQsent] id 3 len 4

00:29:28: BR0:1 IPCP: MLP bundle interface is built, process packets now

00:29:28: BR0:1 IPCP: Redirect packet to Di1

00:29:28: Di1 IPCP: I CONFREQ [REQsent] id 3 len 10

00:29:28: Di1 IPCP: Address 192.1.12.2 (0x0306C0010C02)

00:29:28: Di1 IPCP: O CONFACK [REQsent] id 3 len 10

00:29:28: Di1 IPCP: Address 192.1.12.2 (0x0306C0010C02)

00:29:28: BR0:1 CDPCP: MLP bundle interface is built, process packets now

00:29:28: BR0:1 CDPCP: Redirect packet to Di1

00:29:28: Di1 CDPCP: I CONFACK [ACKsent] id 3 len 4

00:29:28: Di1 CDPCP: State is Open

00:29:28: BR0:1 IPCP: MLP bundle interface is built, process packets now

00:29:28: BR0:1 IPCP: Redirect packet to Di1

00:29:28: Di1 IPCP: I CONFACK [ACKsent] id 3 len 10

00:29:28: Di1 IPCP: Address 192.1.12.1 (0x0306C0010C01)

00:29:28: Di1 IPCP: State is Open

00:29:28: Di1 IPCP: Install route to 192.1.12.2

00:29:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up

stuart#

stuart#

stuart#

stuart#

00:29:33: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01628500453 creed

stuart#

stuart#

00:29:39: BR0:1 PPP: Phase is TERMINATING [0 sess, 0 load]

00:29:39: BR0:1 LCP: O TERMREQ [Open] id 36 len 4

00:29:39: Di1 CDPCP: State is Closed

00:29:39: Di1 IPCP: State is Closed

00:29:39: Di1 PPP: Phase is TERMINATING [0 sess, 0 load]

00:29:39: Di1 LCP: State is Closed

00:29:39: Di1 PPP: Phase is DOWN [0 sess, 0 load]

00:29:39: BR0:1 LCP: I TERMREQ [TERMsent] id 49 len 4

00:29:39: BR0:1 LCP: O TERMACK [TERMsent] id 49 len 4

00:29:39: BR0:1 LCP: I TERMACK [TERMsent] id 36 len 4

00:29:39: BR0:1 LCP: State is Closed

00:29:39: BR0:1 PPP: Phase is DOWN [0 sess, 1 load]

00:29:39: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]

00:29:39: BR0:1 LCP: State is Listen

00:29:39: Di1 IPCP: Remove route to 192.1.12.2

00:29:167503765504: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 01628500453 creed, call lasted 11 seconds

00:29:39: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

00:29:39: BR0:1 PPP: No remote authentication for call-out

00:29:39: BR0:1 LCP: State is Closed

00:29:39: BR0:1 PPP: Phase is DOWN [0 sess, 1 load]

00:29:39: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di1

00:29:40: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to down

stuart#

Then again it fails, and so on and so on.

Just wondering if someone's seen this. I've tried different code levels and both routers are doing it.

I'll include the simple configs:

stuart#term len 0

stuart#wr t

Building configuration...

Current configuration : 803 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname stuart

!

!

username creed password 0 XXXXX

username stuart password 0 XXXXX

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 10.1.113.5 255.255.0.0

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp multilink

!

interface Dialer1

ip address 192.1.12.1 255.255.0.0

encapsulation ppp

dialer pool 1

dialer remote-name creed

dialer idle-timeout 10

dialer string 01628500453

dialer-group 1

ppp authentication chap

ppp multilink

!

no ip http server

ip classless

!

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

login

!

no rcapi server

!

!

end

Router over 3 months old, so opening a TAC case isn't an option. WOuld really appreciate your assistance.

Many Thanks,

Stuart Smith

(stu_cisco@hotmail.com)

3 REPLIES
Bronze

Re: Line Appears Looped - every other time

You should suspect your simulator. The MagicNumber is an option within LCP negotiations, it is a randomly generated number that is intended to detect loopback conditions. In the first case, we are receiving our own MagicNumber - thus we believe there to be a loop. Given the consistency,

I would suggest the simulator be looked at.

Bronze

Re: Line Appears Looped - every other time

Whatever PPP/LCP frames your router "stuart" is sending out, its coming back into itself (as shown by the same magic number in the outbound and the next inbount LCP). Its intermittent but you definitely need to check your simulator. No where else.

~ZUlfi

New Member

Re: Line Appears Looped - every other time

Do you have any hunting setup in the simulator for 01628500453? If you added "debug isdn q931" to the mix it might help a little, maybe not, since the simulator could be doing anything with those ppp packets. Do you have more then one channel assigned to either router?

Josh

490
Views
0
Helpful
3
Replies
CreatePlease to create content