Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Line Not Comming UP after Idle-timeout ??

Hi, All,

I have a typical problem here,A router has been configured to dial out to the ISP and the users on the LAN can browse the internet.

During the day time when the router attains Idle Time out,the line is dropped, and later on when it senses any interesting traffic the line comes up.

But the problem is during the Night,When the router goes into Idle time out in the night , and stays off the whole night, Next day morning, The line does not come up even if IE is double clicked R does not in fact respond to any interesting traffic , UNLESS the router is shut down and restarted again....

Any clues why so ?? I have included the configuration below for your refrence .... ANy input for this will be highly apprecitated....

ReachMass#sh conf

Using 1362 out of 8076 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname beachmail

!

enable password 7 082C4D5D1A

!

!

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

interface Ethernet0

description connected to EthernetLAN

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

interface BRI0

description connected to Internet

no ip address

ip nat outside

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

!

interface Dialer1

description connected to Internet

ip address negotiated

ip nat outside

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 600

dialer string 4002222

dialer hold-queue 10

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname beachmail

ppp chap password 7 02575D025B0B0E325F

ppp pap sent-username beachmail password 7 12485C4E42060D1739

!

ip nat inside source list 1 interface Dialer1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit any

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

snmp-server community public RO

snmp-server chassis-id JAD053508YF

!

line con 0

exec-timeout 0 0

password 7 131712130804

login

stopbits 1

line vty 0 4

password 7 0833494F0A11

login

!

end

Thanx in advance !!!

Tauseef

tauseef@cadgulf.com

2 REPLIES
VIP Purple

Re: Line Not Comming UP after Idle-timeout ??

This looks like it should work to me. Try a command like:

debug dialer events

And make sure the router is seeing some interesting traffic. Then you could try something like:

debug isdn events (use ? to get actual syntax).

Basically, use the debug commands until you track the problem down.

New Member

Re: Line Not Comming UP after Idle-timeout ??

First your Dialer Timeout is set to 660 Seconds. When no traffic is found your Dialer will timeout and drop.

Add this to your config.

conf t

int d1

dialer idle-timeout 2147483

dialer load-threshold 1 either

Also, add this command.

conf t

service tcp-keepalives-in

service tcp-keepalives-out

This will fix your problem.

By the way, Dont ever post your passwords in your config. These are easliy hacked.

Happy surfing!

116
Views
0
Helpful
2
Replies