cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
323
Views
0
Helpful
4
Replies

llq on atm interface

grunky
Level 1
Level 1

I'm working on configuring low latency queuing on our 7206vxr router. I'd like to give preference to delay sensitive traffic. I've done so on our T1's

class-map match-any latency_sensitive_traffic

match protocol telnet

match protocol ssh

match protocol vpn

match protocol ipsec

!

!

policy-map latency

class latency_sensitive_traffic

priority 384 51200

interface Serial2/4:0

bandwidth 1544

ip address 1.2.3.4 255.255.255.0

ip load-sharing per-packet

encapsulation ppp

service-policy output latency

However I can not apply this same service-policy to the atm interface. I realize atm is a different beast, hense my problems, but don't know where to begin. The reading I have done says that QoS policies can be applied at different places, interface, sub-interface or pvc. I've tried the interface and sub-interface, reconfiguring the policy map differently. Right now my atm neophite status is limiting my understanding and options.

Does anyone have good links/example reguarding QoS and atm?

4 Replies 4

donewald
Level 6
Level 6

Try this:

http://www.cisco.com/warp/customer/121/where_policy.html

Just keep in mind that ATM Qos (out in your ATM cloud) is a completely different thing. IP to ATM Qos can be done with VC bundling and other techniques.

Hope this is what you were looking for,

Don

thisisshanky
Level 11
Level 11

I see no reason why u cannot apply the service-policy on the atm interface or subinterface. You should be applying it on the pvc mode.

int atm 0.1 point-to-point

pvc X/YY

service-policy <>

Hope this helps...

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Yes - reading up I attempted to apply "service-policy output latency" to in atm interface, sub-interface, and the pvc 5/500.

Again here's the what I'm tring to apply..

class-map match-any letency_sensitive_traffic

match protocol telnet

match protocol ssh

match protocol gre

match protocol pptp

match protocol l2tp

match protocol ipsec

match protocol icmp

!

!

policy-map latency

class letency_sensitive_traffic

priority 384 51200

interface ATM3/0

no ip address

no ip mroute-cache

atm framing cbitplcp

no atm ilmi-keepalive

!

interface ATM3/0.500 point-to-point

ip address 1.2.3.4 255.255.255.252

no ip mroute-cache

pvc 5/500

oam-pvc manage

encapsulation aal5snap

!

service-policy input limit_file_sharing

Thanks for the advice and the previously mentioned url should help out.

in the original cfg, you have service-policy output latency under ATM interface and in latest post you have 'service-policy input limit_file_sharing ' . This policy doesn't exist in the cfg posted above FYI.

When you apply the service-policy to the interface, or PVC and there is a problem IOS will output a warning about insufficent bandwidth, etc. Are you seeing any errors? If you are telented into the router do a 'term mon' before applying the command. Also I see there is no vbr-rt/vbr-nrt/cbr/etc command applied to atm PVC to define the bandwidth over this PVC. This is needed when doing LLQ so LLQ uses the correct amount of bandwidth. I've had issues with service-policys not being applied when the vbr-rt/vbr-nrt, etc settings were not configured.