Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

LMS 2.2 and NetConfig

Hi,

Since I've installed LMS2.2 with Common Services SP2, I can't use NetConfig anymore. I can launch the Window NetConfig, but in the final step, when I click on Finish, the message "Cannot schedule job. Exception stack trace:java.lang.NullPointerException" appears !

I use the Plug-in 1.4.1_02, which is installed with SP2. RME works correctly, except NetConfig...

Is anybody have the same pb of me ?

What can I do ?

Thanks.

9 REPLIES
Blue

Re: LMS 2.2 and NetConfig

If you're using plug-in 1.4.1_02, have you installed the Cumulative/Jubmo patch for RWAN/LMS from CCO which adds support for this plug-in version?

New Member

Re: LMS 2.2 and NetConfig

I'm not sure that I've installed this Cumulative/Jubmo patch for RWAN/LMS : where can I download it on CCO ? Could you give me the URL ?

This is the update I've installed : CiscoWorks-LMS-2.2-LMS-1.3-Update-1-k9.exe (normally, its supports the use of Plug-in 1.4.1-02). Is it OK ?

Thanks for your help.

Blue

Re: LMS 2.2 and NetConfig

You can get this jumbo patch from:

http://www.cisco.com/cgi-bin/tablebuild.pl/lms -> For LMS Bundle and

http://www.cisco.com/cgi-bin/tablebuild.pl/rwan -> For RWAN Bundle. Without the patch, 1.4.1_02 plug-in is not supported.

New Member

Re: LMS 2.2 and NetConfig

So yes, I've installed this patch on my server. The pb may be elsewhere...

Do you have another idea ?

New Member

Re: LMS 2.2 and NetConfig

What platform is CiscoWorks installed on: Solaris or Windows?

Are you able to schedule a job in Software Management?

If not, then you might have issues with cron on Solaris or the casuser account might have some permission issues

Have you tried a different browser/client machine to create a Netconfig job to verify it is truly a Server issue not a Client issue.

Hope that helps

New Member

Re: LMS 2.2 and NetConfig

CiscoWorks is installed on Windows platform (W2K with SP3).

Yes, I can schedule a job in Software Management, no problem.

I've tried to launch NetConfig jobs on different clients and on the server CiscoWorks, but it's the same issue...

I'm wondering if the issue appears because the JRM Server is Down. Is anyone has the same pb ?

New Member

Re: LMS 2.2 and NetConfig

Besides JRM is anything else down?

Can you open a dos prompt on the server and type,

net stop crmdmgtd

wait about 5 minutes

type,

net start crmdmgtd

once it is up with no errors, wait 10 minutes

check the JRM service again to see if it's up and running

Do you have anything else installed on that server? any other web applications?

New Member

Re: LMS 2.2 and NetConfig

Except JRM Server, no any service is Down.

I've tried to stop and restart all the services with the net stop/start crmdmgtd command, but the JRM Server is always Down.

Even after a restart of the CiscoWorks Server, the JRM can't start normally.

Do you think there is a link between my pb with NetConfig and the JRM Server ?

New Member

Re: LMS 2.2 and NetConfig

I had this same problem with netconfig after a failed LMS 2.2 upgrade from LMS 2.1. After restoring the server and the DB from tape, everything was back working, except for netconfig with the same error you describe. The problem seemed to be with the password to the CMF DB. The command below fixed the netconfig problem.

In further testing, I then built a test Ciscoworks box the exact same as the production box and restored the DB from production (to test disaster recovery procedures). Since restoring the DB from production to test, I now have the netconfig problem on the test box, (but not production) and the procedure below won't fix the test box. I am now stuck with netconfig not working on the test box and can't get it fixed. I got the commands below from TAC.

1.net stop crmdmgtd

2 C:\program files\CSCOpx\bin>perl.exe dbpasswd.pl dsn=cmf encryption=yes npwd=newpassword

substitute "newpassword" with the new password.

3. net start crmdmgtd

183
Views
2
Helpful
9
Replies
CreatePlease login to create content