Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

LMS 2.2 update with java 1.4.1 support?

Do you need to have LMS 2.2 to get the java plugin support or is the patch good for all other LMS versions? I have installed the patch but my XP clients still cant access CW. I am also having problems finding the 1.4.1 plugin. I have found the 1.4.2 plugin from sun but it doesnt seem to work and the old 1.3.1 version keeps trying to install everytimne I connect to CW. The 1.4.2 plugin does work on a win2k box though. Can anyone shed some light on this subject?

7 REPLIES
Bronze

Re: LMS 2.2 update with java 1.4.1 support?

Cisco does not support plugin from Sun. You need to apply update 1 for LMS 2.2 to get JPI 1.4.1_02. Only LMX 2.2 or RWAN 1.3 can get new JPI. Older versions of CW can only work with JPI 1.3.1

http://www.cisco.com/cgi-bin/tablebuild.pl/lms

New Member

Re: LMS 2.2 update with java 1.4.1 support?

Will windows XP with IE6 and SP1 work with JPI 1.3.1?

Thanks

Bronze

Re: LMS 2.2 update with java 1.4.1 support?

Yes, they work with 1.3.1 fine. In fact, you can have both 1.4.1 and 1.3.1 installed on same client, and toggle between them.

Re: LMS 2.2 update with java 1.4.1 support?

have you really successfully tried this?? If yes on which OS and which settings have you had for the JRE in the ADVANCED tab of the control panel of both of the plugins?

this would be really great if it works because I have to toggle between different versions of LMS.

thanks,

Martin

Bronze

Re: LMS 2.2 update with java 1.4.1 support?

I have been using both on my XP laptop all the time. In control panel, you will have to JPI icons. Go into the one with coffee cup, and click on "Browser" tab, select IE checkbox to use 1.4.1, deselect it to fallback to 1.3.1.

There's also another workaround which doesn't need you do this toggling. Simply install both IE and Netscape, and select IE to use 1.4.1 and let Netscape deal with 1.3.1.

HTH,

Re: LMS 2.2 update with java 1.4.1 support?

Now I have had the chance to try it out - and you are right, it works! Thanks, helps me a lot!

regards,

Martin

New Member

Re: LMS 2.2 update with java 1.4.1 support?

I found out that if you install Windows XP and then load SP1A you will not have the Microsoft Java Virtual Manager. So when you try to access Cisco Works Java will be disabled on the browser. Microsoft did incorporate the JVM with SP1 and then took it out with SP1A. You can not download the JVM from Microsoft and they only support updates if you all ready have it installed. To get the JVM you must find XP SP1 and look for a file called msjavx86.exe. Just install it and you will be good to go.

95
Views
5
Helpful
7
Replies
CreatePlease to create content