Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

eap
New Member

Load-balance from 4006 between 6509 and 6506

Currently we have a Cat4006 in 5 of our wiring closets with each closet on a different vlan. From each closet there is 12 strands of fiber ran to a junction box. Only 2 of those strands are being used right now junctioned to the 6509. We would like to junction 2 more of those strands to the 6506 and somehow load balance between the two. I thought we could form an etherchannel with the 4 strands, however have since learned that it is not possible to then split the channel between the 2 6500 switches in this "V-like" configuration. How else could we go about doing this? Any suggestions would be appreciated.

Thank you,

Paula

10 REPLIES
Silver

Re: Load-balance from 4006 between 6509 and 6506

Paula,

With only one vlan in each of your closet 4006's (assuming you have no routing functions in your 4006's) if you connected them to both 6509 & 6 you'd have a bridging loop (assuming again your 6509 & 6 are interconnected) and one of these connections would need to be put into blocking mode. Spread loading this topology would only be possible with multiple VLANs in your 4006's. Where one VLAN would forward over your 6509 and one over your 6506, and have a redundant path in the case of failure. This is done with the spanning tree cost... per VLAN over multiple trunks.

Hope this helps you,

Don

Bronze

Re: Load-balance from 4006 between 6509 and 6506

Another good way of doing this and since these are very fast layer 3 switches, not to forward the vlans which are forwarding on the closet between core switches, in this case, there would be any blocking ports and both ports will be forwarding towards the channel and you can implement multiple hsrp group, to load balance the traffic betweem 2 core.- The less blocking ports you have, the better is the convergence time.. If any path fail, the convergence time you are looking for is the hrsp failover. which is nothing in compare with spantree blocking..

hope this helps

eap
New Member

Re: Load-balance from 4006 between 6509 and 6506

Thanks for the input. I am not sure I understand your suggestion here. Would we need layer 3 switching capability on our 4000's? Are you saying to ether channel the 4pair to the one 6509 and then implement hsrp between the 6000's? I thought that hsrp was strictly for redundancy and not load balance. Can you offer any more details about this solution or a reference to a site with an example? Thanks again for your time.

Bronze

Re: Load-balance from 4006 between 6509 and 6506

No, you don't need layer 3 at the cat4000 site at all. This is case scenario is only possible if you have one unique vlan in every cloeet switches. For example if you have vlan 3 on one closet. cat4k-1, you just forward that vlan3 on both core cat6ks to that one cat4k-1 and don't forward that vlan between cat6k. in that case, you will this vlan 3 spantree path will be ."- V " instead of triangle. Since this is not the loop anymore then the vlan 3 will be forwarding on both links to both switches and if you want you can create two hsrp groups under vlan 3, half people forwards to core1 and half to core2. This case scenario is only possible since you have only one unique vlan on each closet switches and make sure only forwards those vlans between each core switches that needed to share by both switches,like magement vlan, any wan routers etc.. other than that, no reason to forwards any vlans between two cat6k..

Sorry i think there is no good urls.. i know it is not easy to understand..

eap
New Member

Re: Load-balance from 4006 between 6509 and 6506

Thank you for that suggestion. Leaving out the 4000 for now due to time pressure, I am trying to muddle through the commands for the following: Form a etherchannel between the 6000s and then a trunk to forward just one subnet across. We would have servers directly connected to the 10/100/1000 ethernet card on our 6506 and forward just that subnet across the etherchannel to the 6509. Is the following syntax correct?

6506-IOS

interface port channel 1

switchport trunk encap dot1q

switchport trunk native vlan 71

switchport mode trunk

int gigabitethernet 1/1

switchport mode trunk

channel-group 1 mode desireable

int gigabitethernet 1/2

switchport mode trunk

channel-group1 mode desireable

int range fastethernet 4/1 - 16

switchport access vlan 71

spanning tree portfast

int vlan 1

ip address

int vlan 71

ip address 155. .71.

Then on the 6509-IOS, similar syntax would be used with only different ip addresses in the vlans for management purposes?

What about on the SFM?

set interface sc0 1 155. . . /255.255.255.0

On Module 1:

set trunk 1/1

set trunk 1/2 (these would need to be on both 6506 and 6509?)

On Module 4:

set VLAN 71 4/1-16(this would just need to be on the 6506)

Where does vtp come in? Does it need to be set on both CatOS and IOS?

Thank you,

Paula

Silver

Re: Load-balance from 4006 between 6509 and 6506

Paula,

Looks good but one comment/gotcha on the IOS config. Let IOS creat the port-channel interface for Layer 2 port channels. Meaning. Don't do a "interface port-channel 1" to create this port. By entering "Channel-group 1" on one of the channel members IOS will create this port for you. Everything will look fine if you don't do this and manually create the portchannel interface but it might not function properly for you, unless you reload.

VTP comes in only if you plan to share the VTP database, meaning creation of VLAN on one 6500 propogates to the other. It would need to be set on both CatOS and IOS boxes. One of the boxes or both could be VTP servers if you choose to implement VTP.

Did not get your SFM ?... IF you have more questions please clarify.

Hope thi shelps you,

Don

eap
New Member

Re: Load-balance from 4006 between 6509 and 6506

What a great help! Thank you.

Each 6500 has the router blade and switch fabric module. I just was asking what configurations needed to be made on the switch fabric. Currently on the 6509 which is not yet connected to the 6506 we have the following:

!

#module 1 : 2-port 1000BaseX Supervisor

set module name 1

!

#module 2 empty

!

#module 3 empty

!

#module 4 : 16-port 10/100/1000BaseT Ethernet

set vlan 71 4/1-16

!

Since we will be using module 1 ports now I was questioning what needed to be configured there.

Thanks again,

Paula

Bronze

Re: Load-balance from 4006 between 6509 and 6506

Here is one more good link

http://www.cisco.com/warp/customer/473/71.html.

Also you don't have to do anything on the sfm. Default works fine..

Silver

Re: Load-balance from 4006 between 6509 and 6506

No configurations need to be made on the SFM. This is transparent to you and only provides a crossbar for the switch fabric enabled cards you have installed.

Hope this helps you,

Don

Bronze

Re: Load-balance from 4006 between 6509 and 6506

One quick question, if you want to send only one subnet across, why you want to trunk it.. Anyway if you want to trunk to forward other vlans, i don;t see the channel config on the CatOS side, make sure you do deseriable mode also on the catos side,,don't leave auto...

Here are some good links that might helps.

http://www.cisco.com/warp/customer/473/71.html

http://www.cisco.com/warp/customer/473/67.html

207
Views
0
Helpful
10
Replies
CreatePlease to create content