cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
630
Views
3
Helpful
7
Replies

Load balancind using loopback

gkaravit
Level 1
Level 1

Hello all, while I was reading some documentation i saw the following paragraph:

"Bundling of E1 links will be achieved by using unnumbered links, multiple unnumbered links use a single IP address usually configured as loopback address. Load balancing per packet is required on the E1 bundles to allow for efficient use of available bandwidth. "

It seemed quite interesting so I proceed to a test environment:

3 back-to-back E1 lines between two 72xx routers

first i checked that each back-to-back line is working properly: channel-group unframed on the controllers, on Router1 clock source line and on Router2 clock source internal, some private IPs, and all 3 interfaces pinged the other end.

Then I created a loopback on both routers with a new IP and changed to ip unnumbered loopback on each Serial:

========== config =========

Router1:

interface Loopback10

ip address 172.18.0.13 255.255.255.252

no ip directed-broadcast

interface Serial4/5:0

ip unnumbered Loopback10

interface Serial4/6:0

ip unnumbered Loopback10

!

interface Serial4/7:0

ip unnumbered Loopback10

Router2:

interface Loopback10

ip address 172.18.0.14 255.255.255.252

interface Serial4/0:0

ip unnumbered Loopback10

!

interface Serial4/1:0

ip unnumbered Loopback10

!

interface Serial4/2:0

ip unnumbered Loopback10

======================================

Shouldnt it just work? or do i have to use multilink in order to bundle the E1s?

Is there any documentation on the above?

Rgrds

1 Accepted Solution

Accepted Solutions

Please ignore the previous mail

When using unnumbered, you are using same subnet on bothends. This wouldnt work. I tried in my test lab.

so try giving different ip address on loopback interfaces and enable routing protocol.

-Deepu

View solution in original post

7 Replies 7

rais
Level 7
Level 7

It should work as is. Provided you have routes added, data will be shared among these lines. How data is shared depends what switching you are using (cef etc.)

Hope this helps.

Thanks.

Unfortunately it didnt (work) :(

Is there any documentation with configuration examples to see whats wrong with my config? Any ideas for debugging in order to find whats wrong?

When you are using ip unnumbered, do you have the end-to-end connectivity.

Coz, loopback ip address on each end, even though they are in same networks/subnetworks, there should be a way for the packets to go out. Otherwise, packets wouldnt go coz, the directly connected serial interfaces dont have ip address, so fail to connect to the other end.

Please try giving a static default route giving the next hop as your outgoing interface.

-Deepu

Please ignore the previous mail

When using unnumbered, you are using same subnet on bothends. This wouldnt work. I tried in my test lab.

so try giving different ip address on loopback interfaces and enable routing protocol.

-Deepu

Thanx! problem solved.. it was exactly that, ip address 172.18.0.10/32 on one loopback, 172.18.0.11/32 on the other, router protocol, and it worked..

Thanx for your answer!

You can also get it working by using same subnet IPs (the way you had) but putting static routes for the other side loopback interface e.g.

ip route 172.18.0.13 255.255.255.255 ser4/0:0

Thanks.

Curious... do you see a significant increase in CPU util? I've read that loopback interfaces forces the router to use process switching. If this is true, is this a reasonable solution? If you have point-to-point E1s then I would suggest PPP Multilink.

I'm looking for the same solution but I'm stuck with frame relay encapsulation and cannot find a solid answer to aggregate two T1s between two routers.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: