cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
513
Views
0
Helpful
5
Replies

Load Balancing 4 links (diferent speeds) without OSPF

willianp
Level 1
Level 1

Hi all,

I need to implement load balancing between a Nortel Passport and a Cisco 3600 router, there are 4 serial links connecting them ( 3 128K and 1 256K), i am using static route pointing the same network address for all links, but Cisco IOS balance the links for the slowest speed, so the 256k link is working with the maximum speed of 128K. Is there a way to use the total bandwith, without implementing a routing protocol like OSPF?

Regads,

Willian Prando CCNA

IBM Brasil - Network Strategic Outsourcing

5 Replies 5

steve.barlow
Level 7
Level 7

You can use Multilink PPP. Per cisco: "The Multilink PPP feature provides load balancing functionality over multiple WAN links, while providing multivendor interoperability, packet fragmentation and proper sequencing, and load calculation on both inbound and outbound traffic. The Cisco implementation of MLP supports the fragmentation and packet sequencing specifications in RFC 1717."

eg.

username RouterB password xxxxxx

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Ethernet0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial2

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial3

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Ethernet0

ip address 10.10.10.10 255.255.255.0

Or you can use CEF:

http://www.cisco.com/warp/public/cc/pd/ifaa/pa/much/prodlit/loadb_an.htm

Hope it helps.

Steve

Steve,

Do you know if I can stay with the ip address on my interfaces? it will still work? Since I am not using any routing protocol if I loose my ip addresses all my static routes will not work.

Regards,

Willian Prando

For CEF (per packet or per destination) it's not a problem, keep your IP's. For PPP Multilink you could point the static routes to the interface virtial-template. Example, ip route x.x.x.x 255.255.255.0 virtual-template 1. Each physical interface can't have it's own IP as all interfaces in the PPP bundle are treated as one interface (IP applied on the virtual interface).

Steve

rhyun
Level 1
Level 1

William,

I have the same issue recently – load balancing between a OC-12(622Mbps) and a OC-3(155Mbps). I tested and am going to use the recursive static routing. The method is - first assigning five different private ip addresses, and configuring static routing for these five networks toward the two links at the ratio of 4:1, and then configuring static routing for the destination addresses to the five networks again.

For example, let destination address x.x.x.x(mask y), the next-hop addresses of two links 10.0.0.1(OC-12) & 11.0.0.1(OC-3), and private addresses 172.30.0.1~5. The configuration is :

ip route 172.30.0.1~.4 255.255.255.255 10.0.0.1

ip route 172.30.0.5 255.255.255.255 11.0.0.1

ip route x.x.x.x y 172.30.0.1~.5

(note) Cisco routers, CEF enabled

Regards,

Hyun Ryu

Network Planning Team, DACOM

I tried to use Multilink PPP, but the Nortel Passport do not support it so it won´t work, I think the only option that I have is using OSPF....

Does anyone have another ideia that will work between a Cisco 3600 and a Nortel Passport ?

Regards,

Willian Prando

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: