Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Load balancing between Frame Relay and ADSL

I want to setup redundancy and load balancing between FR and ADSL. I would like internet traffic only through the ADSL interface and all other traffic through the FR interface. In the event of a failure of either of the interfaces, all traffic should be rerouted to the active interface. What is the best way to accomplish this on a router?

2 REPLIES

Re: Load balancing between Frame Relay and ADSL

Hi Friend,

You can implement Policy Base Routing for the purpose.

Check this list for more details.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart1/qcpolicy.htm

For redundancy when you impleme PBR you can get the interface check also

Like when you implement PBR you will match the traffic and set the exit interface same time you can put second interface and it will match if first interface is down it will start sending all traffic by another interface.

HTH

Ankur

VIP Purple

Re: Load balancing between Frame Relay and ADSL

Hello Wayne,

your configuration should look something like this (of course the IP addresses might be different in your case):

access-list 101 permit tcp any any eq www

access-list 101 permit tcp any any eq 443

access-list 101 permit udp any any eq domain

access-list 102 deny tcp any any eq www

access-list 102 deny tcp any any eq 443

access-list 102 deny udp any any eq domain

access-list 102 permit ip any any

!

interface FastEthernet0/1

ip policy route-map TRAFFIC

!

route-map TRAFFIC permit 10

match ip address 101

set ip next-hop 192.168.1.2

!

route-map TRAFFIC permit 20

match ip address 102

set ip next-hop 172.16.1.2

Then, turn on CEF (ip cef globally) on the router, and configure two static default routes:

ip route 0.0.0.0 0.0.0.0 192.168.1.2

ip route 0.0.0.0 0.0.0.0 172.16.1.2

Since the policy routing takes priority, the CEF table (FIB) is only looked up if the next-hop configured in the PBR route-map becomes unavailable.

Hope I didn´t forget anything, can you try and see if this works for you ?

Regards,

GP

109
Views
0
Helpful
2
Replies
CreatePlease to create content