Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Load Balancing on two dynamic ADSL Connection

Hi All,

I am doing the Load Balancing on two dynamic adsl. I have cisco 1721 with two adsl cards. I am doing NAT on the router for internal LAN going to internet. but apparently the loadbalancing doesn't work. I do NAT on the two interface dialer ( because it's dynamic ip). The connection always use the dialer1. here are the configs

any feedback will be appreciated

thank you very much

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 1/1

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

no fair-queue

!

interface ATM1

no ip address

no atm ilmi-keepalive

pvc 1/1

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

dsl operating-mode auto

no fair-queue

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

speed auto

!

interface Dialer1

bandwidth 512

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username aaaaa pass bbbbb

!

interface Dialer2

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 2

dialer-group 1

ppp pap sent-username xxxx password yyyyy

!

ip nat inside source list 1 interface Dialer2 overload

ip nat inside source list 2 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 dialer1

ip route 0.0.0.0 0.0.0.0 dialer2

no ip http server

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 2 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit

3 REPLIES
Bronze

Re: Load Balancing on two dynamic ADSL Connection

Hi,

you'll need to change your nat config to something like this:

ip nat inside source route-map provider1-map interface Dialer1 overload

ip nat inside source route-map provider2-map interface Dialer2 overload

!

route-map provider1-map permit 10

match ip address 1

match interface Dialer1

!

route-map provider2-map permit 10

match ip address 1

match interface Dialer2

hth

Herbert

New Member

Re: Load Balancing on two dynamic ADSL Connection

Hi,

thanks for your reply..

one question, will it backup each other ? lets say one link is down, will I get 50% packet loss ?

regards

santo

Bronze

Re: Load Balancing on two dynamic ADSL Connection

Good question.

Since your default routes point to Dialer interfaces, and Dialer interfaces are always up, both defaults will stay active even if one interface fails. So yes you will have 50% packet loss.

Not sure if/how this can be solved. I'm thinking along the lines of creating Dialer3 and Dialer4 and configure them as backup interfaces of the ATM interfaces. Then create default routes to them with a lower admin distance than to the Di1 and Di2.

Don't have any test equipment at hand unfortunately, but if you can, give it a try and let us know how it goes?

regards

Herbert

111
Views
0
Helpful
3
Replies