cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
208
Views
0
Helpful
1
Replies

Load Balancing outgoing traffic through 2 adsl lines without BGP!

dpapallis
Level 1
Level 1

Dear All,

I have a 2611 xm router with 3 ethernet interfaces one for the inside network and 2 for the adsl connections with the internet (two different isps)!

From the 1st i have (cytanet) one static ip and from the second (spidernet) a pool of 8 ip's!

The only thing that i want to do is to load balance the outgoing traffic (as also fault taulerance) with this configuration :

interface FastEthernet0/0

description $ETH-LAN$Connetction To Firebox-700

ip address a.0.0.1 255.255.255.248

no ip proxy-arp

ip nat inside

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

description $ETH-WAN$connected to CytaNet

ip address x.x.x.x 255.255.255.252

ip nat outside

ip policy route-map Cytanet

duplex auto

speed auto

no cdp enable

!

interface Ethernet1/0

description $ETH-WAN$connected to Spidernet

ip address y.y.y.y 255.255.255.248

ip nat outside

ip policy route-map Spidernet

half-duplex

no cdp enable

!

ip nat pool Spidernet y.y.y.y y.y.y.y netmask 255.255.255.248

ip nat inside source route-map Cytanet interface FastEthernet0/1 overload

ip nat inside source route-map Spidernet pool Spidernet overload

ip route 0.0.0.0 0.0.0.0 y.y.y.y

ip route 0.0.0.0 0.0.0.0 x.x.x.x

access-list 3 permit a.0.0.0 0.0.0.7

access-list 4 permit y.y.y.0 0.0.0.255 (subnet of ip's where dns servers of spidernet are)

route-map Spidernet permit 10

match ip address 4 3

match interface Ethernet1/0

set ip default next-hop y.y.y.y (DG of ADSL to Spidernet)

!

route-map Cytanet permit 10

match ip address 3

match interface FastEthernet0/1

set ip default next-hop x.x.x.x (DG of ADSL to Cytanet)

The only probem that i have is to redirect traffic for the subnet where the source ip address is from the dns server of the second provider spidernet

Any ideas ?

Thanks J.V.

1 Reply 1

didyap
Level 6
Level 6

I am not able to get why you are using the same route-maps to do NAT as well as Policy routing. See if the information in this doc helps you :

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080093fca.shtml