Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Load-balancing with OSPF

I have two WAN Links:

1. 2Mpbs encapsulation HDLC

2. 1Mpbs encapsulation HDLC

I use OSPF routing protocol to Load-balancing IP traffic.

I set cost 1024 (bandwidth 1024) both of the links.

What happend if my total traffic exceed more than 2Mbps ?

I will have drop packets from the second Link (1Mbps) ?

Router: cisco 3640

George

8 REPLIES

Re: Load-balancing with OSPF

Traffic on the 1 mb link cannot exceed the limit, so you wont get 2 mbps throughput. Probably your ISP would have rate limited yout traffic to 1 mbps and configured to drop any traffic above 1 mbps.

In your case the bandwidths (cost) manipulated, doesnt reflect the actual bandwidth of the link, and hence the 2 mbps link is being underutilized.

I would recommend using a routing protocol such as EIGRP which can do unequal cost load balancing, based on the bandwidth of the link, unless you are having a different vendor router on your network, due to which you are forced to run OSPF.

New Member

Re: Load-balancing with OSPF

I have changed the scenario (because using EIGRP is not an option) to the following:

I have switched to frame-relay service using 3 PVCs of 1Mbps CIR each,

the 1st PVC utilises 100% the the 1Mbps Link

and the other two utilise 100% of the 2Mbps Link.

So OSPF now knows 3 equal path links of 1Mbps each (3 subinterfaces) and is supposed to load balance the traffic between them (per destination). The bandwidth definition is the same on all subinterfaces from my side and ISP side.

The problem now is the IP traffic distribution between the three PVCs, which is very unusual.

According to MRTG graphs for each PVC,

1st PVC: 290k input, 446k output

2nd PVC: 121k input, 0k output

3rd PVC: 223k input, 1k output

Any ideas why the distribution is not (almost) equal between the three PVCs ?

Thanks..

Silver

Re: Load-balancing with OSPF

can you paste in the config on all 3 pvc's from both sides

New Member

Re: Load-balancing with OSPF

MY SIDE

-----------------------------------------------------

interface Serial0/0

bandwidth 1024

no ip address

encapsulation frame-relay IETF

load-interval 30

no fair-queue

frame-relay lmi-type q933a

!

interface Serial0/0.1 point-to-point

description *** 1st Link (Peer 10.0.199.97) ***

bandwidth 1024

ip address 10.0.199.98 255.255.255.252

no cdp enable

frame-relay interface-dlci 128

interface Serial0/1

bandwidth 2048

no ip address

encapsulation frame-relay IETF

load-interval 30

no fair-queue

serial restart-delay 0

frame-relay lmi-type q933a

!

interface Serial0/1.1 point-to-point

description *** 2nd Link (Peer 10.0.199.241) ***

bandwidth 1024

ip address 10.0.199.242 255.255.255.252

no cdp enable

frame-relay interface-dlci 228

!

interface Serial0/1.2 point-to-point

description *** 3rd Link (Peer 10.0.253.217)

bandwidth 1024

ip address 10.0.253.218 255.255.255.252

no cdp enable

frame-relay interface-dlci 328

router ospf 100

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 10.0.199.98 0.0.0.0 area 5

network 10.0.199.242 0.0.0.0 area 5

network 10.0.253.218 0.0.0.0 area 5

*****************************************************************

THE OTHER SIDE

-----------------------------------------------------

interface Serial3/0

bandwidth 1024

no ip address

encapsulation frame-relay IETF

no fair-queue

serial restart-delay 0

frame-relay lmi-type q933a

interface Serial3/0.3 point-to-point

description *** 1st Link (Peer 10.0.199.98) ***

bandwidth 1024

ip address 10.0.199.97 255.255.255.252

no cdp enable

frame-relay interface-dlci 128

interface Serial1/0

bandwidth 2048

no ip address

encapsulation frame-relay IETF

load-interval 30

serial restart-delay 0

frame-relay lmi-type q933a

!

interface Serial1/0.1 point-to-point

description *** 2nd Link (Peer 10.0.199.242) ***

bandwidth 1024

ip address 10.0.199.241 255.255.255.252

no cdp enable

frame-relay interface-dlci 228

!

interface Serial1/0.2 point-to-point

description *** 3rd Link (Peer 10.0.253.218) ***

bandwidth 1024

ip address 10.0.253.217 255.255.255.252

no cdp enable

frame-relay interface-dlci 328

router ospf 100

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 10.0.199.97 0.0.0.0 area 5

network 10.0.199.241 0.0.0.0 area 5

network 10.0.253.217 0.0.0.0 area 5

Silver

Re: Load-balancing with OSPF

good you have the same bandwidth statements on all interfaces , it looks like all your traffic is going out 1st PVC , this must be the cheapest way to the host . Can you turn on IP accounting on the s0.0.1. This will tell you the Source & dest ip addresses . You will have to tweak your cost somewhere once you figure out where the majority of the traffic is destined .

Once you capture the ip accounting stats paste them in and I can help you figure how to configure the path to load balance.

New Member

Re: Load-balancing with OSPF

I found the solution of my problem. Using the command 'sh ip cef' I noticed that was only one last resort route.

This was because I used to have a default route to my 1Mbps link peer, but I didn't put two new default routes for my new peers.

So the only traffic that was routed through the two new PVCs was for networks known in OSPF, and the rest was routed only through the first link..

Now everything works perfectly normal, balancing alomst equally between all three links :-)

Thanks to everyone for your help.

Gold

Re: Load-balancing with OSPF

There are lots of possible reasons.... For instance, you could be sourcing most of your traffic from one source, and sending it all to one destination. This would cause CEF to switch all the traffic available along one path.

I'd also check the routing table to make certain all three paths are listed in the routing table whenever one of them is listed.

Try this document:

http://www.cisco.com/en/US/tech/tk827/tk831/technologies_tech_note09186a0080094806.shtml

It might help.

Russ.W

Silver

Re: Load-balancing with OSPF

What you need to do is use the command 'ip ospf cost ' on all 4 sides of the links

the cost of a T1 is approk 60 the cost of an E1 is approx 45. so if you wanted to load balance what you would do is set the cost on the E1's to 45

ip ospf cost 45

on the 1024K link the cost is approx 90 on the 1024K links configure

ip ospf cost 90

this will do a relativley good job of balancing the traffic , keep in mind if you are using some kind of route-caching like CEF it will be per session not per packet load balancing

289
Views
0
Helpful
8
Replies