Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Loadbalancing with MCFC2 per-packet configuration working not well

I have a Catalyst 6509 with a Sup2 and MSFC2. We have two WAN links to a remote site and would like to do a load balancing per-packet basis. The MSFC2 has the following configuration.

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip load-sharing per-packet

!

interface Vlan20

ip address 192.168.20.1 255.255.255.0

ip load-sharing per-packet

!

router eigrp 1010

network 192.168.10.0

network 192.168.20.0

no auto-summary

no eigrp log-neighbor-changes

The sh ip route show me two routes to network 192.168.40.0/24 with the same metric.

192.168.30.0/30 is subnetted, 2 subnets

D 192.168.30.4 [90/2170112] via 192.168.20.3, 00:09:26, Vlan20

D 192.168.30.0 [90/2170112] via 192.168.20.2, 00:09:26, Vlan20

C 192.168.10.0/24 is directly connected, Vlan10

D 192.168.40.0/24 [90/2195712] via 192.168.20.3, 00:01:29, Vlan20

[90/2195712] via 192.168.20.2, 00:01:29, Vlan20

C 127.0.0.0/8 is directly connected, EOBC0/0

C 192.168.20.0/24 is directly connected, Vlan20

The ip cef 192.168.40.0 show me the MSFC2 should do load balance per packet over the two wan links to the network 192.168.40.0.

RT1#sh ip cef 192.168.40.0

192.168.40.0/24, version 25, per-packet sharing

0 packets, 0 bytes

via 192.168.20.3, Vlan20, 0 dependencies

traffic share 1, current path

next hop 192.168.20.3, Vlan20

valid adjacency

via 192.168.20.2, Vlan20, 0 dependencies

traffic share 1

next hop 192.168.20.2, Vlan20

valid adjacency

0 packets, 0 bytes switched through the prefix

RT1#

if I do a ping from host 192.168.10.3 residing on the network 192.168.10.0/24 to the host 192.168.40.1 on network 192.168.40.0/24 the serial interface show me unequal load on the two links.

Link1 Link2

RT1 RT2

TX 20/255 TX 20/255

RX 41/255 RX 1/255

I made also a debug on both links. The debug on link1 shows me icmp echo request and replays but on the link2 there are only icmp replays, no icmp echo request packets.

Thanks for any recommendations,

Rolf

1 REPLY
Bronze

Re: Loadbalancing with MCFC2 per-packet configuration working no

Hi Rolf,

Are the two WAN links of equal cost? If not the variance command has to be enabled to do unequal cost load balancing.

Please check that.

The following is a doc on Troubleshooting Load Balancing Over Parallel Links Using Cisco Express Forwarding. It might be able to help you diagonise and solve the problem.

http://www.cisco.com/en/US/tech/tk648/tk365/technologies_tech_note09186a0080094806.shtml

94
Views
0
Helpful
1
Replies
CreatePlease login to create content