Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Loads Of Output Queue Drops, HELP!!

Hi There,

We have a 2MB serial interface that is really busy and I was wondering what I could do to improve upon this config. I have included the config and a sh int s0/0 which happens to be the interface getting hammered. CPU proc is at 65% + continually and the process using the most CPU is IP @ 6.5%.

I was thinking of putting on WFQ as it should control traffic better than FIFO or am I wrong?

Any help would be hugely appreciated.

Thanks

Serial0/0 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: IPclear Frame link 1

MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,

reliability 255/255, txload 233/255, rxload 183/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 224, LMI stat recvd 224, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

FR SVC disabled, LAPF state down

Broadcast queue 0/64, broadcasts sent/dropped 1124/0, interface broadcasts 112

4

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:37:16

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 66304

Queueing strategy: fifo

Output queue: 22/40 (size/max)

5 minute input rate 1471000 bits/sec, 3372 packets/sec

5 minute output rate 1874000 bits/sec, 3480 packets/sec

7591762 packets input, 412670209 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

7822955 packets output, 527987182 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

version 12.2

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

!

hostname "IPC1001"

!

logging buffered 8000 debugging

no logging console

enable password xxxx

!

clock summer-time BST recurring

ip subnet-zero

!

!

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

!

call rsvp-sync

!

interface FastEthernet0/0

ip address 10.126.35.245 255.255.252.0

duplex auto

speed auto

!

interface Serial0/0

description IPclear Frame link 1

bandwidth 2048

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

description 2Meg IP Clear Link

bandwidth 2048

ip unnumbered FastEthernet0/0

ip accounting output-packets

frame-relay class 2048k

frame-relay interface-dlci 101

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

router rip

version 2

redistribute bgp 64531

network 10.0.0.0

default-metric 3

no auto-summary

!

router bgp 64531

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor 10.126.35.250 remote-as 65400

neighbor 62.6.192.196 remote-as 2856

neighbor 62.6.192.196 ebgp-multihop 255

neighbor 62.6.192.196 update-source FastEthernet0/0

neighbor 62.6.192.196 filter-list 1 in

default-information originate

no auto-summary

!

no ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0.1

ip route 10.126.32.0 255.255.252.0 FastEthernet0/0

ip route 62.6.192.196 255.255.255.255 Serial0/0.1

ip http server

ip as-path access-list 1 deny _2856$

ip as-path access-list 1 permit .*

!

map-class frame-relay 2048k

no frame-relay adaptive-shaping

no logging trap

no cdp run

!

snmp-server community xxx

snmp-server community snmpv1 view xxxx RO

snmp-server trap-source FastEthernet0/0

snmp-server location xxxx

snmp-server chassis-id cisco2621

no snmp-server enable traps tty

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps envmon

snmp-server enable traps bgp

snmp-server enable traps frame-relay

snmp-server enable traps syslog

snmp-server enable traps rtr

snmp-server host xxxx snmpv1

!

dial-peer cor custom

!

line con 0

password xxxx

login

line aux 0

line vty 0 4

password xxxx

login

ntp clock-period 17180021

ntp server 10.126.35.248 source FastEthernet0/0

end

4 REPLIES
Cisco Employee

Re: Loads Of Output Queue Drops, HELP!!

The output you provided indicates the reason for drops is the load on the link. The question is what do you want to do? Reduce the load or improve the chances for certain traffic to make it through? If you want to reduce the load then you will need to rate limit traffic toward that link (ie, at the ingress FE ints on the router). If you want to create a more fair utilization of the link (still dropping though) then WFQ or CBWFQ will help. Remember you have a 100Mb FE feeding a 2Mb Serial so your drops are expected.

Bronze

Re: Loads Of Output Queue Drops, HELP!!

You could tune rip to reduce its effects. Stretch out the updates and the interpacket delay.

Also, not sure but I'm wondering if the unnumbered interface causes any traffic from the ethernet to get on the circuit (layer 3 broadcasts, etc.) ? Anyone know if thats could be happenning???

New Member

Re: Loads Of Output Queue Drops, HELP!!

You can enable CEF if the CPU utilisation is hitting high. Observe the type of traffic flowing through the router by enabling " ip route cache flow" on the ethernet. then issue "show ip cache flow" to check if ICMP traffic is high due to recent viruses.

New Member

Re: Loads Of Output Queue Drops, HELP!!

Hi There,

Thanks for the help all, I will investigate these options.

Regards

Andrew Morris

166
Views
0
Helpful
4
Replies
CreatePlease login to create content