Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Local DDNS server on 831

I would like to configure my 831 router to add dynamic DNS entries to its local DNS database whenever a new client (Windows box) is assigned an IP address from its DHCP server.

The 831 is running a DNS server (ip dns server) to filter all client DNS queries.

There is some info about how to do this in the "Dynamic DNS Support for Cisco IOS Software" section of the "Cisco IOS IP Addressing Services Configuration Guide" (Release 12.3 and 12.4), but I can't get it to work for a local DDNS server.

Here's my config as of now:

! enable DNS server

ip dns server

! setup DDNS

ip dhcp update dns both override

ip ddns update method myddns

internal

! configure NAT

access-list 101 permit ip 10.10.10.0 0.0.0.255 any

ip nat inside source list 101 interface e1 overload

! client DHCP pool

ip dhcp pool clients

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 10.10.10.1

lease 0 2

! exclude e0 interface from DHCP pools

ip dhcp excluded-address 10.10.10.1

! interface configure

interface e0

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip ddns update myddns

interface e1

ip address dhcp client-id e1

ip nat outside

interface e2

no ip address

shutdown

interface FastEthernet1

no ip address

interface FastEthernet2

no ip address

interface FastEthernet3

no ip address

interface FastEthernet4

no ip address

2 REPLIES
VIP Purple

Re: Local DDNS server on 831

Hello,

can you post the output of ´debug ip ddns update´ ? This might reveal the reason for the database not being updated...

Regards,

GP

New Member

Re: Local DDNS server on 831

There is actually no output when 'debug ip ddns update' is used.

There is some useful debug output from 'debug ip dhcp server packet' and 'debug domain'. I've included this debug output below.

Note that the DHCP request to my ISP via the outside interface (e1) returns a domain name of 'hsd1.md.comcast.net', a primary DNS server of 68.87.73.242, and a secondary DNS server of 68.87.71.226. The DHCP transaction shown in the debug output below is from when my router assigns an IP address to a client on its inside interface (e0). This client is a Windows box with a computer name of 'slappy'.

Jan 9 13:18:52.258: DHCPD: DHCPDISCOVER received from client 0100.07e9.5f8d.14 on interface Ethernet0.

Jan 9 13:18:54.258: DHCPD: Sending DHCPOFFER to client 0100.07e9.5f8d.14 (10.10.10.2).

Jan 9 13:18:54.258: DHCPD: creating ARP entry (10.10.10.2, 0007.e95f.8d14).

Jan 9 13:18:54.258: DHCPD: unicasting BOOTREPLY to client 0007.e95f.8d14 (10.10.10.2).

Jan 9 13:18:54.262: DHCPD: DHCPREQUEST received from client 0100.07e9.5f8d.14.

Jan 9 13:18:54.266: DHCPD: Appending system default domain

Jan 9 13:18:54.266: DHCPD: Using hostname 'slappy..hsd1.md.comcast.net.' for dynamic update (from FQDN option)

Jan 9 13:18:54.266: DHCPD: Doing dynamic update...

Jan 9 13:18:54.266: DHCPD: Updating 'PTR' RR 10.10.10.2 -> 'slappy..hsd1.md.comcast.net.'

Jan 9 13:18:54.266: DHCPD: Updating 'A' RR 'slappy..hsd1.md.comcast.net.' -> 10.10.10.2

Jan 9 13:18:54.266: DDNS: Enqueuing new DDNS update 'slappy..hsd1.md.comcast.net.' <=> 10.10.10.2

Jan 9 13:18:54.266: DHCPD: Sending DHCPACK to client 0100.07e9.5f8d.14 (10.10.10.2).

Jan 9 13:18:54.270: DHCPD: Including FQDN option name 'slappy..hsd1.md.comcast.net.' rcode1=255, rcode2=255 flags=0x3

Jan 9 13:18:54.270: DHCPD: creating ARP entry (10.10.10.2, 0007.e95f.8d14).

Jan 9 13:18:54.270: DHCPD: unicasting BOOTREPLY to client 0007.e95f.8d14 (10.10.10.2).

Jan 9 13:18:54.274: Domain: query for 2.10.10.10.in-addr.arpa type 6 to 68.87.73.242

Jan 9 13:18:54.294: Domain: Reply received no such name

Jan 9 13:18:54.294: DDNS: Can't find authoritative zone info for '2.10.10.10.in-addr.arpa.'

Jan 9 13:18:54.298: Domain: query for slappy..hsd1.md.comcast.net type 6 to 68.87.73.242

Jan 9 13:18:57.166: Domain: query for slappy..hsd1.md.comcast.net type 6 to 68.87.71.226

Jan 9 13:18:57.314: Domain: query for slappy..hsd1.md.comcast.net type 6 to 68.87.73.242

Jan 9 13:19:00.194: DDNS: Can't find authoritative zone info for 'slappy..hsd1.md.comcast.net.'

Jan 9 13:19:00.194: DDNS: Update of 'slappy..hsd1.md.comcast.net.' <=> 10.10.10.2 finished

Jan 9 13:19:00.194: Destroying binding info after doing update

Jan 9 13:19:00.330: Domain: query for slappy..hsd1.md.comcast.net type 6 to 68.87.73.242

Jan 9 13:19:03.346: Domain: query for slappy..hsd1.md.comcast.net type 6 to 68.87.71.226

As you can see, the router appends the external domain name to the client's computer name to create a hostname. I don't understand why there are two periods in between. I'm not sure if this concatenation should even occur. I also don't understand why the router is querying my ISP's DNS servers for my client's inside IP address and hostname. Any help would be appreciated.

Thanks,

-Paul

839
Views
5
Helpful
2
Replies
CreatePlease to create content