Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Lock and Key ACL outbound on Dialer Interfaces?

I am try to set up Lock and Key ACLs on dialer interfaces on a 2610. I want it for outbound traffic. Everything looks ok. However, when I telnet to the dialer interfaces IP and log in I get a message saying:

No input access group defined for Ethernet0/0.

What little information I can find on Lock and Key indicates you can put the ACL on any interface in or out. I am missing something here? Here is the part of my configuration that addresses the Key and Lock ACL.

Current configuration : 29521 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router

username testuser password testpass

!

interface Ethernet0/0

ip address 192.168.1.3 255.255.255.248

ip nat inside

half-duplex

no cdp enable

!

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async mode dedicated

ppp authentication chap

group-range 33 40

!

interface Dialer1

description testdial

ip address 172.20.11.10 255.255.255.240

ip access-group 102 out

ip nat outside

dialer pool 1

dialer remote-name remotesite

dialer idle-timeout 45000

dialer string 628

dialer-group 1

no cdp enable

access-list 102 remark Testing Dynamic ACL

access-list 102 dynamic testacl timeout 120 permit ip any any log

access-list 102 permit tcp any host 172.20.11.10 eq telnet

access-list 102 deny ip any any log

line vty 0 4

password termpass

login local

autocommand access-enable timeout 5

end

Thanks Much!!!

Chuck Glover

2 REPLIES

Re: Lock and Key ACL outbound on Dialer Interfaces?

I have never seen this done with an acl out, only in. Makes sense as you must telnet into the router first, get authenticated, then the dynamic acl is created allowing you access. Change the access-group to in and see what happens.

This is a good link on lock and key: http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800d9814.html

Hope it helps.

Steve

Bronze

Re: Lock and Key ACL outbound on Dialer Interfaces?

I assume what you want here is for people to dial in, enable lock and key via telnet, and then be able to get access to networks behind the 2610, with the access-list restrictions being placed on packets OUT OF the 2610, towards the dial in client. Anything else would not make any sense.

Note that since your dynamic access-list permits any any, it could just as well be placed inbound. Note too that an inbound list saves processing/network time; any packets denied will be dropped. For outbound, all inbound packets would be accepted, routed, responded to, routed back, and then dropped. It would make no sense to want this. I can't see where it's mentioned that outbound is not supported in the docs, yet looking at the code I see that one of the first checks we do is for an inbound access-list, so I don't believe that outbound is supported.

200
Views
0
Helpful
2
Replies