Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Loss of network connection using NAT

Good day;

I'm currently bringing users over slowly to a private address 10.0.0.0

There are two problems I'm having that I'm hoping someone can help me out.

If anyone on the 10 Network accesses our file server on the 142.143 Net to run a access database, its seems the connection times out and I get an error stating no network connection. The time out can take 5 minutes or fifteen minutes. The same applies when transfering files from the 142.143 Network to the 10 Network. If the file is over 80 MB (we have a few that large), the connection will drop three quarters the way through the transfer.

I know this is a very general described question and I will be more then happy to answer any questions requiring more detail.

Below is the config for my NAT Router.

Current configuration : 1804 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname *******

!

boot-start-marker

boot-end-marker

!

no logging on

enable secret 5 ***************

!

no aaa new-model

ip subnet-zero

!

!

ip domain name mhcp.on.ca

ip name-server 142.143.186.132

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.0.1 255.255.0.0

ip nat inside

duplex auto

speed auto

!

interface Ethernet1/0

ip address 142.143.186.236 255.255.255.128

ip nat outside

half-duplex

!

router rip

network 10.0.0.0

network 142.143.0.0

no auto-summary

!

ip nat pool ovrld 142.143.186.179 142.143.186.179 prefix-length 16

ip nat inside source list 7 pool ovrld overload

ip nat inside source static 10.1.0.209 142.143.186.144

ip nat inside source static 10.1.2.1 142.143.186.177

ip nat inside source static 10.1.0.203 142.143.186.134

ip nat inside source static 10.1.0.205 142.143.186.139

ip nat inside source static 10.1.2.7 142.143.186.151

ip nat inside source static 10.1.0.250 142.143.186.247

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 142.143.186.129

!

!

logging 10.1.0.209

access-list 7 deny 10.1.2.1

access-list 7 deny 10.1.0.2

access-list 7 deny 10.1.1.1

access-list 7 deny 10.1.2.7

access-list 7 deny 10.1.0.203

access-list 7 deny 10.1.0.205

access-list 7 deny 10.1.0.210

access-list 7 deny 10.1.0.209

access-list 7 deny 10.1.0.250

access-list 7 permit 10.1.0.0 0.0.255.255

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

password 7 ******************

login

terminal-type monitor

line aux 0

line vty 0 4

password 7 *****************

login

terminal-type monitor

!

!

!

end

1 REPLY
Bronze

Re: Loss of network connection using NAT

Are the transfers using UDP ? Try increasing the nat translation udp timeout. Maybe some of the translations are timing out resulting in the connectivity loss.

(ip nat translation udp-timeout )

99
Views
0
Helpful
1
Replies
CreatePlease login to create content