Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

low on memory, try again later error

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

hello, i work for an isp and we have recently been experiencing some major problem with one of our 2600 routers. After a certain period of time the router runs out of memory. we upgraded the ios and installed more memory as well as access-list for the recent virus'. here is a copy of the show memory processes command

router#show processes memory

Total: 42417564, Used: 14275692, Free: 28141872

PID TTY Allocated Freed Holding Getbufs Retbufs Process

0 0 143104 10892 2429864 0 0 *Init*

0 0 176 19920 176 0 0 *Sched*

0 0 7179888 2624756 68 163260 0 *Dead*

1 0 0 0 6884 0 0 Chunk Manager

2 0 188 188 3884 0 0 Load Meter

3 66 2900 940 15320 0 0 Virtual Exec

4 0 0 0 6884 0 0 Check heaps

5 0 88996 0 69640 21320 0 Pool Manager

6 0 0 0 6884 0 0 AAA_SERVER_DEADT

7 0 188 188 6884 0 0 Timers

8 0 188 188 6884 0 0 Serial Backgroun

9 0 188 188 6884 0 0 AAA high-capacit

10 0 188 188 6884 0 0 Environmental mo

11 0 22604 2051832 29488 0 0 ARP Input

12 0 0 0 6884 0 0 HC Counter Timer

13 0 188 188 6884 0 0 DDR Timers

14 0 4796 1172 10508 0 0 Entity MIB API

15 0 0 0 6884 0 0 SERIAL A'detect

16 0 188 188 6884 0 0 GraphIt

17 0 188 188 12884 0 0 Dialer event

18 0 0 0 6884 0 0 Critical Bkgnd

18 0 0 0 6884 0 0 Critical Bkgnd

PID TTY Allocated Freed Holding Getbufs Retbufs Process

19 0 124032 0 116264 0 0 Net Background

20 0 188 188 12884 0 0 Logger

21 0 188 188 6884 0 0 TTY Background

22 0 0 0 9884 0 0 Per-Second Jobs

23 0 188 188 6884 0 0 SM Monitor

24 0 0 0 6884 0 0 Net Input

25 0 188 188 6884 0 0 Compute load avg

26 0 1084 0 7648 260 0 Per-minute Jobs

27 0 0 0 6884 0 0 Service-module a

28 0 188 188 6884 0 0 AAA Server

29 0 0 0 6884 0 0 AAA ACCT Proc

30 0 0 0 6884 0 0 ACCT Periodic Pr

31 0 188 188 6884 0 0 AAA Dictionary R

32 0 13415828 0 10849960 9360 0 IP Input

33 0 0 0 6884 0 0 ICMP event handl

34 0 12712 3060 16816 0 0 CDP Protocol

35 0 376 376 12884 0 0 PPP Hooks

36 0 0 0 6884 0 0 X.25 Encaps Mana

37 0 0 0 12884 0 0 TCP Timer

38 0 14384 0 14384 0 0 TCP Protocols

39 0 0 0 6884 0 0 Socket Timers

40 0 1868 0 11752 0 0 HTTP CORE

40 0 1868 0 11752 0 0 HTTP CORE

PID TTY Allocated Freed Holding Getbufs Retbufs Process

41 0 648 404 13128 0 0 PPP IP Route

42 0 188 188 12884 0 0 PPP IPCP

43 0 76 0 9960 0 0 IP Background

44 0 152 0 10036 0 0 IP RIB Update

45 0 188 188 6884 0 0 Adj Manager

46 0 0 0 6884 0 0 Asy FS Helper

47 0 0 0 6884 0 0 RARP Input

48 0 29824 188 22740 0 0 DHCPD Receive

49 0 0 173524 6884 0 0 IP Cache Ager

50 0 0 0 24884 0 0 COPS

51 0 188 188 6884 0 0 PPP Bind

52 0 0 0 6884 0 0 PAD InCall

53 0 188 188 12884 0 0 X.25 Background

54 0 188 188 6884 0 0 LOCAL AAA

55 0 188 188 6884 0 0 ENABLE AAA

56 0 188 188 6884 0 0 LINE AAA

57 0 2056 188 8752 0 0 TPLUS

59 0 188 188 6884 0 0 CRM_CALL_UPDATE_

60 0 188 188 6884 0 0 AAA SEND STOP EV

61 0 0 0 6884 0 0 Syslog Traps

62 0 1868 0 8752 0 0 SAA Event Proces

63 0 188 188 12900 0 0 HyBridge Input

49 0 0 173524 6884 0 0 IP Cache Ager

50 0 0 0 24884 0 0 COPS

51 0 188 188 6884 0 0 PPP Bind

52 0 0 0 6884 0 0 PAD InCall

53 0 188 188 12884 0 0 X.25 Background

54 0 188 188 6884 0 0 LOCAL AAA

55 0 188 188 6884 0 0 ENABLE AAA

56 0 188 188 6884 0 0 LINE AAA

57 0 2056 188 8752 0 0 TPLUS

59 0 188 188 6884 0 0 CRM_CALL_UPDATE_

60 0 188 188 6884 0 0 AAA SEND STOP EV

61 0 0 0 6884 0 0 Syslog Traps

62 0 1868 0 8752 0 0 SAA Event Proces

63 0 188 188 12900 0 0 HyBridge Input P

PID TTY Allocated Freed Holding Getbufs Retbufs Process

64 0 376 188 7088 0 0 Tbridge Monitor

65 0 340 188 7052 0 0 Spanning Tree

66 0 188 188 12884 0 0 PPP manager

67 0 95860 712 108032 0 0 PPP Events

68 0 212 212 6884 0 0 Multilink PPP

69 0 188 188 6884 0 0 Multilink event

70 0 0 0 6884 0 0 DHCPD Timer

71 0 188 0 7084 0 0 DHCPD Database

14184728 Total

I blocked ports 69, 135, 445 and 593 for the virus. any other suggestions on what could be doing this. here is also a copy of the show version and running config. any suggestions would be greatly appreciated.

thanks

mike

IOS (tm) C2600 Software (C2600-I-M), Version 12.3(1a), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Fri 06-Jun-03 22:07 by dchih

Image text-base: 0x80008098, data-base: 0x80C90180

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

router uptime is 21 minutes

System returned to ROM by reload

System image file is "flash:c2600-i-mz.123-1a.bin"

cisco 2620 (MPC860) processor (revision 0x600) with 61440K/4096K bytes of memory

.

Processor board ID JAD052109ZD (703326654)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Building configuration...

Current configuration : 1036 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router

!

enable secret 5 xxxxxxxxxxxxxxx

enable password xxxxxxxxxxxx

ip subnet-zero

!

!

interface FastEthernet0/0

description to office ethernet

ip address x.x.254.2 255.255.255.0

ip access-group 101 in

ip access-group 101 out

speed auto

full-duplex

bridge-group 1

!

interface Serial0/0

description to St. Gen

bandwidth 1536

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip mroute-cache

no fair-queue

bridge-group 1

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route x.x.254.0 255.255.255.0 Serial0/0

ip route x.x.138.0 255.255.255.0 x.x.254.1

ip route x.x.138.0 255.255.255.0 FastEthernet0/0

ip route x.x.138.0 255.255.255.0 x.x.138.1

!

!

bridge 1 protocol ieee

!

line con 0

password xxxxxxxxxx

login

transport preferred none

line aux 0

line vty 0 4

password xxxxxxxxxxx

login

transport preferred none

!

!

!

end

1 REPLY
New Member

Re: low on memory, try again later error

We have the same problem on a 3660.

Did you block icmp echo and echo-replies too?

290
Views
0
Helpful
1
Replies