Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

making NM-16ESW in 2611XM work ?

Hello,

I recently had to configure abovementioned router with Ethernet switch network module.

However, I do not seem te be able to route from a port (1/0 - 1/15) on the NM-16ESW module to the router ports (0/0 and 0/1).

Software is IP BASE 12.3 (5b)

I'm trying to connect local users to the NM-16ESW module (several ports per VLAN) and then perform both inter-VLAN routing and routing to the in-built router ports.

I did so by declaring the ports as "switchport mode access" and "switchport access vlan NNN" and then defining "interface vlan NNN" with "ip address XXX Mask". Can anyone declare what is wrong ? The command formats used are similar as for C3550 L3 switches.

Another attempt involved declaring a port on the NM-16ESW as a trunk port. "switchport mode trunk", "switchport encapsulation dot1q", "switchport trunk allowed vlan NNN" for several values.

When doing "show run" afterwards, the trunk characteristics had all disappeared.

As it is the first time that I try to configure ports on such a module, I am not sure whether I'm using the correct commands, or that the software is supporting these features.

Can anybody clarify ?

Thank you

Paul De Valck

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: making NM-16ESW in 2611XM work ?

3 REPLIES
Silver

Re: making NM-16ESW in 2611XM work ?

New Member

Re: making NM-16ESW in 2611XM work ?

I too am going to have the configuration that was specified in this question. Although the document you specified has all the questions, I am very new at this and need to route between networks I create on the switch. Do you have a example of the code to accomplish this?

thank you

New Member

Re: making NM-16ESW in 2611XM work ?

You can find a configuration underneath,

but this is only the result of the show run command.

For this to work there are first the commands to define the VLANs :

....#vlan database

....(...)#vlan NN name ....

these commands are necessary. Without defining the vlans, it is not possible to route from the switch-ports.

However, these commands do not show up in a "show run"

Hope this helps a little.

!

!

!

interface FastEthernet0/0

description To_firewall_naar_DvS

ip address 192.168.0.125 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

description naar WLAN_apparatuur_via_SDH

no ip address

speed 10

full-duplex

!

interface FastEthernet0/1.701

encapsulation dot1Q 701

ip address 172.28.1.2 255.255.255.252

ip access-group 21 out

!

interface FastEthernet0/1.801

encapsulation dot1Q 801

ip address 172.28.1.6 255.255.255.252

ip access-group 21 out

!

interface FastEthernet1/0

description naar LAN DvS voor vast aangesloten apparatuur sluizen

switchport access vlan 10

no ip address

!

interface FastEthernet1/1

description naar vast aangesloten apparatuur sluizen

switchport access vlan 10

no ip address

!

interface FastEthernet1/2

switchport access vlan 2

no ip address

!

interface FastEthernet1/3

switchport access vlan 3

no ip address

!

interface FastEthernet1/4

no ip address

shutdown

!

interface FastEthernet1/5

no ip address

shutdown

!

interface FastEthernet1/6

no ip address

shutdown

!

interface FastEthernet1/7

no ip address

shutdown

!

interface FastEthernet1/8

no ip address

shutdown

!

interface FastEthernet1/9

no ip address

shutdown

!

interface FastEthernet1/10

no ip address

shutdown

!

interface FastEthernet1/11

no ip address

shutdown

!

interface FastEthernet1/12

no ip address

shutdown

!

interface FastEthernet1/13

no ip address

shutdown

!

interface FastEthernet1/14

description naar_WLAN_access_point_DvS

switchport mode trunk

no ip address

!

interface FastEthernet1/15

description naar_WLAN_sluizen_via_SDH

switchport mode trunk

no ip address

!

interface Vlan1

description Beheer_WLAN_Access_Points

ip address 192.168.0.30 255.255.255.224

ip access-group 1 out

!

interface Vlan2

description DvSBedrijf_via_WLAN

ip address 192.168.0.254 255.255.255.128

ip access-group 2 out

!

interface Vlan3

description DvSPrive_via_WLAN

ip address 192.168.0.62 255.255.255.224

ip access-group 3 out

!

no ip http server

ip classless

!

!

access-list 1 remark to Access Points

access-list 1 remark from network management

access-list 1 permit 10.32.1.32 0.0.0.31

access-list 1 permit 10.192.1.32 0.0.0.31

access-list 2 permit 192.168.0.126

access-list 2 remark to Workgroup Bridges & DvSBedrijf

access-list 2 remark from network management and firewall Hasselt DvS

access-list 2 permit 10.32.1.32 0.0.0.31

access-list 2 permit 10.192.1.32 0.0.0.31

access-list 3 remark to DvSPrive

access-list 3 remark from firewall Hasselt DvS

access-list 3 permit 192.168.0.126

access-list 11 remark to Access Points

access-list 11 remark from network management

access-list 11 permit 10.32.1.32 0.0.0.31

access-list 11 permit 10.192.1.32 0.0.0.31

access-list 21 permit 192.168.0.126

access-list 21 permit 172.28.1.2

access-list 21 permit 172.28.1.6

access-list 21 permit 192.168.0.136

access-list 21 permit 192.168.0.141

access-list 21 permit 192.168.0.131

access-list 21 permit 192.168.0.132

access-list 21 permit 192.168.0.133

access-list 21 permit 192.168.0.134

access-list 21 permit 192.168.0.135

access-list 21 remark to management

access-list 21 permit 192.168.0.0 0.0.0.31

!

!

!

!

419
Views
0
Helpful
3
Replies
CreatePlease login to create content