cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
588
Views
5
Helpful
4
Replies

Management VLAN

h.stepp
Level 1
Level 1

I am in the process of changing my managment VLAN from VLAN 1 to VLAN 2. I made the change on a 5500 switch with a RSM module and it is connected to our backbone switch which is also a 5500 and it works fine. The problem I am having is how do you change the management VLAN on a 2900/3500 XL? I created the new VLAN but it will not become active until I remove the IP address off the VLAN 1 interface. It then displays a status of UP Down for VLAN 1. The new VLAN 2 shows UP UP but I am not able to ping the backbone switch. The connection between the 2900 and my backbone is a ISL trunk link. The management VLAN has not been changed on the backbone switch yet, does this have to be changed first before I can change the other switches?

The documentation keeps refering to configuring cluster to make the VLAN management change but I am not using cluster.

Any help would be greatly appreciated.

4 Replies 4

sguerrero
Level 1
Level 1

Here´s an example of a catalyst 3548 using VLAN 2 instead of VLAN 1 as default:

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname IC2_AZC

!

enable password red

!

!

ip subnet-zero

ip dhcp-server 10.194.8.60

!

!

!

interface FastEthernet0/1

switchport access vlan 2

!

interface FastEthernet0/2

switchport access vlan 2

!

interface FastEthernet0/3

switchport access vlan 2

.

.

.

.

.

interface FastEthernet0/48

switchport access vlan 2

!

interface GigabitEthernet0/1

switchport access vlan 2

switchport mode trunk

!

interface GigabitEthernet0/2

switchport access vlan 2

switchport mode trunk

!

interface VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN2

ip address 10.194.34.47 255.255.254.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 10.194.34.1

!

line con 0

transport input none

stopbits 1

line vty 0 4

password red2

login

line vty 5 15

login

!

end

That is not exactly what I am looking for I do not want to put all of the Ethernet ports in VLAN 2 I only want to use VLAN 2 for management traffic. I plan on using other VLANs for user traffic.

Erick Bergquist
Level 6
Level 6

Hi,

You need to shutdown the VLAN1 interface, then put no shutdown under the VLAN2 interface. The VLAN interfaces on the 2900/3500s are Management interfaces ONLY and only one of them can be up at a time.

You're going to have to console into the switch to do this. You'll lose your telnet connection to the switch if you shut down interface VLAN1 remotely.

Erick

colin.mccrory
Level 1
Level 1

You need to enter the command "management" under the interface vlan 2 for the management vlan to become active. Then your ip address under vlan 2.

Remember to add the default gateway statement as a global command back to your default router (backbone).

Hope this helps!