Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

mcast question

I have a cat5500 with an RSM and several vlans that I'm trying to use to multicast video from an IP/TV server cluster. I think I have the switch and RSM configured properly, but the RSM won't forward the IGMP membership report packets from the client vlan to the server vlan. I have igmp enabled on the cat:

#igmp

set igmp fastleave enable

!

and here's relevant config from the RSM:

ip multicast-routing

!

interface Vlan60

description SON vlan60: User60

ip address 10.2.60.8 255.255.255.0

no ip redirects

no ip directed-broadcast

ip pim sparse-mode

no ip route-cache cef

no ip mroute-cache

mls rp vtp-domain SON

mls rp ip

standby 1 priority 100 preempt

standby 1 ip 10.2.60.10

!

interface Vlan120

description SON vlan120: 4th-labs

ip address 10.1.120.8 255.255.255.0

no ip redirects

no ip directed-broadcast

ip pim sparse-mode

no ip route-cache cef

ip cgmp

no ip mroute-cache

mls rp vtp-domain SON

mls rp ip

standby 1 priority 100 preempt

standby 1 ip 10.1.120.10

!

Any help would be appreciated.

Rich

1 REPLY
Cisco Employee

Re: mcast question

IGMP messages are not forwarded from one VLAN to another. You see you have configured PIM sparse-mode. I assume you have a Rendez-vous point then. Right? If this is just for a test then you could use dense mode to propagate multicast between the two VLANs.

Hope this helps.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
96
Views
0
Helpful
1
Replies
CreatePlease to create content