cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
384
Views
0
Helpful
1
Replies

Mobile IP Configuration

dustin.yates
Level 1
Level 1

I'm trying to test Mobile IP in a lab. It's a simple set up:

Foreign Agent LAN---R5----Frame Relay----R4-----Home Agent LAN

However, I keep getting a rejected message out of debug ip mobile on R5 when I move a machine to that subnet. Anyone have this working that could review the following code to see what I've missed? TIA!

version 12.2

hostname R4

interface Loopback0

ip address 155.10.4.4 255.255.255.0

!

interface FastEthernet0/0

ip address 155.10.44.4 255.255.255.0

duplex auto

speed auto

ipx network 4

ipx output-gns-filter 1000

!

interface Serial0/0

ip address 155.10.45.4 255.255.255.0

encapsulation frame-relay

ip split-horizon

ipx network 40

frame-relay map ipx 40.0004.0004.0004 304

frame-relay map ipx 40.0005.0005.0005 304 broadcast

frame-relay map ip 155.10.45.4 304

frame-relay map ip 155.10.45.5 304 broadcast

no frame-relay inverse-arp

!

router mobile

!

router igrp 45

redistribute mobile metric 56 100 255 1 1500

network 155.10.0.0

!

ip mobile home-agent

!

end

R4#

R5#sh run

version 12.1

hostname R5

interface Loopback0

ip address 155.10.5.5 255.255.255.0

!

interface Ethernet0/0

ip address 155.10.25.5 255.255.255.0

ip mobile foreign-service

ipx network 50

!

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

!

interface Serial0/0.45 point-to-point

ip address 155.10.45.5 255.255.255.0

ipx network 40

frame-relay interface-dlci 403

!

router mobile

!

router igrp 45

redistribute ospf 1 metric 56 100 255 1 1500

passive-interface default

no passive-interface Serial0/0.45

network 155.10.0.0

!

ip mobile foreign-agent care-of Loopback0

!

!

end

R5#

R5#debug ip mobile

IP mobility events debugging is on

R5#u all

MobileIP: Ethernet0/0 add 155.10.44.100 rejected

1 Reply 1

ciscomoderator
Community Manager
Community Manager

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: